• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v5 Wrong landclass returned

Messages
38
Country
unitedstates
This may be long winded.....sorry.

I am working on some sloped runways now that it's available in P3D. I chose some airports with significant slope to practice on. It's going pretty well. The grass runways are much easier to get right, but with work hard surface runways are doing pretty well also.

While doing all of this I was dressing up the immediate area around a particular airport when I discovered that when assigning "Dirt" landclass to an area (ADE), the simulator returns a high-rise city, not dirt. It is the only one I have found that is obviously wrong. I went into the terrain.cfg file fully expecting to find the problem only to find that is appears OK. I am fully convinced this is not an ADE problem as it does perfectly with every other landclass I have used. I also double-checked the guide in the shapePolylist to ensure it was the same as the terrain.cfg file. It was. I went through terrain.cfg files all the way back to FSX and they are all the same for the "Dirt" landclass. In the .cfg the "DIRT" texture is properly identified, but the compilation doesn't return dirt. It returns a big city.

So...my question is this. How does FSX/P3D call the appropriate textures for a particular landclass? Is there some lookup table somewhere? How can I get "DIRT" to actually return the dirt texture?
 
Top