• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

yoke animation lag

Messages
44
Country
italy
Hi all,
I have done in blender a yoke animation with length 100 , ( frame 50 as "0" position )
in the sim works , but I have a lag specially in LR moving. A little bit less in forward / back move.

my xml code is :
<UseTemplate Name="ASOBO_GT_Anim_Code">
<ANIM_NAME>HANDLING_YOKE_Lever_StickLR</ANIM_NAME>
<ANIM_CODE>(A:YOKE X POSITION,percent) 50 +</ANIM_CODE>
<ANIM_LENGTH>100</ANIM_LENGTH>
</UseTemplate>

<UseTemplate Name="ASOBO_GT_Anim_Code">
<ANIM_NAME>HANDLING_YOKE_Lever_StickForeAft</ANIM_NAME>
<ANIM_CODE>(A:YOKE Y POSITION,percent) 50 + </ANIM_CODE>
<ANIM_LENGTH>100</ANIM_LENGTH>
</UseTemplate>

I don't understand why I have these lag in movement.
thanks
 
You can try adding a <ANIM_LAG>0</ANIM_LAG> element to ensure there is no lag

But your other problem is the yoke positions return values from -100 to +100 and your animation is only going to show -50 to +50. Half of your yoke movements will do nothing because you have hit the limits. I don't know if this is the problem you are seeing.

The following will show the full range of motion by scaling the yoke position down to -50 to +50.

<ANIM_CODE>(A:YOKE X POSITION,percent) 0.5 * 50 +</ANIM_CODE>
 
Hi Anthony31
Thanks for your reply. I tried but doesn't work as expected
for example I speak about one axis ( LEFT/RIGHT ) I tryed:
1) animation with 100 frames total , frame 0 left , frame 50 neutral , frame 100 right , and <ANIM_LAG>0</ANIM_LAG>, <ANIM_CODE>(A:YOKE Y POSITION,percent) 50 + </ANIM_CODE> = animation with lag
2) animation with 100 frames total , frame 0 left , frame 50 neutral , frame 100 right , and <ANIM_LAG>0</ANIM_LAG>, <ANIM_CODE>(A:YOKE Y POSITION,percent) 0.5*50 + </ANIM_CODE> = animation with lag
3) ( test just to change something ) animation with 200 frames total , frame 0 left , frame100 neutral , frame 200 right , and <ANIM_LAG>0</ANIM_LAG>, <ANIM_CODE>(A:YOKE Y POSITION,percent) 100 + </ANIM_CODE> = animation with lag

strange.....
 
Sorry but I can't be much more help. The only thing I could suggest is to make sure your animation in Blender is linear (use the graph editor to check). By default Blender uses curves which doesn't give straight animation.

OR

don't use the Yoke parameter. Personally I animate my joysticks with Aileron and Elevator Position. If you use Simvars to monitor Yoke X Position, Yoke X Indicator and Aileron Position you may notice that Yoke X Position doesn't always return the same values as the other two.
 
Did you find a solution for it ?

I'm having the same issue also using the standard ASOBO template "ASOBO_HANDLING_Yoke_Template"
 
Back
Top