P3D v4 Adding custom made objects to the scenery removes autogen

#1
Hi guys!
I am trying to add some custom created 3d objects to my scenery, but when i do so, autogen disappearing somehow. Bounding boxes are ok, so not them are the problem.
What are your thoughts about this?
Thx!
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

What kind of objects are you adding? If their bounding box is very big that will suppress the autogen.

There is a no autogen suppression option you can add while placing the objects.
 
#3
Hi, @arno! I have created many objects so far, and no matter which one i chose to add to scenery, it cuts out autogen.
And yes, i convert my MDL exported files from max to BGL with MCX, and i am aware of "No autogen suppression" checkbox, and i do check it everytime.
But how you can see from attached screenshot, the size of bounding box are not that big to have problems with it even if i don't check no autogen suppression checkbox when i convert files.
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
Hi,

What you are looking at is the crashboxes. As you can see the origin is very far from the object (you see the grid in the background). This means that the object actually has a huge bounding box. It is better to move the object so that it is centered on the origin.
 
#5
But the button that enables this box in MCX is entitled as "Display boundingbox", and you can see crashboxes in next attached screenshot.
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#6
Ah, right, sorry my mistake.

But inside the scenery engine an object that is far from the origin does suppress more autogen. The bounding box as shown in MCX is calculated from the geometry of the object.

Just try the difference when you move your object so that it is centered around the origin.
 
#8
The problem persist. I have made a simple cube and placed it and the same thing happens. And if i delete the BGL, and reload scenery, autogen still doesn't appear. Only after i remove completely scenery from sim and afterwards add it again, autogen appears normally. Maybe something with the sim?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#9
There might be another BGL file in your scenery that is still suppressing the autogen in that case.
 
#10
But i left in the scenery only ADE files, custom mesh and phototerrain bgl. And when i add another bgl, no matter what it contains... well, you know already.
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#11
ADE can also place objects and create ground polygons. So also ADE made file can have an effect on the autogen. Probably best to try to isolate which file is causing it, so that you can continue source for the object that does it.
 
#13
Hi! So, i reinstalled my sim, and the problem was still there. So i added the scenery without ADE files, and seems like here was the problem, because there was a big exclusion rectangle, that i cannot see because in ADE view tab view exclusions was unchecked. So that was my fault. Sorry for taking your time, and thank you one more time.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#14
Glad to hear you solved it. It can sometimes be complex to find the cause of an issue indeed.
 
Top