ADE 1.77.7018 Beta

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#1
This is the latest development build for ADE. It includes the fix kindly made by Don (gadgets) to his code for the error reported for the last build related to Ground Polys for P3Dv4.4. There are two update packages available
Reminder
  • If you are installing the full beta for the first time then install it separately from any production version.
  • Under no circumstances un-install your current production version. Run the beta side by side with the production version
  • The detailed footprint database is not shipped with the beta so please copy it from your existing installation
  • If you are a ProKey User then you will need to copy prokey.dll from your production installation into the beta so that you have the ProKey features available in the beta.
 
#2
Not sure I dare :stirthepo!
It is one thing to stay updated but another thing when you are working on something and have things go wrong because of a new beta version (though called earlier on an alpha one?).
If I would know how to use it separately from my 1.76 version I would try it and could help debugging but it is a bit too complicated/time encompassing for the moment.
Just a suggestion: make sure the transition to a newer version is made easier (I already have 3 versions stored and for some things I need previous ones!) and call it experimental or something (seen the updates and problems) whilst awaiting the outcome from the users.
Just a hint to make more users download and use the newest.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#3
Roby. No one has to install and run a beta. There are only two version of ADE at any one time. The current production version which is 1.76 and the development version 1.77 There is no pressure on anyone to use the latest development version (I am going to stop calling it a beta from now on). I am sorry but I think I am missing the meaning of your post.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#10
I can see some fatal errors related to license code and being able to create the main ADE form. These appear early in the log and it seems they cleared when you ran ADE again. Sadly there are no references in the log to a failed compile. Neither can I find any place in the code that specifically refers to devices. I assume this is replicable?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#12
OK this is the error:

1553766066252.png


I can't explain why in your case Windows is reporting this - the error is a WinIO error. The code is indicating that ADE is trying to check that the CompileTo location is accessible. It does that by trying to write to the specified folder. If that fails it means the folder is in use say by the sim or is a UAC locked folder. In this case the folder is shown at the top. This doesn't seem to be the folder defined by your settings for the compile to location:

1553766435876.png


The Compile To folder in your screenshot suggests the compile to folder is different than either mentioned already. This may be because it is defined specifically for a given project. This does not explain why it is happening but perhaps you can create a simple project file and try to compile that to the default compile folder you set in Settings > Options > Project Tab. This is what mine looks like for example and these settings are used for projects by default unless you set something different specifically for a project


1553766687888.png
 
#14
Hello,

Just a little bug not annoying but something to be aware of. In the GP Texture Editor, if you give a name with only numbers to a Line Style Definition, ADE crashes.
Hopefully it asks for saving before crashing.

Thanks for all your work !!!
 
Last edited:
#16
Hi,

On my FS9 Test/Editing PC, which runs WinXP x86, I have ADE 1.71.6177.24088 with Pro key, I think one of the last to run on an x86 OS.
With these newer versions (v1.75 and later), am I missing out on some important stuff for FS9?
Or are all new updates mainly FSX and P3D related?

Regards,
DDP.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#17
Not all updates aren't specifically related to FSX/P3D. some are but many are bug fixes or general enhancements. If you have no issues with earlier versions (e.g. 1.70) then use that. We stopped supporting XP a while back due to x32 and x64 OS issues
 
#18
Hi there ... i am a new user to this program. I installed version ADE 177.7018
I just finished my hometown airport (LGLR) for P3D4.5 and everytime i try to "compile" it, i get this weird error.



Compiler Errors Found. These were not identified by the Issue Manager. Please let us know
what the compiler error is so that we can improve the Issue Manager.

The compiler message is shown below

ScruffyDuck Scenery Design Engine Compiling
Using BglComp....


Parsing document: E:\177_6986\!AdeTempWorkOnly\LGLR_MITSOS.xml

INTERNAL COMPILER ERROR: #C2528:
***** Duplicate Frequency *****
INTERNAL COMPILER ERROR: #C2031: Failed element parse <Com>
INTERNAL COMPILER ERROR: #C2032: XML Parse Error! Element tree follows:

ERROR: <FSData
ERROR: version = 9.0
ERROR: >
ERROR: <Airport
ERROR: country = Greece
ERROR: city = Larissa
ERROR: name = Larissa
ERROR: lat = 39.6490361906153
ERROR: lon = 22.4618270586272
ERROR: alt = 232.999F
ERROR: magvar = 4
ERROR: trafficScalar = 0.7
ERROR: airportTestRadius = 5000.0M
ERROR: ident = LGLR
ERROR: >
ERROR: <Com
ERROR: frequency = 120.5500
ERROR: type = APPROACH
ERROR: name = LARISA
ERROR: >
ERROR:
INTERNAL COMPILER ERROR: #C2528:
***** Duplicate Frequency *****
INTERNAL COMPILER ERROR: #C2031: Failed element parse <Com>
INTERNAL COMPILER ERROR: #C2032: XML Parse Error! Element tree follows:

ERROR: <FSData
ERROR: version = 9.0
ERROR: >
ERROR: <Airport
ERROR: country = Greece
ERROR: city = Larissa
ERROR: name = Larissa
ERROR: lat = 39.6490361906153
ERROR: lon = 22.4618270586272
ERROR: alt = 232.999F
ERROR: magvar = 4
ERROR: trafficScalar = 0.7
ERROR: airportTestRadius = 5000.0M
ERROR: ident = LGLR
ERROR: >
ERROR: <Com
ERROR: frequency = 122.1000
ERROR: type = APPROACH
ERROR: name = LARISA
ERROR: >
ERROR:
INTERNAL COMPILER ERROR: #C2528:
***** Duplicate Frequency *****
INTERNAL COMPILER ERROR: #C2031: Failed element parse <Com>
INTERNAL COMPILER ERROR: #C2032: XML Parse Error! Element tree follows:

ERROR: <FSData
ERROR: version = 9.0
ERROR: >
ERROR: <Airport
ERROR: country = Greece
ERROR: city = Larissa
ERROR: name = Larissa
ERROR: lat = 39.6490361906153
ERROR: lon = 22.4618270586272
ERROR: alt = 232.999F
ERROR: magvar = 4
ERROR: trafficScalar = 0.7
ERROR: airportTestRadius = 5000.0M
ERROR: ident = LGLR
ERROR: >
ERROR: <Com
ERROR: frequency = 120.5500
ERROR: type = TOWER
ERROR: name = LARISA
ERROR: >
ERROR:
INTERNAL COMPILER ERROR: #C2528:
***** Duplicate Frequency *****
INTERNAL COMPILER ERROR: #C2031: Failed element parse <Com>
INTERNAL COMPILER ERROR: #C2032: XML Parse Error! Element tree follows:

ERROR: <FSData
ERROR: version = 9.0
ERROR: >
ERROR: <Airport
ERROR: country = Greece
ERROR: city = Larissa
ERROR: name = Larissa
ERROR: lat = 39.6490361906153
ERROR: lon = 22.4618270586272
ERROR: alt = 232.999F
ERROR: magvar = 4
ERROR: trafficScalar = 0.7
ERROR: airportTestRadius = 5000.0M
ERROR: ident = LGLR
ERROR: >
ERROR: <Com
ERROR: frequency = 122.1000
ERROR: type = TOWER
ERROR: name = LARISA
ERROR: >
ERROR:
INTERNAL COMPILER ERROR: #C2607: Compilation errors detected, compilation failed!


Parse complete!
( please help me, how can i fix this? )


EDIT: I fixed it, it was the wrong radio frequencies by default ..... (hmmm, :confused: microsoft got it ALL WRONG in this airport)
 
Last edited:
Top