• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS ADE 2020 Alpha 21 HotFix 3

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
This is a cumulative patch for ADE 2020 Alpha 21 and should only be used to patch that version.

Updated
  • Removed surface attribute from painted lines due to issues with SU6
  • Changed decompiler for Bgl to that created by Patrick Germain
  • Handling of Open Read Only Files.
  • Project Properties Package Version is now editable
  • Taxi Name is now shown in the property grid for Taxi paths as well as the Name Index. This is a partial change and future version should use names and not indexes when editing the properties
Fixed
  • Compiler error with parking spot names
  • Problem adding library objects to LOM. This fixes issues in adding libraries to the LOM - it also improves updating existing libraries where changes have occurred. Options to load Folders have been disabled for the time being
  • Server side problem that caused CTD when checking for version.
Removed
  • Removed access to load last project option. This option code has not been updated for ADE 2020 and will cause projects to be rendered unusable. May be re-instated at a later date
Download from link below and follow the instructions for installing a patch: http://scruffyduck.org.uk/ade_2020_help/Process1.html


Version is 20.21.7997

Also note that SU7 made changes to the stock airports available - added some and removed others. You can update ADE so that it will allow you to edit these new stock airports. To do this open ADE and Select Tools >Update Stock Indexes

1637663993986.png


Click the Scan Button and the update will take place After a short while the job will report done and you can close the dialog

1637664143829.png


Close and restart ADE and the airport list will be updated to reflect the latest stock records

Use Tools > Lookup Airport to see some information

1637664421713.png


There is now a list of new airports available which will be posted shortly
 
Last edited:
Messages
134
Thank you Jon, I've been checking daily for a fix for the LOM missing libraries and look forward to checking this out.

Excellent, no problem adding the following modellib files manually and re-launching ADE20 twice to verify the selection sticks:
asobo-modellib-airport-generic
asobo-modellib-buildings
asobo-modellib-props
 
Last edited:

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,344
Country
us-wisconsin
I got an error adding Patrick AFB to the LOM. This is a new airport in SU7 I believe.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
I got an error adding Patrick AFB to the LOM. This is a new airport in SU7 I believe.

I am getting them as well Dick - They are comings from Arno's code and I need to check with him. It is new
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
Thank you Jon, I've been checking daily for a fix for the LOM missing libraries and look forward to checking this out.

Excellent, no problem adding the following modellib files manually and re-launching ADE20 twice to verify the selection sticks:
asobo-modellib-airport-generic
asobo-modellib-buildings
asobo-modellib-props
Thanks Dan
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,344
Country
us-wisconsin
I don't know how hard this would be to implement. Could the LOM be run outside of ADE to cycle through the Official folder, find the ModelLib bgls and update them. Then optionally copy that output to the ADE folder. That way, after an Asobo update, we could have ADE optionally update the LOM while we sleep. 😴
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
I don't know how hard this would be to implement. Could the LOM be run outside of ADE to cycle through the Official folder, find the ModelLib bgls and update them. Then optionally copy that output to the ADE folder. That way, after an Asobo update, we could have ADE optionally update the LOM while we sleep. 😴
I will look but it is pretty well embedded. There is a crawler function that never got properly implemented. Actually I have an updated base set of data which I manually keep up to date. LOM handles the data and footprints but thumbnails are done with MCX

EDIT

Not all model bgl files are called ModelLib so ADE would have to read nearly all bgl files to find models. That would probably take several days!
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,344
Country
us-wisconsin
The app named Everything finds them quickly with this search string: ext:bgl D:\MSFS\Official\ case:content:"ModelInfo guid"

It searches only BGLs in Official (and subfolders), and they must contain the string "ModelInfo guid"
 

Attachments

  • BGLs.txt
    7 KB · Views: 42

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
The app named Everything finds them quickly with this search string: ext:bgl D:\MSFS\Official\ case:content:"ModelInfo guid"

It searches only BGLs in Official (and subfolders), and they must contain the string "ModelInfo guid"

So it does. I have used Everything for years but never got into complex searches. I just tested your search string here and got the list from the MS Official folder. So if I read through that text file and feed the paths into the LOM it should work

EDIT

There are some in the list that I had missed in my manual work :(
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,344
Country
us-wisconsin
SimObjects are tricky.

wholeword:sim D:\MSFS\Official\ content:title=

There seem to be some errors on Asobo's part. For example, we find D:\MSFS\Official\Steam\aerosoft-paderborn\SimObjects\Landmarks\EDLP_Jetway_Type_A\sim.cfg and D:\MSFS\Official\Steam\aerosoft-paderborn\SimObjects\Landmarks\EDLP_Jetways\sim.cfg which also contains a EDLP_Jetway_Type_A, with it's own models (with LODs) and shares the same GUIDs. Not a good practice, and could lead to errors in the sim. There are others.
 

Attachments

  • SimObjects.txt
    7.6 KB · Views: 42
Last edited:
Messages
497
Country
australia
So I read all this and my eyes glossed over…Brain shutdown from dinner and a 🍷 What is the net outcome of all this? I still have objects that are stock that don’t appear back in ADE (2way) other than black boxes. I’ve added my ModelLib stuff ok but standard Asobo items which I assume must be added via the LOM?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
This is a bug fix for something I broke between Alpha 20 and Alpha 21. You are correct that if you get black boxes in ADE then it cannot find any information about the object in the LOM. The bug fixed was to stop the LOM crashing when adding new libraries. The fix did not update the LOM with missing stock items so you may need to load the relevant libraries into the LOM yourself.

We are looking at a way to provide data for stock objects as part of future patches or updates
 
Messages
80
Country
us-northcarolina
So I read all this and my eyes glossed over…Brain shutdown from dinner and a 🍷 What is the net outcome of all this? I still have objects that are stock that don’t appear back in ADE (2way) other than black boxes. I’ve added my ModelLib stuff ok but standard Asobo items which I assume must be added via the LOM?
If you haven't already, you probably need to add these to the LOM as mentioned before:
asobo-modellib-airport-generic
asobo-modellib-buildings
asobo-modellib-props
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
Thanks

I have them added to the base object list which will be released either with a hot fix or with the next version update
 
Messages
497
Country
australia
If you haven't already, you probably need to add these to the LOM as mentioned before:
asobo-modellib-airport-generic
asobo-modellib-buildings
asobo-modellib-props
Thanks - Any idea which one has the EDLP stuff in it? A few items still don't appear such as
EDLP_Antenna_House_001 <LibraryObject name="{8FF8B811-0C2B-4B8D-8E7A-964717D9F5A1}"

Also Dick - I remember you create or had a file with all the thumbnails. Is there one for the base stuff in these libraries? I'd love to be able to search the thumbnails by 'something' rather than in DEV or scrolling through a PDF or whatever. Any ideas? If I know how, I'd write something myself to parse the BGLs but it probably already exists...
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
Hi guys,
after applying the hotfix ADE won't start/open. Before the hotfix, it opened properly. What can this be?

If you want help then you need to provide more information. Do you get an error message, if so then screenshot(s) would help. Also provide the log.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
Thanks - Any idea which one has the EDLP stuff in it? A few items still don't appear such as
EDLP_Antenna_House_001 <LibraryObject name="{8FF8B811-0C2B-4B8D-8E7A-964717D9F5A1}"

Also Dick - I remember you create or had a file with all the thumbnails. Is there one for the base stuff in these libraries? I'd love to be able to search the thumbnails by 'something' rather than in DEV or scrolling through a PDF or whatever. Any ideas? If I know how, I'd write something myself to parse the BGLs but it probably already exists...

I have a set of thumbnails for most of the stock objects. MCX generates them easily enough. Parsing a bgl file for what?
 
Messages
497
Country
australia
Parsing a bgl file for what?
No idea. Was just floating a nothing idea I guess. I was thinking on my second screen having all the thumbnails displayed and searchable so I can find and simply place. Sounds a bit opulent I know. Maybe the LOM could be a floating window?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,677
Country
unitedkingdom
when you add a library object the add dialog shows thumbs and is searchable
 
Top