• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

ADE ADE Version 1.79.7410 Dev is released. Supports P3D v5

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
This version is now avaiable from here: https://www.mediafire.com/file/i6xk38ghqjomykp/ade_current_dev.zip/file This is the same link as the earlier 1.79 dev.

This version has the following changes
  • Support for P3D v5
  • Removes support for P3D v2 and v3
  • Some minor bug fixed
INSTALLATION

Please do follow this information.
  • If you have an earlier version of 1.79 then please update it. Only create a new installation if this is the first time install for 1.79
  • If you are updating then it is highly recommended that you backup the existing installation. This zip contains a simple backup utility that will do this for you.
  • If you are creating a new installation please don't use the Settings Import function. Start clean
To update change the destination directory to the current 1.79 installation

1587020450975.png


If the installation does go wrong for any reason restore the previous 1.79.7401 installation and report the issue here
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
I will provide some notes on changes in this version as soon as I can.

Sloped Airports

There are properties in Airport, Apron, Taxipoint. Taxisign, Parking and Taxipath.

Airport

1587022424558.png


the sloped flag needs to be checked for sloped airports. My understanding is that rendering sloped airports is slower than non. They may have improved this

Apron

Three properties - altitude, flatten and SurfaceQuery

1587022581328.png

Taxi path

Flatten and SurfaceQuery

1587022712747.png


Taxi Point
Just Altitude

1587022860847.png


Parking

Altitude

1587022913486.png


Sign

Sign has the most new properties and they are accessed via a button on the property dialog

1587022985538.png


1587023011791.png
 
Last edited:
Messages
26
Country
italy
Hi Jon,
thanks for the update!
I have, however, one big error:

First one:
I've just open stock LIMC airport, set it sloped and removed the background airport polygon, when I compile I get the following error:

XML:
Compiler Errors Found. These were not identified by the Issue Manager. Please let us know
what the compiler error is so that we can improve the Issue Manager.

The compiler message is shown below

ScruffyDuck Scenery Design Engine Compiling
Using BglComp....


Parsing document: C:\MSFS\FS Design Tools\Airport Design Editor 179 Dev\!AdeTempWorkOnly\LIMC_ADEP5_RL.xml

INTERNAL COMPILER ERROR:  #C2033: XML Parse Error (line, column, error)

ERROR: 9556, 32, "12" violates enumeration constraint "NDB COURSE_TO_DIST COURSE_TO_ALT HEADING_TO_ALT MANUAL_TERMINATION TERMINAL_NDB TERMINAL_WAYPOINT VOR WAYPOINT RUNWAY LOCALIZER".

Impossible to analyze "fixType" with value "12".

INTERNAL COMPILER ERROR:  #C2950: Invalid fixType tag (12).
INTERNAL COMPILER ERROR:  #C2031: Failed element parse <Transition>
INTERNAL COMPILER ERROR:  #C2032: XML Parse Error!  Element tree follows:

ERROR: <FSData
ERROR:     version = 9.0
ERROR: >
ERROR:     <Airport
ERROR:         country = Italy
ERROR:         city = Milan
ERROR:         name = Malpensa
ERROR:         lat = 45.629999935627
ERROR:         lon = 8.72305557131767
ERROR:         alt = 234.086M
ERROR:         magvar = -1
ERROR:         trafficScalar = 0.7
ERROR:         airportTestRadius = 5000.0M
ERROR:         sloped = TRUE
ERROR:         ident = LIMC
ERROR:     >
ERROR:         <Approach
ERROR:             type = GPS
ERROR:             runway = 00
ERROR:             designator = NONE
ERROR:             suffix = D
ERROR:             gpsOverlay = TRUE
ERROR:             fixType = RUNWAY
ERROR:             fixRegion = LI
ERROR:             fixIdent = BLA5L
ERROR:             altitude = 1828.8M
ERROR:             heading = 0
ERROR:             missedAltitude = 0.0M
ERROR:         >
ERROR:             <Transition
ERROR:                 transitionType = FULL
ERROR:                 fixType = 12
ERROR:                 fixRegion = LI
ERROR:                 fixIdent = RW35L
ERROR:                 altitude = 353.568M
ERROR:             >
ERROR:

ERROR: 22080, 0, Validation failed.

INTERNAL COMPILER ERROR:  #C2430: Unrecoverable error parsing XML!
INTERNAL COMPILER ERROR:  #C2006: Parse failed  (0x80004005)
INTERNAL COMPILER ERROR:  #C2003: Failed to process file: C:\MSFS\FS Design Tools\Airport Design Editor 179 Dev\!AdeTempWorkOnly\LIMC_ADEP5_RL.xml

I reported only one of the many of this same error, I guess something went wrong with processing SID/STARS ?
I have no clue on that since I never used approach function.

There is also a minor error, ADE seems not to support the 8.33 Khz spacing that was introduced in P3D V5, this generate a minor report that can be fixed with the "fix errors" button, that however does not resolve the XML SID/STAR problem.

ADDENDUM #1: I tried to open some approaches in the approach mode, ADE tells me he cannot draw them, moreover, all "GPS" approaches are linked to "runway 00", which, obviously, is not a LIMC runway.

ADDENDUM #2: Deleting every SID/STAR from the approach mode made ADE compile the airport, might be that SID/STAR function is not yet implemented in ADE ?

Looking forward for help!
Thanks!
 
Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
Please post your project file here and also confirm what SDK version you are using
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
You are correct that ADE does not yet support the 8.33 Khz spacing
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
OK - I am getting the error you report. I will need to investigate this as it seems some elements may not be properly implemented
 
Messages
26
Country
italy
Please post your project file here and also confirm what SDK version you are using

SDK version is 5.0.21.34709

I've read you are getting the same report, I will avoid posting my AD4 file as it will not give the same error since approaches have been deleted.

Looking forward for a solution, I'am available if you need some testing.
Thanks again for your hard work, we much appreciate it!
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
I am looking at it now. It's not obvious, I may need to ask LM
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
OK it seems the SDK docs may not be up to date against the compiler schema

Schema

<xs:simpleType name="stFixType">
<xs:restriction base="xs:string">
<xs:enumeration value="NDB" />
<xs:enumeration value="COURSE_TO_DIST" />
<xs:enumeration value="COURSE_TO_ALT" />
<xs:enumeration value="HEADING_TO_ALT" />
<xs:enumeration value="MANUAL_TERMINATION" />
<xs:enumeration value="TERMINAL_NDB" />
<xs:enumeration value="TERMINAL_WAYPOINT" />
<xs:enumeration value="VOR" />
<xs:enumeration value="WAYPOINT" />
<xs:enumeration value="RUNWAY" />
<xs:enumeration value="LOCALIZER" />
</xs:restriction>
</xs:simpleType>

SDK Docs


NDB
TERMINAL_NDB
TERMINAL_WAYPOINT
VOR
WAYPOINT

I am checking with LM
 
Messages
3
Country
nigeria
Hello,
Am getting the following error when I try to load a stock airport. Am using the ADE version you posted above and SDK 5.0.21.34709. clean installation with no settings imported.
Desktop Screenshot 2020.04.16 - 12.20.34.15.png
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
thanks looks like a file is missing from the installer. I will try and fix it today
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
Hello,
Am getting the following error when I try to load a stock airport. Am using the ADE version you posted above and SDK 5.0.21.34709. clean installation with no settings imported.
View attachment 56648

This link contains files which should fix this error: https://www.mediafire.com/file/4fa58f95gpn3mml/179_7410_missing_files.zip/file

One or more of these may be missing from the 179_7410 installer. Make a backup of the 179_7410 installation then copy the files in the zip into the installation. This should fix the missing file issue - hopefully
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
You are welcome. I will update the main installer as soon @as I can
 
Messages
115
I have copied the said missing files which has stopped the error when loading stock airports, however ADE is getting freeze during loading when opening some stock airports, VTBS for one.
 
Messages
17
Country
brazil
I have copied the said missing files which has stopped the error when loading stock airports, however ADE is getting freeze during loading when opening some stock airports, VTBS for one.

Same here.

EDIT: Correction, it took a long while, but it opened the airport in the end.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,081
Country
unitedkingdom
The slow load may be due to creating detailed footprints for new objects found in v5. We updated the database but probably did not find all of them. I will try and get an updated database in the next release. Meantime it is normal behavior and as objects are processed load times will improve to normal
 
Messages
115
I tried modifying one stock airport and update another afcad bgl of previous p3d version, both caused holes in the ground. I tried looking through xml and they had some taxiway points and parking at 0.0 altitude. Since this didn't cause any anomaly in p3d v4, I presume in v4 alt of 0.0 was taken as AGL while v5 is taking it msl and sinking it below ground. Manually changing these altitudes to airport elevation fixed the hole in airport. Interestingly directly using v4 afcad in v5 didnt cause any problems, but seem to be causing the to sim crash on approach.
 
Top