• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS AIFP for MSFS

gadgets

Resource contributor
It would be helpful if someone could translate the error message.

In any case, AIFP expects to find MSFS aircraft in either the Official or Community folders in standard Asobo folder/file format.
 
It just says 'click next to ignore the error', and as he states the Official/OneStore folder does not exist if you have the steam edition, which supposedly is what the program is looking for. For Steam it is Official/Steam instead.

I can't verify since I bought on the Microsoft store.
 

gadgets

Resource contributor
Surely there's a description of the error as well. Can you provide a translation of the full message.
 

tgibson

Resource contributor
I.e. if you click the Details button there will be more information there, above the "Loaded Modules" which I assume isn't important.
 
It just says 'click next to ignore the error', and as he states the Official/OneStore folder does not exist if you have the steam edition, which supposedly is what the program is looking for. For Steam it is Official/Steam instead.

I can't verify since I bought on the Microsoft store.
Tjoeker is perfectly right.
The error message is generated by my German Windows, sorry.

Here is the google translation of the message:
Unhandled exception in the application. Click on "Next" to ignore the error and continue the application. If you click "Exit", the application will exit immediately.
Part of the path "E: \ SteamLibrary \ Official \ OneStore" could not be found.


Upon clicking "Next" the empty aircraft list is shown:
1602824270081.png
 

gadgets

Resource contributor
The important part of the message was the sentence before 'click next to ignore the error'.

Development Release 3.4.0.7 just posted

Thanks for reporting jdiegel. That should not happen regardless of the folder structure.
 
Hi, thanks for the update.
The error message doesn't appear any longer and the selection of aircraft works perfectly.
However, even after carefully reading chapter 4.8 and eliminating any FS 2020 generated traffic I wasn't successful up to now in creating my own traffic.
I selected standard Asobo A320neo, made a flight plan for Aerosoft EDLP, 24hrs, Take Off at 1000UTC, two legs from EDLP to EDLP. I'm quite sure the airport fullfills all prerequisites as parkings, taxi and runway paths, links, hold shorts etc.
AIFP creates a traffic package in the community folder. Anything looks as expected, but the aircraft won't show up.
May be there is annother issue with the steam version. Could you provide a configuration (aircraft, airport, flight plan etc.) which I could try?
Sorry for my impatiance,
Regards, Joachim
 

gadgets

Resource contributor
Since I don't have the Steam version, sending you a FP that works on the MS version would prove nothing. It would be better if you posted your traffic file so that I can attempt to determine where the problem lies.
 

gadgets

Resource contributor
Others have reported that only IFR FPs work with MSFS. Also, while it's not normally a problem, I'd suggest you use two airports and assign flight numbers - just in case ...

Otherwise, the Traffic file looks fine.
 
Thanks for reviewing my traffic file.
In the past days I desperately tried a lot of combinations: two airports, flight number, IFR FP, different airports, different aircraft, switched off any autogen AI-Traffic.
No way to see any self generated AI-Traffic, not even to see my selected AI aircraft parking. What am I doing wrong?
 

gadgets

Resource contributor
What am I doing wrong?
That's an impossible question to answer other than to say that whatever you are doing is not producing the intended result.

I have confirmed that your traffic file is OK and suggested a couple other things you should try, I'd have to be on your system to diagnose further. Since I'm not, I can only rely on you to tell me what's wrong.

Did the traffic file install properly in MSFS, i.e., in \Community\Custom AI Traffic\scenery\world\traffic? That's where traffic files get installed in the MS Store version. If the Steam version requires it be installed elsewhere, someone has got to tell me. Are you looking in the right place at the right time? Are your traffic sliders set appropriately? Does the same FP (with a different aircraft. of course) run on P3D or FSX?
 
The 'Mounting for MSFS 2020' function of AIFP exactly places the traffic bgl in E:\steamlibrary\Community\Custom AI Traffic\scenery\world\traffic. Any other addon placed in the commuity folder is working fine. I think the Steam version is not the problem.
My settings:
General/Graphics:
- USING GENERAL PLANE MODELS (AI TRAFFIC): OFF (as recommended in the thread before)
- USING GENERAL PLANE MODELS (MULTIPLAYER): OFF
General/Traffic:
- AIRCRAFT TRAFFIC TYPE: AI OFFLINE
- AI AIRLINERS TRAFFIC DENSITY: 50% (tried many settings)
- AI GEENERAL AVIATION TRAFFIC DENSITY: 50% (tried many settings)
- GROUND AIRCRAFT DENSITY: 50% (tried many settings)
My last trials were with version 3.4.11. I tried with German or Italian airports having 'Ramp' type parkings. One MSFS stock airplane. Take off time 10:00 UTC. IRF and VFR. Set the 'Time' slider to 09:58 UTC. Watch the scenery using the drone. Never saw an AIFP planned aircraft parking, being pushed back, taxiing to the hold and runway, and taking off.
I believe AIFP is doing all right. I suspect the airports I have selected may not provide the prerequisites for custom AI. Since using AIFP for P3DV4 on self created airports (using ADE) I know there must be the right parkings, taxi links, hold shorts, links to RWY center line etc. The SDK does not seem to allow a look inside stock airports.
Does anyone have a simple working flight plan? Either a .bgl to placed in the /F20 folder and to be mounted by myself, or a ready MSFS package to be placed in the community folder?
Thanks in advance,
Joachim
 
- AI AIRLINERS TRAFFIC DENSITY: 50% (tried many settings)
- AI GEENERAL AVIATION TRAFFIC DENSITY: 50% (tried many settings)
These should be at 100% unless you changed it in AIFP.

I'll see if I can get you a flightplan using the standard models.

- GROUND AIRCRAFT DENSITY: 50% (tried many settings)
I personally prefer this to be at 0 as I don't want any aircraft on the ground that will never move. But that's up to you. :)
 
Last edited:
These should be at 100% unless you changed it in AIFP.
The 'activity level' in AIFP is set at 1 %. According to the manual (and my understanding) in that case custom AI traffic is enabled if the slider ist at any value above 1 %. Is there another way to change this in AIFP?
Looking forward to a working FP, if not too big effort.
 
Oh yes I see that now. I thought standard was 100%.

My first test has failed. I used a Asobo model and it does indeed not show up.
I'll try again with a different model and airport.

My working flightplans use custom models (ivao library), so maybe that's where the issue is and possibly why it hasn't been reported yet. I figure most use custom models for flightplans. :)

note: I bought the game on the Microsoft store, so the issue is not only for Steam. (jdiegel is on Steam)


edit: after more tests I confirm this: in game models do not load, while community models do.
 
Last edited:
No I tried with 3 custom aircraft in my community folder (don't have other custom aircraft):
- dr400-140b Dauphin (freeware from Asobo)
- indiafoxtecho-indiafoxtecho_mb339pan (payware from Dino Cattaneo)
- Riko Fokker D.21 1940 (freeware from Rikoooo)
No success.
 
Top