• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Alright, what is going on here?

Usually things like this are caused by unwelded vertices or smoothing groups gone wrong. I have tried everything in the book to fix it: Mass welding of all vertices, checking smoothing groups, making sure duplicate polys weren't hiding under the surface, using the Edit Normals > Reset modifier, resetting X-Form, even remapping the entire part...Nope. Nothing has had any effect.

It started as just a couple of unshaded grey polys on the apex of the V-stab...Now it's spread to the whole top of it after I tried to delete the offenders and patch the holes with new mesh. Has anybody else been plagued by this?
 

Attachments

I've had that happen. Problem is that it happened a long time ago and I'm trying to remember what the fix was! :scratchch
Explore mirroring the offending polys. I seem to recall that it was something like that...
 
Is the mapping degenerated to a line for those polys? FS-X seems to hate that. Good news is you do not need to alter the geometry, just the mapping to give polys at least a pixel of texture depth!
 

Paul Domingue

Resource contributor
@mariomotta may have hit on the problem. Check for degenerate polys. A degenerate poly is a polygon with only two vertices and therefore an edge line with polygon properties that will play havoc with textures. They can be hard to find. Compile the object to MDL and check your build log. Any degenerate polys will be listed there.
 
have you exported the geometry yet? That's the quickest way to find a degenerated poly.
Yeah, I'll have to check the build log for a degenerate then when I get home. Seems to be the consensus here...I know that in Max I deleted all of the problem polys in the first place but maybe those edges that I extruded the new mesh from were degenerate in some way.
 
Hmm...After checking the build log, I didn't find any discrepancies related to the part in question. Looks like I'm going to have to patch that section with a new object. :(
 
Ah ha! Mario and Paul, you were on to something. It turns out that I didn't have any degenerate POLYS in my mesh, I had degenerate MAPPING of it. The polygons along the stabilizer's top (which is UV'ed with Planar mapping from the sides) are perfectly flat on the Z-axis and share UV space with the next loop of edges. Pulling those edge vertices out about a pixel or two in UV space seems to have solved the problem. ;) I didn't realize that improper UV mapping could cause things like this.

Thanks guys.
 
Last edited:
Top