Attach A Library Object In MDCx

#1
Maybe I don't understand or maybe its not possible except in a design program like Blender...I created a tailhook.dae in Sketchup...looks nice in my opinion...it is a simple cylinder hook for a 1930s biplane. I can open the model of the aircraft without the hook in MDCx no problem. I also open the attached object editor which I have successfully used to attach deck cables; hard deck platform and lights to an aircraft carrier model this past week all good. This particular aircraft, the Hawk II was converted to a Navy version by Curtiss called the BFC-2 but since the designer did not create the Navy version only the military/civilian version it has no hook. I don't assume to animate it because with the tailhook section in aircraft.cfg, FSX(A) "recognizes" a hook and the airplane lands just fine on the deck. I know MDCx animates but maybe after I manage to attach it visibily to the aircraft model. After all this explanation, how do I do this. I exported the dae into an FSX.bgl and loaded it into the scenery library in ADEx. I copied the GUID. I open the attach object editor; ADD library object; paste in the GUID but then after pressing ENTER the box just sits there and nothing appears on the model. HELP!
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

MCX will only show the attachpoint of the attached object, the preview will not actually load the other object. So you would have to save the aircraft mdl and load it in the sim.
 
#4
I was able with some experimentation to get the correct position for the tailhook attach point. Exported the mdl and pasted the new mdl into the model folder. When I open it in FSX the aircraft is a pinpoint in the sky which can only be brought in to a tiny airplane visible and is not visible at all in the sim. What did I do wrong or don't have checked. Until I tried to attach a library object no other export did this I went back to do it again and this time noticed that in the Options Export MDL was FS2004 MAKEMDL sdk which I don't even have so I searched in FSDevelopers and found for FSX this should be xtomdl so I replaced that location and exported again. Same results.
 

tgibson

Resource contributor
#5
Check that Remove Scaling in Options is set to TRUE. If not, your aircraft will be huge and you will get that "far away" problem in the sim.

If you already have that set at TRUE, then you need to use the MDL Tweaker (in MCX) to reset the bounding box to reasonable values. My tutorial has a discussion of this problem:

http://www.calclassic.com/convert_tutorial/part5.html

Hope this helps,
 
#6
Hi Tom,
Just downloaded the calclassic as a pdf so i have it to ref and thank you. I will post I hope successful results here in a little while. Everytime I think that I know what I'm doing in MDCx I get lost again. LOL.
 
#7
Good news and bad. I followed your tutorial and yes everything you said to do worked. The bad news is that the library object tailhook is not visible. Since I can use the aircraft just like it is in FSX with tailhook info in the aircraft.cfg I'm not going to spend any more time on it. Thank you for taking the time to help. I learned something how to fix huge faraway planes if it occurs again. As far as converting it to FSX that works perfectly.
 
#8
I don't like to quit so I took another stab at this. Imported the F11C mdl added the attach point for the library object including the guid that I saved for it. I figured that maybe like in scenery I had to have the tailhook.bgl in the model folder like it has to be in the scenery folder to appear. OK? Not really. After using the MDL Tweaker to reduce all those numbers as Tom suggested, I save the MDL. Wisely, made a backup of the original in the folder. The aircraft appears a proper size in the preview window in FSX(A) but when I open it at an airport, the virtual cockpit is gone only the 2D is there and there is no mdl.interior like some aircraft in the model folder just the mdl. HELP!!!!! I can go back to my original mdl and fly fine but I would like to have the tailhook if its possible not to lose the VC in doing so.
 

tgibson

Resource contributor
#9
If it is an FS2004 aircraft (no "interior=" in the model.cfg file in the model folder) then the VC is part of the model and you will lose it during the MCX Export to FSX format. You can export it separately using MCX - my tutorial explains that.
 
Top