• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Blender model not showing in object library

Messages
29
Country
bahrain
Hello everyone,

I have followed "MyPhysicalWorld" tutorial videos on creating the scenery project. I have the model ready with me and its all exported as the exact way.

The problem I am facing is, its not showing the model in the sim. The project built was successful.

Picture number 3 is showing the material editor to pick up the folder, but not the 3d object from modelLib.

I have attached the whole project with the 3d model file in as well.

Please suggest if I am doing anything wrong.
 

Attachments

  • 1.png
    1.png
    174.2 KB · Views: 33
  • 2.png
    2.png
    104.1 KB · Views: 30
  • image_2022-03-14_175340.png
    image_2022-03-14_175340.png
    375.9 KB · Views: 31
  • test.part1.rar
    5 MB · Views: 23
  • test.part2.rar
    5 MB · Views: 20
  • test.part3.rar
    5 MB · Views: 21
  • test.part4.rar
    651.2 KB · Views: 22
Messages
466
Country
italy
Hi there
You are not expected to find a 3d model in the material editor

You have to pick It from the objects window in the Scenery editor

The scenery editor Is loaded once you load It by clicking on myscene ,opening the Inspector and click load in Editor



And please, rename myscene, mymodellib and mymaterials to something more "yours" and related to your airport, or sooner or later you or any user downloading you work Will have some conflict with other scenery using the same names
 
Last edited:
Messages
29
Country
bahrain
Hi there
You are not expected to find a 3d model in the material editor

You have to pick It from the objects window in the Scenery editor

The scenery editor Is loaded once you load It by clicking on myscene ,opening the Inspector and click load in Editor



And please, rename myscene, mymodellib and mymaterials to something more "yours" and related to your airport, or sooner or later you or any user downloading you work Will have some conflict with other scenery using the same names

Yes I am searching for it in the objects window, its not being shown there.
and will surely rename the scene, modellib and materials.

Let me know if there is anything else wrong.
 
Messages
466
Country
italy
in your screenshot you are showing the Material Editor, not the Scenery Editor with the objects window

please look at my screenshot, with your house and your project working

i have cleaned your project, just add back texture (not included because of size) and compile again, you will succeed!
 

Attachments

  • Screenshot (349).jpg
    Screenshot (349).jpg
    1.1 MB · Views: 29
  • Rashidar84-test-project.zip
    210.2 KB · Views: 27
Messages
29
Country
bahrain
in your screenshot you are showing the Material Editor, not the Scenery Editor with the objects window

please look at my screenshot, with your house and your project working

i have cleaned your project, just add back texture (not included because of size) and compile again, you will succeed!
Thanks alot. My this project was testing of how to build the folders. I will compare them.

Can you tell me what was wrong if possible ??
 
Messages
466
Country
italy
Nothing really wrong
Compiling It the console shows warning about naming (test as package name Is not compliant)
And errors about the material library, wich you should add only when adding Custom materials

My advice Is to use the wizards and avoid manual xml editing wherever Is possible. This Is also Asobo advice


(Old tutorials are a file edit fest because no wizard was available at the time)

I have a few tutorials using the "new" methods, if you feel the Need give them a shot





Inviato dal mio Mi 9 Lite utilizzando Tapatalk
 
Top