• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Blender to FSX Toolset

random shot of my testplane

In-sim shot of the Phenom 300 I use for testing the toolset. Landing lights were attached using the attachpoint tool... Always make sure to have a unique name for each attachpoint of your model. The ACES toolset handles this automatically, as it generates a unique name for you. My toolset, alas, doesn't handle that yet, so you have to take care of the naming by yourself. Maybe a point to improve...
 
Just write a random character generator to handle the naming.
Assign a string as unknown and have a random generation using a specific range be set as the string, with a condition limiting each string combination to be used only once within the file.

Just dont forget to add the ability to reveal the name after generation and conversion to string or else the developer wont know the name of his points :)

BTW I am about to test out your plugin. You mind if I open it and see the internals in IDE?
 
Last edited:
BTW I am about to test out your plugin. You mind if I open it and see the internals in IDE?
I'm fine with that. Just don't scream at what you will find, hehe... I'm still learning python.

edit. What IDE are you using? I ask because I'm just using Blender's internal scripting window and PN2, which is not what I would call an IDE.
 
Last edited:
Hi capt_x
first of thanks for your efforts ...and your patience with me :) !

Yesterday evening, before reading your answer to my

Originally Posted by scighera View Post
You know, I'm a novice to animation !!


I made an attempt to export an animation from blender, without any assotciation object/animation: got myfile.X and myfile.xanim ... naturally not working :)

Then after reading your hints I associated the animation (type ambient ?) to the moving objcted and set frame 0 as the starting one.


I got an error msg, from which i understood I should have to put the animation length in frames ... put in the animation length, but still I get the error msg
:


Probably I made some error, somewhere ...
 
Fixed! Updated plugin in the first post. One word about animation length: IIRC, the limit for framerange in FSX is 1024 keyframes per animation. Your 2000 frames may cause XToMdl to fail on compile time, because the exporter exports every single frame as a keyframe. If XToMdl fails, you can try editing the .xanim file by hand and simply delete some keyframe entries. If that doesn't help, try staying below 1024 frames when you animate.

edit. forget about the animation limit. That was for FS9.
 
Last edited:
Fixed! Updated plugin in the first post......
The crane boom is ROTATING !!!!
:D

Now it's time I put myself to work hard in order to make the "Funivie del Monte Bianco" (Monte Bianco cableways) working, for the Official Ski Season 2013/2014 Opening, on Saturday December the 7th ...

Many, many thanks ... Hooray, hooray, hooray for capt_x :)
 
Im using the Python IDE v3.3.2. It makes it a lot easier to code python because it will tell you when something is wrong while you are writing; ie. undeclared classes.
 
So, capt_x the rotating boom of the crane works perfectly, as I said, even if I do still have some problems with the alpha textures and with the double sided faces ... I thought I overcome the problem, but with the file of the crane the problem showed up again: probably I make some error in the settings of the material. I checked and rechecked with the file that was working fine with the alpha textures and double sided faces ... but I'm unable to find out the difference in the settings :(

So after the success with the rotating crane, I started to try to animate the cab of the cableway of the Monte Bianco ...
Exporting from blender 2.69 I got the files:
FMB_Cabs_1stLeg.x
FMB_Cabs_1stLeg.xanim

Imported FMB_Cabs_1stLeg.x in ModelCoverter the animation was showing fine (at list for the part visible in Model Coverter).

The exported from ModelConverter I obtained the flie: FMB_Cabs_1stLeg.mdl

Placed it in the sim using Sbuilder, the moving cab showed up fine ... but it disappeared after a short while (roughly after 700 frames, at 25 fps), reappearing after few seconds just for a couple more seconds, to disappear again definitely.

The animation in Blender, presently, last 6350 frames: once completed it should last some 12000 frames (at 25 fps) :confused:

Any suggestion ??? Please, try again to use your :wizard::D
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

You might want to try to compile the x file directly with xtomdl, instead of using modelconverterx to make the mdl file. That would help to figure out if you found a bug or if something is wrong with the keyframes.
 
Hi,

I am a French aircraft designer used to working in Gmax but also a Linux Aministrateur who carefully monitors the Linux software.

I had migrated to FSX somes aircrafts originally maded within Blender.
If your addon can generate directly an MDL it is with pleasure that I would try to go in Blender for my future achievements.

Lagaffe
 
Hi,

You might want to try to compile the x file directly with xtomdl, instead of using modelconverterx to make the mdl file. That would help to figure out if you found a bug or if something is wrong with the keyframes.
Indeed I tried XtoMDL as well ... but (if I'm not wrong ... I made so many attempts :) ) it didn't compile ... for sure I made something wrong writing the command string !

I'm thinking to make available the FMB_Cabs_1stLeg.x and ....xanim, should any goodwilling guy would take a look at it :)
 
direct export to .MDL request...

If your addon can generate directly an MDL it is with pleasure that I would try to go in Blender for my future achievements.

Lagaffe
I thought XToMdl would be the preferred way to go, but I can add the functionality to export directly to .MDL, sure.

Regards,
 
Hi,

I am a French aircraft designer used to working in Gmax but also a Linux Aministrateur who carefully monitors the Linux software.

I had migrated to FSX somes aircrafts originally maded within Blender.
If your addon can generate directly an MDL it is with pleasure that I would try to go in Blender for my future achievements.

Lagaffe
I thought XToMdl would be the preferred way to go, but I can add the functionality to export directly to .MDL, sure.

Regards,
Why not just add the feature needed to place and export directly into bglcomp from blender as well? Giving multiple options to chose the method you wish. Then we are talking about having a full service FSX plugin.
 
Ciao Paolo,

it turns out the bug with the animations export "when no length defined in modeldef.xml" wasn't completely fixed. The animation in .xanim needs to have a "length" attribute (who would have thought?:D), that's why XToMdl wouldn't compile. I hope I have now definitively fixed that bug. The updated plugin is in the first post as usual.

Note: I haven't tried MCX yet, but XToMdl compiles fine now.
 
Ciao Felix
now, solved the problem of the alpha texture, I'm back on the animation !

With the last exporter (the release of dec 3rd) I'm still not able to get the animation of the cab properly working: the animation last some 750 frames, the the cab disappears, to reapper for a couple of seconds (50 more frames) to disappear completly; the cab reappears, I guess, when the animation cycle start over again ... to behave the same.

Again i think there is something wrong in my blender file (as was for the alpha texture ... but what is wrong ??? :confused:
 
Ciao Felix
now, solved the problem of the alpha texture, I'm back on the animation !

With the last exporter (the release of dec 3rd) I'm still not able to get the animation of the cab properly working: the animation last some 750 frames, the the cab disappears, to reapper for a couple of seconds (50 more frames) to disappear completly; the cab reappears, I guess, when the animation cycle start over again ... to behave the same.

Again i think there is something wrong in my blender file (as was for the alpha texture ... but what is wrong ??? :confused:
Did you compile the .MDL using MCX or did you export directly to .MDL with my script ? Because when I load your cab into FSX (albeit as an aircraft), I can see the whole animation, at least the cab doesn't disappear. I have never used SBuilderX though...
 
Scighera, how does your animation work? You have some points the cab is passing through?
Yes, Dutcheese: it follows the rope, thus a line that's norally called "catenary", wigh I have approximated with a number of staight lines, not that many of them, atually..
 
Top