Can't see plane through window

#1
I created a terminal with an interior for FSX. The glass is semi transparent and made in GIMP. After I applied the texture to the window area and loaded it in sketchup, everything looked fine. However, when you go inside the terminal and look through the window, jetways and aircraft disappear. Once you get outside of the terminal, the jetway and aircraft reappears. I think this might have something to do with the semi transparent texture but how do you fix this? In addition, looking through 2 layers of the semi transparent glass causes one of the layers to disappear as well.
 
Last edited:
#3
The windows within SketchUp have to be done inside as well. In other words,... inside and out.
I remember texturing them inside as well so that there would be a brighter night texture for the inner view of the window. I can double check. Any other possibilities if it turns out that isn't it? I can see all static objects and vehicle traffic including animated airport ground vehicles. I cannot see my own aircraft, ai traffic, and jetways. Another thing I noticed, some aircraft can be seen such as my AI Malcontent CRJ200
 

=rk=

Resource contributor
#4
This situation arises from mixing face orientation while texturing. Did you perhaps notice that Sketchup models have a white face and a pale blue face? White represents outer faces and you must make certain that these orientations are preserved throughout every step of modelling to avoid this and other problems. The paint bucket causes this, if you painted each distinct polygon, you would notice the blue faces. This also happens when you paint a a group without edit painting the individual components, anything previously untextured gets covered with the entire texture sheet on each polygon.

How did you go about establishing transparency, did you create and edit a proper alpha channel? Also why would you use a different night texture? Windows are supposed to be transparent, possibly tinted and possibly with reflection. Trying to do too many new things at the same time may not be productive. The simulator does not support 2 different night textures on the same polygon. Night textures are supposed to be a simple edit of the exact same day texture, the alpha channel of the day texture affects night transparency. You would have to make a second pane of glass to support this lighter texture that you would not even be able to see while using your software as a flight simulator, in order to properly render a second night texture.
 
#5
This situation arises from mixing face orientation while texturing. Did you perhaps notice that Sketchup models have a white face and a pale blue face? White represents outer faces and you must make certain that these orientations are preserved throughout every step of modelling to avoid this and other problems. The paint bucket causes this, if you painted each distinct polygon, you would notice the blue faces. This also happens when you paint a a group without edit painting the individual components, anything previously untextured gets covered with the entire texture sheet on each polygon.

How did you go about establishing transparency, did you create and edit a proper alpha channel? Also why would you use a different night texture? Windows are supposed to be transparent, possibly tinted and possibly with reflection. Trying to do too many new things at the same time may not be productive. The simulator does not support 2 different night textures on the same polygon. Night textures are supposed to be a simple edit of the exact same day texture, the alpha channel of the day texture affects night transparency. You would have to make a second pane of glass to support this lighter texture that you would not even be able to see while using your software as a flight simulator, in order to properly render a second night texture.
So is the fix basically to texture the glass inside and out with the same texture and not to apply a LM? Also, I understand the basic concept of the face orientation. However, how does one screw up the orientation, how does one fix it after they've already applied textures, and what do you do to avoid screwing it up? How does this relate to disappearing faces that were already textured?
For the alpha channel, I created it in GIMP by selecting a certain color I set aside in MS Paint for the alpha channel, adding an alpha channel to the layer, and deleting the selected color. Then I added a second layer and filled in that gap with a solid color and changed the opacity to simulate darkened glass.
 

Pyscen

Resource contributor
#6
Having the window textured, inside and out, doesn't have anything to do with having a "_lm" or not. A night texture is needed - no matter what. The "_lm" texture has nothing to do with the problem you are having. Rick is right about the orientation of the faces, the white side should always be facing out and the pale blue or grey (this is the default) is always facing inward (this is prior to any color or diffuse texture is applied).

The only way to correct the faces is within SketchUp. Though, you can remove the color (material) of the face to comfirm which face is showing (white or blue). Unfortunately, I'm not not in front of a computer to give you the commands to do so.

Technically, the Alpha Channel is not a layer. A alpha channel is a component, just as the others (red, green, and blue) are.

Concerning the window within GIMP, all that is required is a 256 x 256 texture with an off blue/green or gray color with the opacity of 46%. Additional layers are not required.
 
Last edited:
#7
Having the window textured, inside and out, doesn't have anything to do with having a "_lm" or not. A night texture is needed - no matter what. The "_lm" texture has nothing to do with the problem you are having. Rick is right about the orientation of the faces, the white side should always be facing out and the pale blue or grey (this is the default) is always facing inward (this is prior to any color or diffuse texture is applied).

The only way to correct the faces is within SketchUp. Though, you can remove the color (material) of the face to comfirm which face is showing (white or blue). Unfortunately, I'm not not in front of a computer to give you the commands to do so.

Technically, the Alpha Channel is not a layer. A alpha channel is a component, just as the others (red, green, and blue) are.

Concerning the window within GIMP, all that is required is a 256 x 256 texture with an off blue/green or gray color with the opacity of 46%. Additional layers are not required.
So what should the orientation be? Should the blue face always face inwards and the white face outwards?
 
#11
Did you use the Set Default Transparent choice in the MCX Material Editor for the glass textures?
Tried it out and I still cannot see aircraft and jetways through the glass. I also forgot to mention that clouds and autogen trees (not buildings) were erased as well.
 
Last edited:

Ronald

Resource contributor
#12
How about adding / uploading some screenshots of your current challenges< so everyone can :oops: what you type of errors you referring too?
 
#17
Here's another guess...

In the MCX Material Editor Enhanced Parameters section, set Z-Write Alpha to False for your glass texture, if it isn't.

I haven't done any transparent glass for a long time, so I might not remember all I did. I think that I took a rather dark color .png, that I wanted and applied it to the glass in SU and set the opacity in the SU Materials Edit tab. Then exported the .dae and converted it in MCX after setting the material parameters there.
 
Last edited:

=rk=

Resource contributor
#18
Omg so much guessing. First off, I am suspecting you have painted a group without opening it. In your model, do you have any polygons that have a small example of your entire texture sheet mapped to them? Also, you did not say why you used a different night texture. bear in mind that the simulator applies a night overlay to every model that does not have a night or _LM texture, which replaces the automatic overlay. This makes night textures optional, especially on glass.

Ok, the whole transparency thing sounds awesome but it is not at all consistent with the MSFS render engine. Transparency is controlled by the alpha channel in gray tones from black, full transparent to white opaque. Anything else you do forces MCX to interpret the transparency and create the alpha channel and it is efficient but it isn't perfect and you want perfection.
https://www.fsdeveloper.com/wiki/index.php?title=Alpha_channel_creation_with_Photoshop

Your easiest, fail safe fix is to put all transparent polygons into a separate group. Delete the rest of the model and then export the glass, do the reverse with the rest of the model. Now back in Sketchup with the glass, delete all the textures. Examine all faces for proper orientation. Re import your texture and with the group unlocked, select all polygons, first click the paint bucket once onto the white side and then once onto the reverse. now you've got you poly's properly oriented and mapped. The thing about blocking visibility is a Sketchup to FSX/P3D glitch that is not well documented or understood. I've tried to explain a few of the causes, as best I can tell.

Now that you have your terminal without glass and your glass model, import the glass into MCX. Find and apply the "set default transparent" attribute set from the drop down selection. Complete your material assignments for night or whatever and export the model. Now import the terminal into MCX. In the material attributes window, find and apply the "set default opaque" attribute set from the drop down selection. Complete the relevant material assignments and use the combine tool to add your glass model to the terminal one. Make sure that the glass texture assignment matches the same texture for the terminal, if you are using single texture sheets. Now export your model and everything should work as expected with transparencies.
 

Pyscen

Resource contributor
#19
To all:

The model has a lot of polygons facing backwards (light blue facing out). Also... the glass material used is intermixed with solid material (concrete or other building material). Therefore, coming up with the problems mentioned in the OP. Have advised and suggested that many of faces need to be reversed and the glass made into 1 separate texture.

The light maps (night) aren't a factor in this situation....
 
Top