FSXA Dropped Animations

=rk=

Resource contributor
Hello, I have created a animated model in FSDS to represent a hold short light. I used two images of an illuminated lens, superimposed over the light fixture with dark lenses. I used key frame animation to alternately 180 degree reverse the lenses every 10 frames. As the back of the lens is untextured, the effect is that each lighted lens disappears for the duration of 10 frames.
When I import the model with .fsc extension into ModelConverterX, everything works as expected. However, when I compile as a .mdl, MCX strips the animations. When I export from FSDS as an .x file or .mdl, the animations are lost before opening in MCX. Additionally, FSDS refused to compile with XToMDL, so I switched to MakeMDL and it compiled.
Is there a solution? Is it buggy code? Superficially, it looks more like an issue with the Microsoft compilers than FSDS. I'll attach the working FSDS file..
 

Attachments

=rk=

Resource contributor
Have you unchecked the drawcall batching checkbox and tried?
I have to apologize in that I am very awkward with FSDS. I model in Sketch-Up, primarily, then use MCX to export components to FSDS for making animations. The draw call batching check box is in FSDS?
You have keyframes in part0 part... normal?
...and again apologies, I have to inform that my technique is basically to do as little in FSDS as possible. In this instance, I split the light into three parts, the static box, and each illuminated lens. The lenses I animated separately, I saved one as a part and then added it to the other after I'd animated it - I should also add that I got it to work at first in a more straightforward fashion, but he darn lenses refused to be sequential and flashed on and off at the same time, that is why I tried it this way, you see. Then once I had both lenses animated, I imported the box as a merged project, then saved that in .x or .fsc for import into MCX. So to answer your question to the best of my knowledge, part(0) is the first one I animated, I am sorry but I do not understand about normal. Perhaps I should include the box in my entire animation..? This I have done, but that is how I get the parallel flash, even though I switch the parts at each key frame.
 
The name "part0" is absent in FSX Keyframe Animation list in Standard Part Names dialog box of FSDS. May be its explain the bug... Try Ambien1, Ambien2 etc.
 

=rk=

Resource contributor
Yes thank you, I believe I understand. I remember I had a similar issue working out the animation for ship antennas. I will explore it.
 

=rk=

Resource contributor
So I got it finally, thank you - by adhering to the naming parameters presumably. It worked fine in MCX after compiling as a .mdl. The nuances of the animation renderer treated it differently in FSX; you can clearly see a single light swing back and forth, like an old school RR crossing or somebody waving a lantern, a stupid orange Cylon visor effect, so I suppose I have to take a different approach. It is frustrating because in the animation the lenses are two separate items that never move in the x,y, or z axis, they only rotate.
 
Top