P3D v4 Effect Boxes don't match the lamp models

#1
Hi,

I'm having trouble with airport lighting recently.

Let me get this straight, First,the models and the attatchpoints are exactly aligned in 3DS Max.

Second as I exported them separatedly, drop them into MCX, and both did FSX earth curve correction.

Then I placed them both with the same reference coordination.

As you can see ,the lamps and the effect boxes are deviated. But some of them are aligned , so weird...














My version of MCX is 1.4, modeling with 3DS MAX including a P3D V4.2 SDK.

I'm looking for a solution for this , wish you guys could help me with it .

Best Regards,

Rustam.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

Are your lights far from the reference point? The engine has some bugs that cause attachpoints to be shown at different locations. Also if you have enabled drawcall batching it might increase this problem.
 
#3
Hi,

Are your lights far from the reference point? The engine has some bugs that cause attachpoints to be shown at different locations. Also if you have enabled drawcall batching it might increase this problem.
Hi Arno,

I‘m glad you replied.

Luckily, I found that my light are far from the ref cor, and the lights far from the ref cor are far more deviated ,on the other hand, the lights which are close to the ref point they appeared to be exactly aligned.

So I'm going to change my ref cor to the center of the lights then try again. ;)
 
#4
Hi,

Are your lights far from the reference point? The engine has some bugs that cause attachpoints to be shown at different locations. Also if you have enabled drawcall batching it might increase this problem.
Hi Arno,

I've tried your method and disabled drawcall batching . But no luck.

My lamp models are perfectly aligned where I put them. However, the strange thing is that attachpoints are not , the points near ref cor (within 300m) are perfectly aligned to the lamps, east of the ref cor are deviated to the west( about 2m) , in the meantime,

the attachpoints which placed west of the ref cor are deviated to the east. o_Oo_Oo_O

I'm really out of solutions.

Best Regards,

Rustam
 
Top