Error in ACM

I started up the program and i got an error in the log file..



16:48:25 | AutogenConfigurationMerger version 1.1.6531.37127 rev cab4a053 date 18/11/2017 20:34:49
16:48:25 | No FS version specified, using current directory as FS path: D:\Program Files\Lockheed Martin\Prepar3D v4
16:48:25 | Prepar3D v4 found as version
16:48:25 | FSPath: D:\Program Files\Lockheed Martin\Prepar3D v4
16:48:25 | >> Found config: D:\Program Files\Lockheed Martin\Prepar3D v4\Autogen\Materials.spb
16:48:25 | >> Found config: D:\Program Files\Lockheed Martin\Prepar3D v4\Autogen\RoofDescriptions.spb
16:48:25 | >> Found config: D:\Program Files\Lockheed Martin\Prepar3D v4\Autogen\Extrusions.spb
16:48:25 | >> Found config: D:\Program Files\Lockheed Martin\Prepar3D v4\Autogen\AutogenDescriptions.spb
16:48:26 | >> Found config: D:\Program Files\Lockheed Martin\Prepar3D v4\Autogen\AutogenDescriptions_Legacy.spb
16:48:26 | >> Found config: D:\Program Files\Lockheed Martin\Prepar3D v4\Autogen\TerrainAutogenClassDescriptions.spb
16:48:26 | >> Found config: D:\Program Files\Lockheed Martin\Prepar3D v4\autogen\default.xml
16:48:26 | Error! Stopping...
16:48:26 | There is no Unicode byte order mark. Cannot switch to Unicode.
16:48:26 | at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.CheckEncoding(String newEncodingName)
at System.Xml.XmlTextReaderImpl.ParseXmlDeclaration(Boolean isTextDecl)
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load(XmlReader reader)
at System.Xml.XmlDocument.Load(String filename)
at ASToFra.AutogenConfigurationMerger.XMLMerger.InitGlobalConfiguration(String fsPath)
at ASToFra.AutogenConfigurationMerger.AutogenConfigurationMerger..ctor(String[] args)
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Is this with a default P3Dv4 installation or has the default.xml file been edited by some addon already?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
So what was the fix? Maybe I can improve ACM to prevent the error.
 
So what was the fix? Maybe I can improve ACM to prevent the error.
I found out that the default.xml had some issues after installing FlyTampa Amsterdam, so i used the default.xml that was backed up before the installation and it seem like it fixed the problem.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
OK, if the default.xml file was corrupt in some way, it's probably not something I can fix in ACM.
 
Top