• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Blender Export from Blender 3.6x using last exporter version 1.3.3 ( new options in settings )

So I played around with 3.6 some more to characterize the issue. It seems to be triggered by two objects using the same material.
- There is no warning if I only a material only to one object
- The warning goes away if a material is assigned to two objects, and I make a copy of one of the materials and assign the copy to one of the objects
- Once I get the warning and the material is flagged with that message saying "Material with this name already exists... renaming", changes to the material don't take effect any more (at least I confirmed changes to the Base Color don't take effect)
- From this point on, doing Clean All, Build All, and assigning only one material per object STILL doesn't make the Base Color change take effect, even when there is no warning anymore
- Making a copy of the material with the Base Color that doesn't show, and giving it a unique name, STILL doesn't make the Base Color show up
- Then I even tried making a NEW material from scratch for the object that I couldn't modify the base color for. Clean All/Build All, and the Base Color STILL has no effect

Edit:
- Then I tried changing the Base Color for a different material in 3.6 and that one did relect the Base Color change, despite giving the warning
- Going back to the "Metal_shiny" material, setting the Base Color has no effect. But it shows up in the material preview view.

I'm kind of baffled by all this.
 
Last edited:
The current version 3.3.3 has been changed. You would need to download the latest version dated 3 weeks ago... I exported the glTF and it compiles without any warnings. Also, I noted in the .blend file you included, you appear to have altered the material in the Shading mode. This doesn't work for MSFS. If you use MSFS materials, you should only alter them in the panel, not using shader nodes.
 
The current version 3.3.3 has been changed. You would need to download the latest version dated 3 weeks ago... I exported the glTF and it compiles without any warnings. Also, I noted in the .blend file you included, you appear to have altered the material in the Shading mode. This doesn't work for MSFS. If you use MSFS materials, you should only alter them in the panel, not using shader nodes.
3.3 works fine for me also with no warnings, and I do use the latest version (I think 3.3.18?). Those warnings and related material issues only happen in 3.6, I was hoping to change to 3.6 after my last project but since I can't get it to export properly I'm still using 3.3.18 for now.

I would not have altered the Shading node intentionally, whatever is there in those materials should have been there when I created them and simply altered MSFS Material Params. Do you actually need to go under Surface and click "Use Nodes" to disable that, every time you create a new material?
 
Your shading nodes:
Your Shader Nodes.png


MSFS shading nodes:
MSFS Shader nodes.png


Your materials are not MSFS materials.
 
Interesting, the Wall and Metal material are like that but others are not. I don't know how it got that way or how to turn it into a MSFS Material, I must have imported that one and made the others from scratch.

I re-created the offending materials to make the shaders look like yours, I open the file in Blender 3.6, and when I export... I still get the "Material with this name already exists" warnings when I build the project.

Now when I change the Base Color for the material in Blender 3.6 I don't see the color have any effect in Blender itself (with material preview), but it does show up in the sim. When I open the same file in Blender 3.3 the Base Color change shows up in Blender and it shows in the sim too, without any of these warnings.
 
A wise man said: never change your environment while you are working on something unless you are forced to do that 😆

(Fresh projects in 3.6 / 1.3.3 works flawlessly 😗)
 
A wise man said: never change your environment while you are working on something unless you are forced to do that 😆

(Fresh projects in 3.6 / 1.3.3 works flawlessly 😗)
This is a new project (a small one too) and that's why I'm trying 3.6 now! :)

But I can't get past this issue, I created materials from scratch and I can't get rid of this stupid warning... I want 3.6 to work.

Do you guys actually use Base Color to shade your textures, and does that color change show up in Blender and the sim? Mamu, I recall that you like to use Substance 3D now, I use plain texture files with all the PBR done by hand. Maybe you guys just don't use that feature?
 
I'm getting old, but I only see one dot in textures. I use ../texture for aircraft. is it the same for scenery?
 
to "fix" your shader issues - just reselect - the material in the drop down. it will keep all your texture and settings. DO NOT SET TO DISABLED - that will delete all your data in that material.

ie. just reselect standard.
 
Back
Top