• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

3DS Max Fixed Animations

=rk=

Resource contributor
Messages
3,684
Country
us-washington
Can someone tell me why this model remains fixed? I have all the hierarchy in the Babylon Animation Groups. I've got a model that works to compare to and the only thing different I can find, is the basic rig. This file is saved to version 2019.
 

Attachments

  • Version with animation group2.zip
    1.7 MB · Views: 17

Christian Bahr

Resource contributor
Messages
906
Country
germany
You have to select the bones and the mesh. Then "Create" a new animation in Animation Groups and then click on "Add Viewport Selection". Then confirm with "Confirm".
 

Attachments

  • animation-groups.jpg
    animation-groups.jpg
    682.2 KB · Views: 35
  • Version with animation group2.zip
    1.6 MB · Views: 18
Messages
83
Country
us-california
I didn't check your file, but did you collapse all the frames of all the elements to the timeline?
1655098393841.png
 

=rk=

Resource contributor
Messages
3,684
Country
us-washington
Thank you both, I am sorry to be pedantic. This model remains stolid, "showing little emotion or animation."
You have to select the bones and the mesh. Then "Create" a new animation in Animation Groups and then click on "Add Viewport Selection". Then confirm with "Confirm".

First pass, I tried the model attached with no luck. I had also applied the collapse transform to that one. Next, I went back to the one I uploaded, saw you'd deleted all the myriad animations I had added using the drop down "FlightSim>Babylon Utilities>Create Animation from Selection," function and I did the same, including the one labeled "animation," then I followed your direction to re apply the single animation name. This time, I was unable to activate the Motion Paths panel, it remained "dull," so I compiled into sim anyway.
I didn't check your file, but did you collapse all the frames of all the elements to the timeline?
Apparently I am unable to figure out why I can duplicate the panel you show a picture of, when I open Christian's edit, but can't with the version I uploaded.

Im dumb.jpg
 
Messages
83
Country
us-california
Apparently I am unable to figure out why I can duplicate the panel you show a picture of, when I open Christian's edit, but can't with the version I uploaded.
This happens to me if I use the same scene of a previous model, merge your FBX from Mixamo in a brand new scene, should work then.
 

=rk=

Resource contributor
Messages
3,684
Country
us-washington
I was able to clear that glitch by saving, restarting 3ds Max and opening the file. I could see the motion paths and after the operation, colored keyframes were set onto the timeline at regular intervals. The animations, however, remained fixed.
 

Christian Bahr

Resource contributor
Messages
906
Country
germany
Rick, I'd like to take another look at your file. Is it correct that different animations are stored on the timeline, so the person should have different animations?
Then you would have to specify a "from-to" range in Animation Groups for each animation.
 

=rk=

Resource contributor
Messages
3,684
Country
us-washington
Christian, I can get animations onto the timeline two ways, one is by clicking the mesh, then right click, scroll to Babylon, select Babylon animation groups and the other is the way I describe above, from FlightSim>Babylon utilities>Create animation group from selection. When I do it the first way, I get one animation that is 1000 frames, the viewport selection has all the hierarchy and it looks identical to carla, which works fine. If I do the procedure from the FlightSim menu, there are maybe 50-60 animations, each is the exact length of the Mixamo animation, which is 760 frames, I think and the have three, or so hierarchy levels in the viewport. This doesn't look like carla, I've tried this version and haven't made it work yet.

I'm attaching latest version with the Collapse transform applied. I notice it's about 2k smaller.
 

Attachments

  • Version with animation group2h.zip
    593.4 KB · Views: 16

Christian Bahr

Resource contributor
Messages
906
Country
germany
I only got around to looking at the animation today, unfortunately the file cannot be opened:

max_version.jpg

I use 3dsm2020.3 and you probably use a version 2021 or higher, please save the file as a Max2020 file.
 

=rk=

Resource contributor
Messages
3,684
Country
us-washington
Ah, of course. I have something that should work even better. I've managed to skin my mesh onto the carla rig. I haven't done any smoothing, or weight adjustments, it's just a proof of concept, but it does follow the carla animation in 3ds Max. Everything looks correct, but the animation remains fixed in MSFS.
 

Attachments

  • chp_carla_rig.zip
    1.7 MB · Views: 17

Christian Bahr

Resource contributor
Messages
906
Country
germany
I'm just checking. You know that your XML file needs an entry for your animation? But I'll create the XML file for you, it's easy :)
 

=rk=

Resource contributor
Messages
3,684
Country
us-washington
Thank you Christian! I've been using a modified copy from the working carla model that I always compare to. I use MCX to generate GUID's.
 

Christian Bahr

Resource contributor
Messages
906
Country
germany
Okay, your Max file is completely fine, no changes needed to be made, leave everything as is. It was probably because of your missing XML file?
In any case, the person is animated in MSFS: www.bahrometrix.de/msfs/video/carla_template.mp4

The export files (gltf, bin) are in the appendix. The XML file is a copy from one of my projects (with modified GUIDs). Important is the entry to the animation!
 

Attachments

  • carla.zip
    632.6 KB · Views: 23

=rk=

Resource contributor
Messages
3,684
Country
us-washington
Thank you very much Christian, I'm certain you've saved me running in endless circles and I'm sorry to put you to task over what appears to be some sort of clerical error on my part. Your .XML is distinctly different from the one I've been using, but it's a bit of a conundrum, because syntactically, the one I'd been using, is identical to the XML that the working carla model uses. My source for the carla XML, was also you, Christian. I'd tried versions copied from the SDK and other posts, but you were advising a developer and you transcribed what is essentially the one I copied and have since been using. Beyond that, I've found slight syntax irregularities in "my" carla XML as compared to this one you just uploaded, small things like closing symbols in odd places, however the document does work for the carla model, just not for the helicopter pilot model.

Anyway, I sincerely doubt the discrepancy is over GUID issues, I am pretty careful that way, but that remains a possibility. I'll do some experimenting and if I learn anything useful, I'll post here. I'll post both XML contents, in case anyone notices anything.

XML:
<?xml version="1.0" encoding="utf-8" ?>
<ModelInfo version="1.1" guid="{be6f3f4c-c4e5-4665-9c8e-e1c40bf5b443}">
<Animation name="carla" guid="f65f0722-5085-458d-ab4f-95e198f2c60b" type="Standard" typeparam2="carla" typeparam="AutoPlay,Random" />

    <LODS>
        <LOD MinSize="0" ModelFile="carla.gltf"/>
    </LODS>

</ModelInfo>

<ModelBehaviors>

<Component ID="testperson" Node="carla">
<Visibility>
<Parameter>
<Code>(E:LOCAL TIME, Seconds) 18000 &gt;= (E:LOCAL TIME, Seconds) 86400 &lt;= and (A:AMBIENT PRECIP STATE, mask) 3.0 &lt; and if{ 1 } els{ 0 }</Code>
</Parameter>
</Visibility>
</Component>

</ModelBehaviors>

XML:
<?xml version="1.0" encoding="utf-8" ?>
<ModelInfo version="1.1" guid="{2246aebc-6dfe-421d-8062-09bf655344b0}">
<Animation name="Cellphone Pilot" guid="09d80e2b-625d-475b-9307-76e9febad80c" type="Standard" typeparam2="Cellphone Pilot" typeparam="AutoPlay,Random" />

    <LODS>
        <LOD MinSize="0" ModelFile="Cellphone Pilot.gltf"/>
    </LODS>

</ModelInfo>

<ModelBehaviors>

<Component ID="testpilot" Node="Cellphone Pilot">
<Visibility>
<Parameter>
<Code>(E:LOCAL TIME, Seconds) 18000 &gt;= (E:LOCAL TIME, Seconds) 86400 &lt;= and (A:AMBIENT PRECIP STATE, mask) 3.0 &lt; and if{ 1 } els{ 0 }</Code>
</Parameter>
</Visibility>
</Component>

</ModelBehaviors>
 

=rk=

Resource contributor
Messages
3,684
Country
us-washington
The situation has become a little confusing, so I have to be careful how I express the aspects. To answer your question, I hope, I build these models as scenery objects. I do not see any configuration that describes LibObject/SimObject, so that is a setting I may be missing. I have built the models as SimObjects, this requires different files and structure, like including a sim.cfg. In that configuration, the carla model appeared and was animated, however it flashed oddly, compared to building as a library object, in which it works fine.

So far, the only thing I know for sure, is that only the carla rig will animate, regardless the mesh it is skinned to. I have a feeling, that the "ModelBehaviors" section of my XML files, is ignored by the sim. The reason I draw this conclusion, is that it works in the original carla model. The model with the helicopter pilot skin is also a carla rig and that model works with the abbreviated XML you provided, Christian. I have not done the reverse test of using the abbreviated XML with the original carla, but I'm pretty confident it will work. No other models will work with either XML. I have 3 or 4 animated models I try with each build.

The fundamental difference, I believe, is that all animations that are not from the carla rig, come from Mixamo and those do not work for me. I think I'll have to explore other sources, before I can discover what prevents Mixamo. I know there is at least one video by Federico Pinotti about running Mixamo animations through Blender into MSFS, so there has to be some traction somewhere and that is another option, learn Blender also...

Attached is the latest version of the helicopter pilot with Mixamo animation saved to Max 2020, if you want to check it out.
 

Attachments

  • Version with animation group2g.zip
    1.7 MB · Views: 19

Christian Bahr

Resource contributor
Messages
906
Country
germany
That is very easy. Either you compile an object as a libobject or you compile it as a simobject.
As a lib object you have very limited options, as a simobject you have very extensive options. For example, a SimObject can be programmed depending on the weather. A LibObject cannot do this.
You can see from your code that it should be a SimObject. A finished SimObject might be able to help you there. I'll take a look.
 

Christian Bahr

Resource contributor
Messages
906
Country
germany
In order to have an example file that corresponds to the same status, I quickly created another animated person: Sonya

Video: www.bahrometrix.de/msfs/video/sonya.mp4

The zip archive contains the Max2020 file and the textures by Sonya.
The Max file clearly shows the name of the animation and the name of the node.

The Simobjects folder contains Sonya as a finished SimObject.
The name of the 3dsm animation and the name of the 3dsm node are referenced in the XML file.
 

=rk=

Resource contributor
Messages
3,684
Country
us-washington
Yes I understand that SimObjects can be driven. In the core FSX engine, there is no discrimination between model types and library objects can run animations, so it just seemed natural to extend that condition to MSFS.

I understand that models can be interchanged between SimObject and LibObject and just to make sure you don't think I am crazy, I also made a short video.


You can see the "new" carla is tolerating placement as a mere scenery object, while my guy is a solid block of marble.
 

Christian Bahr

Resource contributor
Messages
906
Country
germany
Just looked at your max file again. The name of the 3dsm animation and the name of the 3dsm node do not match the information in the XML file. This could be the error (marked in red):

<?xml version="1.0" encoding="utf-8" ?>
<ModelInfo version="1.1" guid="{2246aebc-6dfe-421d-8062-09bf655344b0}">
<Animation name="Animation" guid="09d80e2b-625d-475b-9307-76e9febad80c" type="Standard" typeparam2="Animation" typeparam="AutoPlay,Random" />

<LODS>
<LOD MinSize="0" ModelFile="Cellphone Pilot.gltf"/>
</LODS>

</ModelInfo>

<ModelBehaviors>
<Component ID="testpilot" Node="Mesh1">
<Visibility>
<Parameter>
<Code>(E:LOCAL TIME, Seconds) 18000 &gt;= (E:LOCAL TIME, Seconds) 86400 &lt;= and (A:AMBIENT PRECIP STATE, mask) 3.0 &lt; and if{ 1 } els{ 0 }</Code>
</Parameter>
</Visibility>
</Component>
</ModelBehaviors>

3dsm file: Name of Animation and Name of Node:

animation_groups_3dsm.jpg
 
Top