• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FXEditor won't open

arno

Administrator
Staff member
FSDevConf team
Resource contributor
If no Window shows at all, I really suspect the .Net framework. MCX 1.3 uses version 2, more recent versions of my tools use version 4. So there is a difference.

Other things should at least show a window or error. For example if OpenGL support is not correct.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Just read that in some conditions, when Windows Error Reporting, is disabled, missing references might also cause this. Did you extract all files from the zip you downloaded in the same folder?

Also check the Application log in the Event viewer. It most likely contains errors when the problem happens.
 
sorry for digging up this thread.
FXEditor wont open for me also. .NET is up to date (4.8x), win10 is up to date also.

exported logs from event viewer attached (rename it to .evtx)
 

Attachments

  • fxe_LOG.zip
    68 KB · Views: 12

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Unfortunately the error log only says there was an unhandled exception. So that doesn't help a lot.

From your path I have the impression that you installed FXEditor and ModelConverterX into the same folder. Is that the case? I would install them in separate folder to prevent conflicts between the files.
 
Hi,

Unfortunately the error log only says there was an unhandled exception. So that doesn't help a lot.

From your path I have the impression that you installed FXEditor and ModelConverterX into the same folder. Is that the case? I would install them in separate folder to prevent conflicts between the files.
thanks for your reply. im trying to use the version which comes with the latest mdx version (so fxe is part of mdx)

edit: standalone downloaded, works fine. thank you!
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Where do you find a version that is part of MCX? For many years I have stopped to distribute them together. So that must be a very old build then.
 
Top