P3D v4 (Ghost Bridge), crashbox resolved

#1
Hello, I have redesigned an airport with ADE, (thanks to all the team for such an excellent job), and I have compiled it for P3D 44. Extending the Test Radius I have left a bridge of the P3D scenario within the airport range, I have also drawn a new bridge and I have canceled the generic P3D with a Exclusion Rectangle of the ADE, everything is OK, but I can not fly under my new bridge, because I collide with the old bridge excluded, the exclusion makes it invisible but the obstacle is still there, Any idea how I can remove that obstacle?
I am not interested in flying with deactivated collisions.
Thank you
 

tgibson

Resource contributor
#2
Are you sure it's not your new bridge that is causing this problem? Temporarily remove your new bridge and fly where you would if you were flying under it. Do you still get the crash?
 
#3
Thank you very much Tom for your attention, I'm doing tests but I can't find anything conclusive, if I position the new Bridge elsewhere if I can go under but if I place it in the same position as the excluded generic I can't pass, I will do some more test and I tell you
Thank you
 
#4
I have already gone crazy, sometimes I go under and sometimes not, without any apparent obstacle, I begin to believe that you are right Tom and that it is the New, but I can not see what happens to him and why he does it, I have drawn it with Sketchup and I have compiled it with ModelConvertX and everything seems to be OK, can you think of anything?
Thank you
 
#5
Do not exclude the generic bridge! You have to find and delete it!
Oops, sorry, an exclusion should do it also.
When placing your model of the bridge or the bgl as a scenery object, make sure you check 'no crash'.
 
Last edited:
#6
Thanks Roby, I think you have given me an idea, if as you say I mark my bridge 'no crash' and I keep hitting it, it has to be the generic underneath, excluded.
Regarding eliminating it, it is a bridge that generates with different parts, the structure on its side and the platform on the other, it does not seem feasible to eliminate it, we would eliminate many others from P3D
Thank you
 
#7
great Roby, Tom is right, it is the new Bridge, by marking on the corresponding object 'do not crash' as you told me, you can fly underneath without problems, anyway that does not solve the problem, I would like to find out what happens to that bridge that I have drawn
 
#8
I am not sure either. I just know that I excluded a bridge in VVCR and replaced it by an extrusion bridge but I have not tried to go underneath it with a boat.
 

tgibson

Resource contributor
#9
Hi,

Are you placing your bridge at a scale of 1, or something smaller or larger? If so, the crash box does not scale and remains the size of the object at a scale of 1. This can cause the crash box to not align to the object.

Also, you can Display the Crash Boxes in MCX (it's a button) and that may give you some idea where you cannot fly.
 
#10
Thanks Roby, I fly under with a plane, the bridge is big and tall, that way I sometimes pass a little higher or a little lower and the tests are more reliable
 
#11
Thanks Tom, the scale I use is 1, I'm very careful with that, I read a lot about it, interesting about Crash Boxes in MCX, I'm going to check it, thanks again
 

Pyscen

Resource contributor
#13
Hello

If the image is showing the crash box(es) - I would say, "yes, you can't fly below. Except for the very small area at the bottom"
 

tgibson

Resource contributor
#15
Hi,

There are two Options settings in MCX that may help you (but I'm not sure). Options/Exporter Settings (scroll down). The first is SetCrashBox Granularity, which you can set to TRUE. After that, the CrashBoxGranularity value will set how "tightly" the boxes wrap the object. You will end up with more crash boxes, but it might help you fly underneath? Try a number of 0.5 first - that seems to give you a tighter wrap.

Hope this helps,
 
#17
Hi,

There are two Options settings in MCX that may help you (but I'm not sure). Options/Exporter Settings (scroll down). The first is SetCrashBox Granularity, which you can set to TRUE. After that, the CrashBoxGranularity value will set how "tightly" the boxes wrap the object. You will end up with more crash boxes, but it might help you fly underneath? Try a number of 0.5 first - that seems to give you a tighter wrap.

Hope this helps,[/ QUOTE]

Thanks Tom, I was very clueless and your help solved the problem, in fact the CrashboxGranularity parameter with value 0.8 was enough for a spectacular result.
Thank you very much for your help
 

Pyscen

Resource contributor
#20
Glad you got it working,... I can't take any of the credit, you and Tom did the grunt work. :p I was just the support or cheering section :laughing: :greenflag
 
Top