Ground Poly Materials


I'm currently working on my first ground polygon. It's created in Blender, I've then exported it to MCX to use the ground poly wizard.
When exporting it into the sim (P3Dv3) I get the following results:

The Problem
Some parts of the model are much too dark, and look like they're covered in a constant shadow.
The different modelparts in the images are made up of two different materials.
Specular and bump maps also seem to work only on some parts of the model.
Correct.png wrong.png Spec.png

Here you can see how it looks in MCX:

All materials with diffuse, specular and bump maps are assigned in Blender. In MCX everything works as expected with speculars and bumps etc.
Note: In this example I didn't split the ground poly into 100m slices when using the GPW, so you can see everything better. I get the same results if I use the 100m slice option.
Here are the properties for one of the materials;
Material1.png Material2.png Material3.png

The normals also seems to be correct when viewed in MCX:

Some more info
The materials are on different layers, 20 and 16, but don't actually intersect/overlap on this part of the GP. I've tried placing them on the same layer too without any changes.

I've also tried:
Compiling the GP into both FSX and P3D formats;
Having only one material in each BGL file (running the GPW one material at a time);
Placing the Ground Poly slightly above the ground;
Running the GPW from a .dae and .mdl file; and,
turning of Slice polygons (100m);

The texture format is DDS with DXT5 compression.
I get the same result in P3Dv3 and P3Dv4.4

I believe there must be something vital I've missed. Thank you in advance for your help.

I wish you all a happy new year!
Jakob B
Hi Jakob,

I have not read your message through to the end but there are two (apparently three) things that I would like to draw your attention to:
1. In P3Dv3 and 4 (at least up to 4.3 because I am still reluctant to update to 4.4), groundpoly layers should be negative and two of the major mistakes in compiling with the GPW are either not put in the airport ASL elevation or to not have a flatten terrain big enough to cover the (squared) GP p;oly.
2. (I have not yet updated MCX yet as, as I said, I do not have 4.4 installed so no need for me to update MCX but) Arno is rather busy in trying to update MCX to make it compatible with 4.4 and its new peculiarities regarding PBR materials and probably some more stuff I am not familiar with. Maybe your newest MCX dev release is still having some bugs (Arno?). I am running MCX version dev release of Aug 18 2018 and I have no problems with neither P3Dv3 or P3Dv4.3.
3. You are NOT supposed to put your groundpoly slightly above the ground but at the elevation of your airport AFD and flattened all over the extension of your GP's.
Andf I wish you all and you in particular a solution for your problem before the year is over.


Thanks for your reply Roby!

I've actually tried inputting negative layers in the GPW (-20 and -16) for the materials, but I didn't see any changes.
I tried using both the newest and an older version (Not sure which at the moment, but I can look that up) of MCX and the issue was the same.

A very good point is that I'm need to check so that the flatten terrain in the AFCAD is correct and big enough and overlook the altitude I put into the GPW, there might be something there!

I'll update the thread after some more testing.

Best Regards,
Jakob B
Hello again,

I've continued to troubleshoot and also tried to just export the object without running the ground poly wizard; The problem was still there.

Before, I exported the object from Blender to .dae, instead I tried exporting to .3ds max, and I'm happy to say: Problem Fixed!

Apparently exporting to .dae from Blender can give me some weird results in sim. Exporting from Blender to .3ds fixed the problem.

Best Regards,
Jakob B
Hello all!

I've done some more digging into this issue since I experienced it again when I exported to .3ds max.
The issue was one big thing that I had missed: converting the bump map to FSX-format.

Here's why it "worked" to export the objects as .3ds the first time:
I exported the object as .3ds from Blender. There's seems to be character limit on the textures names for the .3ds format so I had to open up the file in MCX to fix the file names. Upon saving the file as a .3ds again, MCX removed the texture slot for the bump texture (maybe this is by design?) and when I then used the ground poly wizard everything worked, because the wrongly formatted bump map wasn't there.

Updating the format fixed the problem.

Best Regards,
I'm actually facing the same problem, and I figured that converting the normals maps to a FSX type normal map should fix it. However, I can't seem to save the converted normal map... I click the "Save textures" button (ensuring "overwrite existing" is checked), but nothing is ever saved. So whenever I reload the model, it displays the same non-FS type normal maps and the problem continues. Does anybody know what to do? How can I save the converted normal maps?

EDIT: I've found that for some reason it seems fine saving TIFF formatted textures, but it seems unable to save any DDS formatted textures... Any ideas why? I'm using the latest development release.
Last edited:


Staff member
FSDevConf team
Resource contributor
ImageTool is used to make the DDS files. Is the path to the tool in your options correct?
The link to imagetool seems to be fine... I came up with a workaround for now. I export as TIF and then use DXTBMP to manually convert the textures back to DDS. Now the textures appear correctly in the sim :)