Hanger model Size problem

#21
Just for clarifing I have only used the unit scale of 0.304800 which is the default. It stays at 0.304800 whether or not I use Metric or Imperial. I have made many models using only Blender on default unit scale, MCX and collada files. Models are to scale everytime. If I were to change the unit size to 1 the models would be 3.4 times larger in MCX. This is the first time I have tried the FSXtoolset. I thought I would try it to see if it would make hanger modeling easier. I have not found any tutorials for hangers or buildings made using the toolset only aircraft so I thought I would try to make a hanger. I haven't made any aircraft models yet.
Maybe Ed is right about a bug in the Blender2FSX/P3D Toolset .
 
#22
Just for clarifing I have only used the unit scale of 0.304800 which is the default. It stays at 0.304800 whether or not I use Metric or Imperial. I have made many models using only Blender on default unit scale, MCX and collada files. Models are to scale everytime. If I were to change the unit size to 1 the models would be 3.4 times larger in MCX. This is the first time I have tried the FSXtoolset. I thought I would try it to see if it would make hanger modeling easier. I have not found any tutorials for hangers or buildings made using the toolset only aircraft so I thought I would try to make a hanger. I haven't made any aircraft models yet.
Maybe Ed is right about a bug in the Blender2FSX/P3D Toolset .
Hi,

I am using Blender v2.79 and each time I open Blender the unit scale stays at 1.0 without bothering the length: Metric or Imperial. So, I'm confused where does the problem now. As per your info, the unit scale stays at 0.304800 but for me it stays at 1.0. So, I hope someone could help to find why this number different occurs. Is it any settings to be changed in blender itself or any other things need to be configured.
 

Pyscen

Resource contributor
#23
Hello...

Both @2wheelsup (Alan) and @MANOCHVARMA RAMAN are correct. In testing the Unit scale, it should be at 1.0, but once that value changes (I'm not sure what is changing it, as of yet), you can't just change it back to 1.0 because it changes the object(s) size upon export. As Alan states, increases it's size by 3.4 times. Starting up Blender, the Unit scale is 1.0 whether its Imperial or Metrics for me. It's not changing the value just because I'm changing from Metrics to Imperial or Imperial to Metrics. Something else is changing it.

Alan, can you verify that when you start up Blender that the scale unit is 0.304800 (with no object loaded)? If it does, then it is something within your set up within Blender is causing it. What needs to be found out, what's changing it and if it changes the value, how to change it back to 1.0 without affecting the export size (I would think it would be done by a combination of commands to do so).
 
#24
Hi Doug,
Ok, when I start Blender 2.79 with nothing loaded the unit scale is set to 0.304800.
I have set my preferences to load a blank screen. No cube, lights or camera.
 

Pyscen

Resource contributor
#25
Hello @2wheelsup (Alan),....

Ok,.. that means at one time or another, the unit scale was changed to 0.304800 at some time prior to a "Save Startup File" (or Ctrl-U) from the "File" tab at the top (after removing the cube, lights, and camera), when you saved your preferences. The only problem to that: you will be unable to export from the toolset correctly, because of the unit scale change. So, any object you created after that will not export correctly through the Blender2FSX/P3D Toolset, but there is 1 possibility in correcting this.

First thing you need to do is startup Blender and before loading any file, change the unit scale to 1.00 and you can leave it at Imperial. After you do that, "Save Startup File" (or Ctrl-U) from the File tab at the top. Now, if you still have the Collada (.dae) file, that has the correct measurements, import it from the "File" tab. This should correct the object back to the correct state for both Imperial and Metrics and specifically the use of the Blender2FSX/P3D toolset. Make sure after importing, that you reset the rotation and scale to 1.0 as well, very important.

Unfortunately, we are not sure how the unit scale was changed... :rolleyes:.
 
Last edited:
#29
FIGURED IT OUT!!!!! :p
When you first open a new Blender session and look in the Scene selection Units window and it will show Unit Presets. Next window down will show Length - NONE, below that shows Angle - Degrees, Unit scale = 1.000000.
If I click on the Unit Presets button and change the units to FEET. The program automatically changes the Length to Imperial and the unit scale to 0.304800. Click on any other selection like inches or centimeters and it will change the unit scale accordingly.
I guess the Blender2FSX/P3D toolset doesn't like anybody changing the Unit Presets to anything. Leave that button to default. I can change it back to a 1.000000 like post #25 recommends and it will still work though.
Mystery solved. :D
 
#30
I tested a couple of simple objects to see what would happen if you set the Units to feet and then changed the Unit Scale back to 1. After starting Blender I set the Units to feet and changed the Unit Scale back to 1.00000. I then took the default cube and made 3 changes. 1)I moved it 3.28' up the Z axis. 2)I moved the top side up the Z axis by 22'. 3)I gave it a pure white material on all sides. Then I exported it as a dae file, imported it into MCX and exported it as an FSX model file. I exported it again using the Blender2FSX/P3D toolset. In ADE I added both objects as models in an FSX airport project and placed them. Both came out the exact same size. See attached image. Lesson learned if you change the Unit to feet then you are going to have to manually change the Unit scale back to 1.
BlenderTest.jpg
Edit: Just to be clear the model on the left was exported from Blender as a dae file. The one on the right was exported using Blender2FSX/P3D.
Ed
 
Last edited:
Top