P3D v4 Jagged shadows on PBR ground poly

#1
Hi

Before I go too far badgering LM (no answer to a post yet), I want to check if MCX has any influence over how shadows are displayed on ground planes.

With PBR set to true on a ground plane, I find the shadows, like AI aircraft, are considerable more jagged. So much so that the flicker effect makes the pbr ground unusable. Take the same plane and just flip PBR from true to false, and all is well.

Here are some examples images on a simple untextured plane placed with MCX ground poly wizard. The PBR version has zero setting for both metalic and smoothness. You can see how much more jagged it is.

pbrground.jpg


nonpbrground.jpg


I have tried using or not using the various options in the ground poly wizard, and many combinations to texture setting, but nothing I have fried makes any difference.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

How the shadows are rendered is more something of the scenery engine I think, so I'm not sure if there are material settings that influence this.
 
#3
Good to know its probably not my error. Hopefully it will get noticed as payware developers start to release scenery with pbr ground. Maybe the mythycal dx12 will help. P3dv5 anybody?
 

Pyscen

Resource contributor
#4
Hello...

This could be caused within a setting within P3D as well or even graphic card RAM (lack of, that is). Have others experience this with your scenery?
 
#5
I have not released the pbr ground version yet, due to seeing the shadow issues. I could add a link to test files here if anyone wants to try. My sim machine graphics card should cope really, 1080Ti with latest driver (and it happens with previous drivers). Free RAM is OK.

Tried various different settings in sim. Highest shadow quality (shadow map size also increased in cfg to 4096 and 8192), with/without dynamic shadows, with/without HDR lighting, max tesselation.
 

Pyscen

Resource contributor
#6
Hello...

Sorry for the long delay in getting back to you on this... if you wish to share a link that would help.
 
#7
I set up a little test at a default airport for LM to view. Be interested to see if you can see jagged shadows too;

I have set up a pbr and non pbr plane at KPMD. There are simple crosses to make aircraft type shadows floating above. You need buildings cast shadows to see them of course.

Add files to library then start a flight at KPMD. If you slew slowly towards the areas at shallow angles, as if taxiing or landing, you will see the pbr shadows jingle madly. The ones on non pbr ground perform well.

It should be obvious which is which. If in doubt, non PBR plane is closest to rnwy 25. Settings seem to make little or no difference, so use whatever.

I get this effect on middle range development pc with pure stock install of P3d, and on high end sim pc with add-ons. V4.5

files here
http://darkanvil.net/fs9/KPMD PBR Test.zip
 

Pyscen

Resource contributor
#8
I have taken a look at the test models and possible jagged shadows... unfortunately though, I'm not seeing it...

Just to give what I have seen:

There are 2 groups of crosses - I installed everything that is in the KPMD zip file above and activated it. Also, panned up and down and I'm not seeing anything abnormal at all in the shadows (with either group of crosses). Here is what I'm seeing in 2 screenshots:

Group 1.png


the 2nd screenshot is taken directly or just beyond the 1st grouping:

Group 2.png


Not sure what you might be seeing that would cause what you are seeing, except for maybe graphics card or again, settings.

Might want to share screenshots of your settings now.
 
Last edited:

=rk=

Resource contributor
#9
Very nice. I think it would be valuable to see your results with the reflective models, as well.

 
#10
Hi Pyscen

You are seeing the jagged shadows. Look at the aircraft slightly further away in your first image, the pbr plane. They are already very jagged. The furthest away shadow is already mising its wings. This does not happen with shadows over normal ground. Fly around or taxi up to them in a stock aircraft with clear skies, and you'll soon see the jags dancing, compared to the other set especially.

RK, have you seen the test shots in other post about the reflections. PBR ground reflects back as near black I have found, when setting above medium.
 

=rk=

Resource contributor
#11
you, have you seen the test shots in other post about the reflections. PBR ground reflects back as near black I have found, when setting above medium.
Not true. All we have seen is a preliminary test, then extensive tests that reinforce the preliminary test, to the point that you are drawing conclusions
I guess it is just the way PBR is implemented. Not a fault as such, but something to consider when designing PBR objects and scenery. Texture mapped objects have same issue as these objects using only diffuse.
all performed with the same system and video card. You really should quantify this across a range of systems.
 
#12
The jagged shadows are there in Pyscen's screenshot, so it is not system specific in my simple world. Can't remember all the system specs, working remotely, but the cards are;

Nvidia 750gtx 4gb ram
Nvidia 1080ti 11gb ram

Maybe dancing shadows just won't worry others. I shall finish my PBR scenery update and upload for all to play, and see what the reaction is.

LM have the test files. No reaction back yet though.
 
#13
The current PBR implementation have many deficits. There are Problem with night renderings, with the shader model of the smoothness values in the PBR shader itself (Roughness Map) in combination with the dynamic reflections.
The current display for dynamic reflections from the angle of the camera view is also a mediocre solution, which definitely needs to be improved.
Im in contact with a developer and we try to find solutions for the current situation. We have to look at LM and hope that the issues raised will be improved in the near future. (Prepar3D V5.X)
 

Pyscen

Resource contributor
#14
Hello...

The tests in question are questionable for a couple of reasons: 1) No textures were used in the tests only colors. As in no metallic map, bump maps or albedo maps, therefore, no mipmaps. This alone can cause jagged edges. 2) The Settings within P3D have not been set in both PCs as the same or equal. 3) The Graphics card drivers haven't been confirmed to be updated to the latest. or the settings within the drivers itself have been set equally (specifically, the antialiasing). Though, your graphics card are both above the minimum requirements.

The initial reason could be the cause of the anomalies for both the shadows and reflections within the other thread. Because of this, you are asking the Shader within P3D to overwork (per the SDK, you are not utilizing the P3D engine by "its" design).
 
Last edited:
Top