FS2004 MDL won't compile when adding seasonal texture

#1
Hi Arno

I'm trying to add a seasonal texture to a simple model for a fellow simmer after he also had trouble adding it.

MDLT2 adds the seasonal texture ok, I then click update texture and save the tweaked file. When I try to compile with ADE (or even manually) the mdl won't compile.

In the Gmax scene is a small building, a car and a bunker. I stripped it down to just the bunker which is only 34 polygons and shouldnt cause a problem.
I tried one of my own more detailed models and it worked first time? and I can reopen it in mdl tweaker 2 and model converter X. When I try to reopen the tweaked bunker.mdl it crashed MDL Tweaker 2 and MCX.

It crashes MDLT2 with

'Run-time error '100':

Unrecognised BGL Opcode: 60


I can't see any reason why it won't work.

I have attached the untweaked mdl

Thanks

Stevo ;)

Edit: I should add that I am only trying to add a winter texture
 

Attachments

Last edited:
#2
Update

It seems that any new mdl I export from Gmax wont compile with a seasonal texture added and it results in the above error when reopened in MDLT2, but any older exported mdl which would have been exported from Gmax on my old PC seem to work fine :confused:

I upgraded my PC in November, and changed from Win XP to Win7, dont know if this has any bearing on the situation?

I tried making a textured cube which also wouldnt compile with a winter texture added.

:confused:
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#3
Hi Stevo,

I get the same problems. I think your MDL might have been made without optimization, I think there is some debugging code (BGL_TAG) in it. MDL Tweaker probably get's confused by that. So I would double check if you have the optimize option on in MakeMDL.
 
#4
Hi Arno,

Arno to the rescue....Thanks for pointing me in the right direction, I had Debug in the makemdl.cfg file. I dont know if this is the same as optimise but thats what was causing it. I dont even remember putting the debug switch in the cfg :confused:

Works ok now, thank you

:D
 
Last edited:
Top