• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Blender Normals/Shading issue

Messages
221
Country
unitedkingdom
For my aircraft model I'm struggling with a shading issue which I am positive is caused by the normals of the model.

When I cut out the flaps, spoilers, main gear doors and main gear wells, I had set shading of the wings to flat.
When I set shading to smooth the shading of the different wing parts didn't match up. I believe this was caused by the parts being separate objects and therefore shaded individually.
Autosmooth off.PNG

If looking at the model in MCX and FSX the shading seem to be consistent with how it looks in Blender.
MCX.PNG
Video from FSX:

If turning on auto smooth for the wing parts the model looks ok in Blender, however in MCX and FSX the shading hasn't changed. If comparing the mesh normals in the generated .x file, the sections are identical whether autosmoothing has been turned on or not.
Autosmooth.PNG

Does anyone have any suggestions on how to solve this?
 

Pyscen

Resource contributor
Messages
2,526
Country
us-texas
Hello...

Unfortunately, I don't know of anyway, but have you tried placing it through MCX (it also has a Smooth function within the Options tab?
 
Messages
221
Country
unitedkingdom
Thanks Doug,

Is this the SmoothShadingNormalTolerances? Should I expect parts which fall in below the dot product value to look smooth if I use it?
 

Pyscen

Resource contributor
Messages
2,526
Country
us-texas
Sorry,... it's under the Special tools tab -> Normal & Shading
 
Messages
221
Country
unitedkingdom
Thanks Doug,

Ah, had a two year old version of MCX, so no wonder I didn't find it.
Unfortunately, this yielded similar shading results, with each part shaded separately.
 

Vitus

Resource contributor
Messages
1,480
Country
newzealand
Hi Morten,
A couple of things...
1. More edge loops! There's no need to have polygons that span the whole wing - break the geometry down a bit more and try to get the polygons as square as you can to avoid problems later on. Protip: watch some tutorials on how to create good topology and how to avoid n-gons.
2. Select an object of your model, let's say the wing, tab into edit mode, "a" to select all, right click->Shade Smooth. Then, go to the "Object data properties" (green triangle), go to normals->and switch "Auto Smooth" on. Increase the angle to 90.
Having done that will now smooth everything that has an edge-angle of less than 90 degrees. Now comes the fun part: while in edit mode, press 2 for edge mode and select all the edges you want sharp. Right click->Mark sharp.
3. Now everything should look dandy in Blender, however it won't fix it in the sim, because the exporter can't auto-export those sharp edges. To fix that, go to the modifiers of the object and add an "Edge Split" modifier to the selected geometry.For more control, I'd recommend you untick the "edge angle", so that the edge split is solely controlled by the "mark sharp" edges you place.
4. Rinse and repeat the process for all geometry.
 
Messages
221
Country
unitedkingdom
Excellent, thanks. Edge Split modifier solved it for me.
Also, great tip on more edge loops. I will keep this in mind for my next AI model.
 
Top