P3D v4 object reflections+ adding shadows

hi all
I'm currnetly working on a new airport, these time I've decided to create every surface in the airport(rwys, taxiways, aprons, etc ) with sketchup using my own modified textures
after I've finished creating the runway, Ive converted it to a BGL and loded it into my scenery in my sim, it reflected the sun light SO MUCH.
1. how can I reduce the sun reflection of my object?
2. how can I add shadows to my objects?( for example when the sun is out and the aircraft is on the runway, there is no shadow under the aircraft when I'm next/on the object/runway)

thanks in advance
Last edited:

IIUC, you have created flat 3D objects with ground textures as mapped Materials, then imported this to Arno's ModelConverterX as scenery library objects ? :scratchch

These will have shadow and flicker issues until a number of custom settings are used for that MDL to 'minimize' (but not eliminate) graphical anomalies.

In ModelConverterX (aka "MCX") Ground Polygon Wizard, you can import that 3D model and apply a "Z-Bias Material Property" for proper display in P3D. :idea:



Hope this helps ! :)

Thanks for the reply Gary
Correct, I have created a flat 3D object, I have imported it to MCX but I didn’t knew that I have to use the ground polygon wizard.
the first time Ive imported it to MCX it flickerd but in the sim there was no flickering at all...
so the reflection and shadows are the only main problems so far...

Last edited:
Missing shadows on ground polys in P3D4 are normally due to the settings within the simulator, try setting Buildings to receive shadows. Or maybe Sim Objects if that doesn't work...
The 'reflection' I guess is the specular shine, which you can tweak in MCX a number of ways -- simplest is to darken the specular colour. You can also create a specular map which gives you control over different surfaces in your model, or for objects which don't normally shine you can turn on 'no base material specular' to get rid of it completely.