• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Objects exported with Blender appear in the sim in dev mode but not when flying

Messages
4
Country
spain
Hi all!! (excuse my poor english)
I have succesfully made two sceneries with landmarks. I get the data from "that other web that is not Bing" , imported into blender and export to gltf. Made the sceneries, place object in dev mode, compile, exit sim, copy package to comunity folder and relaunch.

All OK.

Now I'm testing PBR objects. Made the monkeys mesh in blender, apply some textures, export to glft... I can see the object in 3D with de Windows viewer.
I make a new scenery, put de textures and de object files where they must be. Launch the sim, compile de proyect, close proyect, reopen and now I can add the objects to the scenery and see it:
i1.jpg


Compile, No errors, exit sim, copy package to comunity folder, relaunch and when I fly to to the place, NO MONKIES!!!!
Clean packages, delete folders, recompile.. All the same. I can see the objects in dev mode but not when flying ( in the packages I can see the correct DDS textures)

More...

I decided to add another object. One that I made for the previos sceneries:
i3.jpg


You can see the new building close to the monkies. Save, compile, exit, copy package to Comunity, relaunh, fly.. and:

i4.png


The new added object appears but NO MONKEYS!!!

I can't figure what is happening. I deleted all textures from the monkeys except albedo. Same result. Y delete even the albedo (white object) same result.
I even created a new object, a simple cube in blender, no textures. I see it in dev mode, a big white cube, but not when flying.

Any ideas about this behaveour??? Is there any scenery log where see meesages and find why the sim is not showing some objects??
 

Attachments

  • i4.png
    i4.png
    789.3 KB · Views: 136
Well, more clues!!!

I decided to begin again. So deleted scenery and made a new one. Only one object, a simple blender cube with no textures

Put it on scenery, compile, etc.. and again..

No cube when in flight... BUT suddenly, as the plane get near the positión of the cube, it suddenly pop up, apearing in the air!!

Close de flight, relaunch and de the same. The cube appear suddenly when de plane get near.

I put de monkey side by side the cube, recompile, exit, relaunch and... No cube, no monkies but when de plane get closer... they appear.
 
Thanks karlo922

That solved the issue. Rethinking the problem, I think that it is a bug in the sim.

The original objects where small. The box, for example, was 1 meter long. In the sim I scaled it to be a very biiiig one ( 100 meters), but it appears that for the sim it has only one meter, so it draw it only when a 1 meter object is near enough to the plane to be seen. But a 100 meter cube suddenly appear in fron of you!! LOL

I Scaled the cube in blender to be 100 meters long and scale to 1. The same for the monkeys. Now the two objects appear correctly from the begining and no pop-ups

Thank you
 
Back
Top