problems with placing

#1
hi
Ive an issue with MCX, Im working on a project and now I need to place my work.
my problem is that when I use the same coordinates it doesnt fit perfectly.
first image(top down):
ive used the GP wizard for the taxiways(ignore the black textures) and the "place and convert wizard" for the objects.
same corinates for both.
what its suppose to look like is that the small aprons on the sides of the taxiways will be coverd by the objects.

as you can see in the second image the GP and the objects fit perfectly in MCX(the merge was done to show that in MCX and in SKETCHUP they fit perfectly.


any solution?

thanks in advance :)
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

Two things come to mind here.

  1. You probably need to correct your objects also for the curve of the earth, else you will most likely see small offsets from the ground polygons that have been corrected by the GPW. But since you have a huge offset now, this is not your main problem.
  2. Are you sure the ground polygons and objects have been exported with the same origin from SketchUp? If that is the case entering the same position in the GPW and the Convert and Place Wizard should work fine. Be aware that the GPW can optimize the lat/lon position when creating the ground polygon BGL, so you should not use the position you see in that BGL for your objects.
 
#3
hi
The GP and the objects have the same origin is Sketchup, they were built on top of each other and then were separated.
And the coordinates that I use for all of my placings are taken from a chart.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#5
Nope, without more information I can't think of anything else.

Did you double check the reference point of the two KMZ files is at the same location?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#10
Hi,

I have exported your two objects with the same position on my PC (to a test location) and they line up fine (don't mind the green/red checkerboard, that's another test file that was still active). So I think you need to double check that you used the same position for both.

1549912800890.png
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#12
I doubt that would matter, are you setting a heading for the objects as well?
 
#13
yes, but its the same as well

I think it has something to do with the fact that im using the GP wizard for one file and the place and convert for the other...
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#16
To get rid of that small offset you would have to run the earth curve editor on the model of the buildings.

Which settings did you change to fix it?
 
Top