P3D v4 SBuilder 3.15 issues

#1
Due to a motherboard failure I have performed a clean install of Win 10 (1803) and a clean install of P3Dv4.3. Some issues/questions...

1. Firstly does SBuilderX (any version), require a true installation or can it just be run from any folder just clicking on the .exe? I was using 3.14 32bit to create polys but using SBuilderX 32 for the first time since the OS install the poly bgls are being created but are having no effect in P3Dv3.4? Others having any issues?

So thought I would try SBuilderX 3.15. Reading the instructions I copied over the 3.15 over my working 32bit SBuilder version.

2. Upon opening SBuilder can never find the path of FSX. It is only a folder I created with all the FSX files but is not a true install. Is SBuilding looking for something in the Registry?
3. Once past that the program shows error: "Could not load file or assembly 'NokiaMapServer' or one of it's dependencies." At that point all I can do is close the program or it will not load.
4. If I just run the 3.15 program on its own (the compiled download version), without touching my previous version the program will run (still can't find FSX), but there is no longer a 'Preferences' selection available to select a background map.

Any input, ideas whatever based on your experiences on what to do or try?

Thx
 
#2
Hello:

Set the Windows Registry entries for FSX via:

FSX/FS9 Registry Repair Tool

http://www.flight1software.com/files/FS_Registry_Repair.exe


Prepar3D SDK ver. 1.4x (aka "ESP" / FSX-SP2) and Prepar3D SDK ver. 4.x auto-configure SDK paths into Windows Registry

https://www.prepar3d.com/support/sdk/


Do not mix an existing SBuilderX ver. 3.13 or 3.14 installation with files from the new 3.15 version; unstead, use a new folder chain created from rhumbaflappy's "complete" SBX315 ZIP package (just un-ZIP; no 'install' is required):

https://www.fsdeveloper.com/forum/threads/sbuilder-x-install-problems.443082/


FYI: Windows 10 issues with CVX vector processing by SDK SHP2VEC have been resolved with the new SBuilderX 3.15 version.


Nokia / Yahoo, tileservers are discontinued; 'original GoogleSatellite' DLL is deprecated ...use Google_api3_Satellite instead.

Be certain to 'check' the "Use <tileserver name> ?" checkbox for a selected tileserver during first use of SBuilderX.

Note that SBuilderX version 3.15 "Google" tileserver DLLs reportedly no longer require updates.


Hope this helps. :)

GaryGB
 
Last edited:
#3
Sure did help Gary.

Got the FSX path thingy corrected with that little tool.

So I have installed (well, created a folder), for 3.15 by itself. Unfortuanately it does not recognize older projects create with 3.14. Liveable. But it has no 'Preferences' option? Has that been removed. How do I switch map types like from Google to OpenStreetMap? Manually edit the ini file?
 
#4
FYI - With 3.15 I was unable to create a waterpoly that worked in P3Dv3.4 using the resample included in SBX315. It did create a bgl with no issues, just had no effect in P3D. So I noticed the P3Dv4 SDK had a different version dated 2/18/2018 at 332kb. SBX315 was dated 7/16/2018 at 313kb. I replaced the bglcomp.exe with the one from the SDK and lo-and-behold my waterpoly worked. Maybe worth looking into?

So SBX315 (full package) seems the way to go but I still don't have a 'Preferences' selection anymore? :)
 
#5
https://www.fsdeveloper.com/forum/threads/sbuilder-3-15-issues.443352/post-803769

So I have installed (well, created a folder), for 3.15 by itself.

Unfortunately it does not recognize older projects created with 3.14. Liveable.
SBuilderX ver.315 should be able to "recognize older projects created with 3.14."

SBuilderX ver_3.15 Menu > File > Open > Browse: [SBuilderX ver_3.14 install path]\Tools\Work > double-click a *.SBP

...or:

SBuilderX ver_3.15 Menu > File > Append > Browse: [SBuilderX ver_3.14 install path]\Tools\Work > double-click a *.SBX


FYI: A Stand-alone utility has now been written by Luis Sa' to convert SBuilderX v_31x *.SBX to FS9 v_2.05 *.SBX format . :wizard:

https://github.com/LuisVSa


https://www.fsdeveloper.com/forum/threads/sbuilder-3-15-issues.443352/post-803769

But it has no 'Preferences' option ...Has that been removed ?

How do I switch map types like from Google to OpenStreetMap ...Manually edit the SBuilderX.ini file?
Explore the SBuilderX ver_3.15 Menu system; "Preferences" has been split into (2) separate < Edit > sub-menu items ! ;)

SBuilderX v_3.15 Menu > Edit > Object Folders

SBuilderX v_3.15 Menu > Edit > Tileservers

GaryGB
 
Last edited:
Top