FS2004 SBuilder won't work after installed

Two days ago, accidentally with stupid my mouse click moved my whole FS9 to the OneDrive Temp and I found and brought it back C: drive and found something with flight simulator files deleted, and all is working fine running FS2004 is fine. I just click Sbuilder desktop it pops up error cannot exist. I uninstall SBuilder and restart and I did for wait bmp built in my FS9. Done and I got open SBuilder Open project under run FS9 slew. I click"Aircraft view" and it "Error communication with FSUIPC".. I checked double and double and registry FS9 done and etc.. FSUIPC is still in the Modules folder under Microsoft games/flight simulator 9. I don't UNDERSTAND it. I tried and tried and tried. Nothing luck. Can you tell me what should I do with this Windows 10 to edit regedit or something else? Remove .ini file somewhere? How? It was working 2 months ago installed everything in my new computer Windows 10. Windows 10 is a pain in the NECK! It drove me crazy right now SBuilder does not work. Please help!

Thanks,

Stuart
 
Last edited:
I took screenshot to see this what am I doing wrong or missing file coming from? I have NO IDEA!

It was working 2 days ago some stupid Windows 10 moved my FS2004 folder went off to the One Drive Temp and I took it back and now lost track and some dumb locked registry path or something... I don't know why Windows 10 gets me a hard time and locked me up! It's very frustrating. It does not make sense at all.

Thanks,

Stuart
 

Attachments

I tried to FSTweaks program but it did not work with SBuilder start again. It still popping up "Error communicating with FSIUPC!" What was this and where is coming from the cause? What is that? Why?

Stuart
 

rhumbaflappy

Moderator
Staff member
Resource contributor
I don't have FS9 installed but I can help a bit. First, I moved your thread to the correct forum. Next, I think I can clarify your actual problem: SBuilder is actually working but cannot establish a connection with FSUIPC. Does the FS9 FSUIPC work with any other program? Is it the right FSUIPC (there are different versions for different sims). FSUIPC 3.999z9
 
Yes, it is the same FSUISP before last week I used it SBuilder and FS2004 works fine I said 3 days ago, I accidentally with stupid mouse click somehow it moved folder a whole thing FS2004 to other folder hidden on One Drive Temp folder. I don't know why the explorer DID NOT ask me OK to move. It's STUPID computer I brought it back to where C:/ FS2004 folder belongs to. I just fixed and I did not know until I want to use SBuilder it went poof error communicating What is the heck going on with this thing? I did NOT touch FSUIPC change or anything!!! It pisses me off I struggled all day and today. Not working! It does not make sense! Stupid Windows 10 thanks a lot!!! Windows 10 loves to BLOCK everything my own programs what I want to I already did UAC permission or edit or change my own programs Something is wrong with Windows 10 blocked my SBuilder or FSUIPC I don't know where it comes from! It makes me so MAD!

Stuart
 
Last edited:
OF COURSE! I said It was the same as before 3 days ago work perfectly fine. The stupid mouse moved my FS2004 to another folder accidentally. I bring it back where belong to C;/ The module was not changed. I see FSIUPC still there in the module folder. I don't get it why windows 10 system blocks me everything!!! Sbuilder cannot read path somehow lost connected and I reinstall new SBuilder and doesn't work and I installed 4th times SBuilder. Still won't work! I tried and tried everything. Stupid windows 10.

Stuart
 
I might have to reinstall Flight Simulator 9 tomorrow and see what happens stupid Windows 10 and maybe Sbuilder needs to clear up path new FS9.exe etc. If you move or change FS9.exe that SBuilder will not work I found somewhere forum. Stupid system in the world!

Stuart
 

gfxpilot

Resource contributor
'stupid Windows 10 '

ok interesting. I had the same issue with fsx on win 10 - that also reported FSIUPC as a failed communication.

Bob and Gary offered the helping hand I have links to go thought to get the latest version of everything (below is the link to that thread

(https://www.fsdeveloper.com/forum/threads/sbuilderx-315-anyone-using-something.447777/)

I updated everything even if I thought I already had done it and surprise surprise it all seemed to suddenly work.

One Questions - Can see that in the image you posed that Flight sim is running - silly question please done get offended but are you starting flight sim before launching SBUILDER?

If yes is flight sim on pause because I found that caused comms issues as well. Basically flight sim on where you want to be in the airport of choice, brake is on and pause id off.

Then launch SBuilder X and text agaiin
 
Should I not use Slew on? Just leave the plane on ramp or runway brake on. Then to start install SBuilder to set it up? I am not using SBuilderX It's SBuilder FS2004 only. I guess I will try do this process again without Slew on. Does slew on and SBuilder lost communicating correct?

Thanks,

Stuart
 
Last time, I remember slew was on and SBuilder installed and work fine perfectly I don't remember last Feb. I don't understand why not working at this time. I will try without slew on. I'll let you know if works or not.

Thanks,

Stuart
 
No, it does still not work. I have to reinstall flight simulator 9 a fresh start again. I read somewhere forum that if you changed folder or change FS9.exe. SBuilder will not accept it if you changed it. I have to reinstall fresh start FS9.exe ALONE! And try again install SBuilder to set up and it might be connected FS9.exe at once! Wait and see give me some time while installing.

Stuart
 
No. It does not work! I don't know what is the cause? Does registry error mess it up in the Windows 10? How do I clear the registry fix? How? I need to clear it out of Windows 10 registry files. I think it is caused registry files messed it up!


Stuart
 
Watch this video what did I do wrong with or missing or what it is? Where is coming from error or cause?



Thanks,

Stuart
 
FINALLY!!!! It fixed! Jeesh! The SBuilder is working now point fly aircraft show there! About that time! It took me 3 days fixing and fixing!

Thank you,

Stuart
 
Very careful step by step FS2004 4 disc installed next to install new FS9.exe patch not original FS9.exe won't work! then update FS9 9.1 worked (it wasn't working last time). Registry FS9 repair then I have back up FSUIPC latest updated. Put in the Modules. Start SBuilder installed then it works. Finally! I did before the same thing I don't know what was the problem coming from. Windows 10 did something to do actions wrong way or something I don't know. Enough...saying tick me off!

Stuart
 
Top