SBX will not compile

#1
I am working on another airport, utilizing a satellite ground texture captured with SBX. I have done several compiles already to check placement and what I might want to eliminate. I decided to color correct the image and did that as I have done hundreds of times with other airport ground textures. I added a blur, compiled, checked. . .all was well. Then this morning I decided to add a water mask and to change the color of the water around the peninsula area I'm working on. . . .again just as I've done hundreds of times before.

However now SBX has decided "There is nothing there to compile". What could have caused this sudden change in a simple bitmap image that SBX no longer recognizes it as a Geotiff? I have selected the image and then selected properties and clicked on "Geotif". . .it's reply was "This Geotif may have problems". . .Gee thanks for those words of wisdom.

Any suggestions?
 
#2
Hi Ed:

When you captured the satellite imagery with SBuilderX, it wrote image tiles into a particular \Tiles subfolder chain.

When you compiled, it wrote a stitched composite image in *.BMP format into the \Tools\Work subfolder chain.

The paired *.TXT file contains the Geo-referencing for that original exported *.BMP.


Assuming you only work with copies of original *,BMP images, at what point did you create a GeoTIFF, and how ? :scratchch


Regardless, if you change the total number of Pixel Rows and/or Columns in a derived image, its Geo-referencing will have changed relative to the original *.BMP as defined in its paired *.TXT file.


Also, simply by graphically editing and saving changes into a GeoTIFF file causes it to lose its Geo-referencing.


If you always keep the Geo-referencing info in the *.INF file and do NOT change the total number of Pixel Rows and/or Columns in derived images, even if you have graphically edited and saved changes into a GeoTIFF file, although the Geo-referencing info in the header of the GeoTIFF will likely be lost, Geo-referencing info in the *.INF file should still allow the TIFF image to be used on the basis of its mapping of the pixel dimensions and coordinates of the upper left pixel to a (NW) geographic coordinate.

GaryGB
 
Last edited:
#3
My mistake Gary in referring to it as a Geotif. . .it was just the bitmap image I captured with SBX, sorry about that. In my work in SBX, once I have saved the image, it gives it a numbered file name. In turn I go into the saved SBX file and change the information contained there to a more recognizable format (the airport name in place of the numbered file name), then I go back to the work folder and replace the image file name and the TXT file name to the same.

After that I do any color correction, night maps, blurs, etc in Paint Shop Pro. I am hard pressed to think of anything I would have done for it to suddenly not recognize the bitmap.

Thanks
 
#4
Hi Ed:

I'm away from a 'real' computer right now, but IIRC, SBuilderX throws the (2) error messages you cited above on rare occasions, and I'll have to refresh my memory on what might apply in your particular scenario.

Did you move the copied / renamed *.BMPs & *.TXTS out of \Tools\Work subfolder ?

If so, it looks for files there when it compiles tiles selected in the work-space unless a different explicit path and file name is otherwise specified in the *.INF file.

Note as well that SBuilderX by default will always write and read *.INF files to / from the \Tools\Work subfolder.

And of course one must always check the *.INF file to ensure it is correct and current when source files have been renamed subsequent to any initial 'test' compiles when files were named differently at time the initial *.INF was created. ;-)


Also, are you sure there is not a "typo"-induced mis-match in file names between (renamed) paired *.BMP and *.TXT files ? :scratchch

GaryGB
 
Last edited:
#6
After checking and re-checking, none of those were the cause of the fault and I have yet to figure out why it is just this airport. I have test captured two other airports images, exported them to an SBX file. . .then loaded them into PSP for color corrections and minor touch ups to eliminate certain areas on the grounds then saved back as a bitmap. I then went into the SBX file, changed the information to a more recognizable syntax, saved and then imported the SBX file and compiled. . .no problems.

Thus far I have done the offending image 4 times and in every instance after color correcting, saving to bitmap, changing the SBX info and importing again into SBX it compiles fine, but then go back to PSP, produce a blur, or a water map or change the water color on the image and try to compile and it gives me the error that there is nothing to compile.
 
#7
Hi Ed:

Since you seem to have a good grasp on the source file names and types, have you tried to compile them all from (1) folder without using the intermediary of SBuilderX and the *.SBX file, by Drag-and-Dropping the *.INF onto a copy of SDK Resample placed within the same folder ? :scratchch.


PS: Are you using all separate images for Masks as well as for Day / Night / Seasons, or have you instead added an Alpha channel as a Mask to 1 or more of your *.BMP images since it was originally created ?

GaryGB
 
Last edited:
#8
Gary,

For quite some time I utilized a separate folder to do my compiles with. . .custom inf file and separate images for all seasons, masks and blurs. . .however recently I got lazy and I've been letting SBX produce the inf and perform the compiles. Maybe that's an avenue I need to revisit.
 
#9
That was the solution Gary. Amazingly there were no differences in what I used to manually compile as compared to what SBX was using, INF files were identical, but at some point in the process SBX was unable to recognize the bitmap image any more.

Thanks again!
 
#10
Spoke too soon Gary. In my excitement that the compiler was actually doing it's job I failed to notice that other than the satellite image, no other source files were being compiled despite being included in the INF file. I am compiling the base bitmap image, a water map "*_W.TIF", a blend "*_B.TIF" and outputting to the airport scenery folder as shown below:

[Source]
Type=MultiSource
NumberOfSources=3

[Source1]
Type = BMP
Layer = Imagery
SourceDir = "."
SourceFile = "Lakeview_30F.BMP"
Variation = All
NullValue = 255,255,255
SamplingMethod = Gaussian
ulyMap = 33.1404259948224
ulxMap = -97.0216369628906
xDim = 2.68220901489258E-06
yDim = 2.24611599031008E-06

[Source2]
Type = TIFF
Layer = None
SourceDir = "."
SourceFile = "Lakeview_30F_B.TIF"
SamplingMethod = Gaussian
ulyMap = 33.1404259948224
ulxMap = -97.0216369628906
xDim = 2.68220901489258E-06
yDim = 2.24611599031008E-06

[Source3]
Type = TIFF
Layer = None
SourceDir = "."
SourceFile = "Lakeview_30F_W.TIF"
SamplingMethod = Gaussian
ulyMap = 33.1404259948224
ulxMap = -97.0216369628906
xDim = 2.68220901489258E-06
yDim = 2.24611599031008E-06

[Destination]
DestDir = "C:\FlightSim_Scenery_Folders\SouthWest_Arpts\Lakeview Arpt\scenery"
DestBaseFileName = "Lakeview_Photo"
DestFileType = BGL
LOD = Auto
UseSourceDimensions = 1
CompressionQuality = 85

I actually took all the files from my "Resample" work folder and put them back into the SBX work folder and let it compile to see if it would work. . . ."There is nothing here to compile". Talk about frustrating.
 
Last edited:
#14
Then you need:

Channel_BlendMask = 2.0
Channel_LandWaterMask = 3.0

in [Source1]
Ok, I did check the SDK samples and mine is set up like the sample is and has worked correctly before because I checked the INF files for previous jobs and they all read the same. At this point I am game to try anything, lol....thanks George.
 
#15
Nope, no difference. I can visually see when changes take place in the project once I reload after a compile. . .it's like this job has a teflon surface on it because after a certain point any additional compiles simply slide right off and never stick. I don't get it. I have babysitting duties for the rest of the day so I'll tackle this some more this evening. . .I enjoy beating my head against the wall in frustration. . .it feels so good when I stop, lol.
 
#16
I am moving on to another project. This one has become a PITA. If anyone wants to play with it, I have supplied a link to download a zip file containing both the current scenery folder and the Resample Work Folder with all the images I've been using to compile (base image, Blend mask, water mask, "INF" file and "resample".) I cannot be held liable for any brain damage incurred by anyone trying to make sense of it.

https://app.box.com/s/n56yyror0vhr2es2hfx4a5evwegd2cdg
 
#19
George,
Just as a comparison, here is what I get after compiling with the same package that you have (unless you made corrections or additions to the INF that I don't have). No suggestion of water inside the rectangle (what looks like water is actually solid ground) and no blend is present.


Inside the rectangle is solid ground. . .it appears to be water, but there is a line of delineation that breaks at the border of the scenery rectangle and it goes from water to solid ground, even incorporating the detail texture of grass.

Note: the white line on the right side. . .no idea where that's coming from as it doesn't show on anything I have.
Also, the slanted lines on the water at the top are shadows from the pilings under the bridge that crosses the lake.
 
Top