P3D v4 Sceneries causing CTD

#1
I have several sceneries from SkyDesigners representing French military airbases. All of the sceneries work fine in FSX-SE and P3Dv3. The sceneries are all very texture intensive with hundreds of 4K textures.

None of the sceneries use SODE or have any dlls associated with them.

Of the 6 sceneries, 4 cause a CTD within a minute or so of spawning an aircraft at them. 2 of the sceneries are working fine (and look beautiful in v4).

My questions are:

1) Are there FS2004 scenery elements in these sceneries that would work in FSX but cause a CTD in v4?

2) How would you go about troubleshooting which scenery elements could be causing this?

3) Are there any specific legacy scenery elements that are known to cause an issue in v4?

Thanks for thoughtful and experienced replies.
 

=rk=

Resource contributor
#2
You will probably want to test each individual scenery in an otherwise default configuration to get consistent results.
 
#3
If they use SCASM it can have issues. I do not know the details, but I do know some of the old FS scenery assembly code has been dropped by Prepar3D because it caused performance issues.
 
#4
After troubleshooting for about 4 hours, I can say with absolute certainty that the issue was Henrik's Global AI Ship traffic.

The symptom was...when sitting in a parking spot at one of the affected airports (let's use LMFY Salon de Provence), going to the locked spot view and panning around would cause the CTD within about a minute. Log files only showed that Prepar3d.exe was unresponsive and had been closed. This behavior was very repeatable and did not vary with different aircraft.

So here is my troubleshooting..
1) With all SkyDesigners scenery disabled, I set up a saved flight at the default LMFY, parking spot 3. While setting this up, it rapidly became apparent that the CTD was happening with the default scenery too. Yes, weird....was able to repeat this several times.

2) Backed up my existing Prepar3d.cfg and allowed a new one to be built. Using the saved flight, the sim did not crash when panning in locked spot.

3) Started making changes to each section (General, Information, etc) of options, one section at a time. After changing one section, loaded the save flight and did the panning. No CTD on setting the texture sizes, lighting, autogen, or other processor intensive settings.

4) However, when I set the traffic sliders to my liking (from 0%, the default in auto created Prepar3d.cfg), the sim would crash with the panning test.

5) Deleted the Prepar3d.cfg again, ran the sim and went to the traffic settings. Started modifying them one at a time, with each time applying the pan test. No crashes until I adjusted the Ship/Ferry traffic. I have 2 ship traffic addons installed: Henrik's and Haze Grey Studios.

6) De-activating Henrik's traffic files (I have them in an addon.xml config), leaving HGS enabled and the sim passed the pan test with no CTD.

7) Re-activating the traffic files and saved flight panning test caused the CTD.

With Henrik's traffic files de-activated, I have enabled all 6 of the SkyDesigner sceneries and they are working fine with no glitches or crashes.

Has anyone seen something like this before where it appears the traffic files were the cause? Any ideas how this problem is occurring?

Thanks
 

=rk=

Resource contributor
#5
Well that sounds more like a conflict, as either one worked independently of the other. Henrik's stuff is thoroughly tested, I'd blame a conflict related to something with the older sceneries, maybe a FS9 traffic file or something.
 
#6
If you have only installed Henrik's version 1 ("global_ai_ship_traffic_v1.zip"), there are a few FS9 native models (4 iirc), they can cause issues in P3DV4. These models have been replaced in the latest addendum, "200_ai_ship_and_ai_ship_traffic.zip".
 
#7
Well that sounds more like a conflict, as either one worked independently of the other. Henrik's stuff is thoroughly tested, I'd blame a conflict related to something with the older sceneries, maybe a FS9 traffic file or something.
No traffic files came with the SkyDesigners sceneries. Not even any effects. My v4 install is very fresh and pristine because I am using the addon.xml install method.

If you have only installed Henrik's version 1 ("global_ai_ship_traffic_v1.zip"), there are a few FS9 native models (4 iirc), they can cause issues in P3DV4. These models have been replaced in the latest addendum, "200_ai_ship_and_ai_ship_traffic.zip".
I have both the v1 and v2 merged together per the instructions for v2. Could I be missing something?
 
#8
A responder at another site suggested I try enabling Henrik's ships while disabling HGS. I did this but still the crash.

Going to review my install of Henrik's and if still an issue, will submit to him for look.
 
#9
A responder at another site suggested I try enabling Henrik's ships while disabling HGS. I did this but still the crash.

Going to review my install of Henrik's and if still an issue, will submit to him for look.
Try to remove the four ship folders below - the most likely is a problem from installation:
AI_AC_Sailboat
AI_Calypso
AI_John_T_Essberger
AI_La_Recouvrance
Next reactivate the traffic.
Where do the problem occur? Place and weekday will allow to identify the problem if it is the AI Ships. it is highly unlikely that a traffic.bgl causes the problem. But the four above FS9 models will cause a CTD in P3Dv4 if they are not replaced.
 
#10
Try to remove the four ship folders below - the most likely is a problem from installation:
AI_AC_Sailboat
AI_Calypso
AI_John_T_Essberger
AI_La_Recouvrance
Next reactivate the traffic.
Where do the problem occur? Place and weekday will allow to identify the problem if it is the AI Ships. it is highly unlikely that a traffic.bgl causes the problem. But the four above FS9 models will cause a CTD in P3Dv4 if they are not replaced.
Henrik,
Removing those models and re-activating the traffic files was a success. The pan test was successful for several minutes with no CTD.

The date and time of my saved flight is 5/30/2017 14:00:00

The CTD was happening at several French airports but not at any others that I could tell.

Thanks for the quick reply.....the ships are back!

I will copy this post at the other site as well for reference.
 
#11
Maybe the final word...

Henrik,

Looks like I missed the v2 of the 200 package. My download is dated May, 2017 and did not have the update 4 models.

The 200 package dated June, 2017 does have the updated models.

Thanks again for all your beautiful work.
 
Top