FSX [SOLVED] Texture problem while applying on lofts

#1
Hi everyone , I am following Jtanabodee's "How to make ground polys for the year 2014" ,
I am working on 3dsMax 2017 64X and the following two problems are occurring with me

1) While applying texture to the loft it doesn't apply perfectly on the curved faces as if you see in the previews i have posted below i have set materials in the material editor to P3D ( Using the P3D v4 SDK)

Screenshot_1.png
34503470_1799227453506591_9181439802992492544_n.png


2) Following is my texture sheet for straight lines it displays well and is perfect while in photoshop or photoviewer but when i import it in the dxtbmp or the 3dsmax the texture messes up and does not show up how it is supposed to
a) The Transparency on edge of the first texture does not retain
b)Hold short markings are messed up when imported ( Though i do know it has to be fixed so it can be repeated it isnt in that shape rn) . I have exported the image as .png as it is the most suitable image type for my project .

pic 1 > how the texture is in photoshop or photoviewer (White is transparent)
pic 2 > how it looks in DXTBMP
pic 3 > how it looks in 3dsMax

34556349_1799351006827569_4705796676097409024_n.png
34631392_1799245000171503_6040634286485274624_n.png



If anyone knows a fix to these problems and can help me it would be much appreciated , thank you .
 

Attachments

Last edited:
#2
I suspect the issue comes down to the fact it's such a large loft and texture, heavily contracted one side and stretched on the other.

I would opt to reduce the size of the loft shape itself and have the double yellows on a separate layer/loft
 
#3
I suspect the issue comes down to the fact it's such a large loft and texture, heavily contracted one side and stretched on the other.

I would opt to reduce the size of the loft shape itself and have the double yellows on a separate layer/loft

Thank for replying so yeah i consider your suggestion but it will need alot of rework since i have all the lofts done and they'll have to made again and adjusted .

I had another thing in mind so i tried increasing shape steps to 2 or 3 where this issue becomes unnoticeable but i was wondering is it going to have any bad impact on FPS , or any kind of affect ?
 
#4
Thank for replying so yeah i consider your suggestion but it will need alot of rework since i have all the lofts done and they'll have to made again and adjusted .

I had another thing in mind so i tried increasing shape steps to 2 or 3 where this issue becomes unnoticeable but i was wondering is it going to have any bad impact on FPS , or any kind of affect ?
Agressive tiling will result in blurries for anyone not using near maximum settings within P3D - try to keep tiled textures to a minimum...increasing steps won't really fix it, it will reduce the visibility of the same problem.

I would strongly recommend using the "Sweep" modifier - Sweep does the same thing as a Loft, but allows you to apply it to multiple lines at one time and edit accordingly. This will save you a lot of time if you do decide to make the lofts smaller and have the double yellows on their own layer and loft.

I personally wouldn't increase the steps, especially if it is already following the exact edge of your main surface, this is of course increasing poly count and will not fix the issue but instead make the inside tile more violently.

If none of this applies to you, you could always alpha out the actual asphalt so you have just your edge (and a small bit over either side) and your double yellow markings
 

jtanabodee

Resource contributor
#5
I think I have answered this question before but I cannot find it.
#1 The texture does not mapped properly.
It happened because the length of the curvatures of Loft are not the same, the inner one is shorter than the outer curve. You need to unwrap the loft then -> Select all vertices ->Break Selected Vertices ->Select the polygon you have problem and re-arrange the length of the curvature: outer curve to be more length or inner curve to be less.
Sweep is much better function than Lofting. But your problem does not related to the method of making the model. Mapping method of Loft is the way to put texture fits in the width of the model. When the model has curve, the length inside curve and outside cure are not the same. So the texture get distorted.
#2 The transparency and the texture look in other program.
I am not sure what happen. But I never use DXTbmp program. I use only ImageTool from FSX sdk to change the texture file to DXT5 with mipmap. Then I get a look in Flight Sim( FSX, P3D, whatever). If it does look right, that's all. Sometime this program does not display the same way as FSX/P3D does.
 
Last edited:
#6
I think I have answered this question before but I cannot find it.
#1 The texture does not mapped properly.
It happened because the length of the curvatures of Loft are not the same, the inner one is shorter than the outer curve. You need to unwrap the loft then -> Select all vertices ->Break Selected Vertices ->Select the polygon you have problem and re-arrange the length of the curvature: outer curve to be more length or inner curve to be less.
Sweep is much better function than Lofting. But your problem does not related to the method of making the model. Mapping method of Loft is the way to put texture fits in the width of the model. When the model has curve, the length inside curve and outside cure are not the same. So the texture get distorted.
#2 The transparency and the texture look in other program.
I am not sure what happen. But I never use DXTbmp program. I use only ImageTool from FSX sdk to change the texture file to DXT5 with mipmap. Then I get a look in Flight Sim( FSX, P3D, whatever). If it does look right, that's all. Sometime this program does not display the same way as FSX/P3D does.

Thanks buddy you're a life saver , i followed #1 and got the loft issues fixed now i am onto #2
For now i just tested it and will be more precise when i do them for all lofts
This is before




and this is after trying your fix

 
Top