P3D v4 XMLTOOLS64

#1
Installed this version totally new!
Moved my B727 panel to P3Dv4.
XML files work so far.
DSD gauges replaced with the 64 version. Works.

But i can't install xmltools64.

found this thread
http://prepar3d.com/forum/viewtopic.php?t=125649

because i have no default installation i created DLL.xml in

G:\Win10.EduHir\Appdata\Roaming\Lockheed Martin\Prepar3D v4

but also in E:\P3D.
This is my main install dir

Code:
<?xml version="1.0" encoding="WINDOWS-1252"?>

<SimBase.Document version="1,0" Type="Launch">
<Descr>Launch</Descr>
<Filename>dll.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>
<Name>XMLTools64</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>E:\P3D\XMLTools64.dll</Path>
<DllStartName>module_init</DllStartName>
<DllStopName>module_deinit</DllStopName>
</Launch.Addon>
I tested also <Path>XMLTools64.dll</Path>

Any help much appreciated.
Edi
 
#2
Edi,

Is that your entire dll.xml? If so, you're missing </SimBase.Document> as the last line.

Example:

XML:
<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>XMLTools64</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\XMLTools64.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
  <Launch.Addon>
    <Name>HttpX64</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\HttpX64.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
</SimBase.Document>
Should work assuming the path to dll.xml and also the modules location are correct.

Bob
 
Top