• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FS2004 BGL2XML problem

When I try to decomplile a scenery bgl, I get following error:

bgl2xml1.jpg


"The value must not be zero" and no xml is created
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
We are updating this utility at the moment and hope to release a new one this week. I have seen a similar bug so we are working in that area.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
I am sorry but I need to check. I recall making an update but I am not sure if it was published :oops:
 
I too shall look forward to Jon's follow-up with this when he has an opportunity, and wish him a stress-free recuperation from his recent medical procedure. :cool:

FYI: The online update for version 1.3.7x originally conveyed a version 1.5x package which did NOT have the apparent 'bug' described above.

The online update for version 1.5X conveys a 1.6x package that DOES have the apparent 'bug' described above.

Recent tests of the version 1.3.7x package did NOT have the apparent 'bug' described above.


BGL2XML version 1.3.7x is available for download at:

http://library.avsim.net/search.php?SearchTerm=Bgl2Xml&CatID=root&Go=Search

http://www.flightsim.com/vbfs/fslib.php?searchid=37567586


Hope this helps ! :)

GaryGB
 
Last edited:
Thanks for that clarification, George; I was referring to the downloadable 'package' version rather than the GUI executable version; I have edited my post above.


< And now for that first cup of coffee this morning ! :coffee: >

GaryGB
 
Hi Guenther:

Until Jon has a had a chance to reply, I'm curious if you get the same error using this BGL2XML version 1.50 that I use ?

NOTE: One must first manually browse to the same folder path as the input file to set it for the output path, before "View" works.


Hope this helps ! :)

GaryGB
 

Attachments

  • bgl2xml_150.zip
    1.8 MB · Views: 280
Results:

1. it is not necessary to browse to the same folder path as the input file to set it for the output path, before "View" bcause the error occurs first and "View" remains grayed out (1.3.7).

2. BGL2XML 1.5.0 works great!

Thanks a lot
:wave:
 
Glad that helped ! :)

BTW: I have 1.60 available also, but have not tinkered with it due to an 'issue', about which, I have since forgotten the details. :scratchch

GaryGB
 
Top