• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Blender2MSFS support thread

Status
Not open for further replies.
Open the XML for that given 3D object and change "version="1.0" that is inside the "<ModelInfo> tag to: version="1.1"

At least I think that may be your issue. All of the newly created objects I export have that issue until I manually edit the XML. But if I re-export to same location it does not rebuild the XML so I do not have to re-edit that file.
I still seem to get the error.
Here's a screenshot
Screenshot 2020-11-10 175652.jpg


And this is what I have in vomm-terminals.xml . (Changed the ModelInfo version manually to 1.1 as per other posts on this thread)
<?xml version="1.0" encoding="utf-8" ?>
<ModelInfo version="1.1" guid="{685414fd-5151-4434-85b7-5e5573615270}">
</ModelInfo>
 
By any chance, is there a way to change the default settings of the PlugIn?

I'd like to have default compiled textures folder, copyright string and a few flags

Thanks for the awesome tool!
 
In blender exporter I simply type the word "Texture". By doing so, a new folder called "Texture" is created containing all the associated object textures and is included wherever the 3 exported files (.bin,.xml. & .gltf) are placed.In the beginning I thought the exported files and textures must be placed directly from blender in their final destination i.e. modelLib/hangar/ for the 3 files and modelLib/textures/ for the textures.But this isn't essential at all,in fact everything can be placed even directly to Desktop and then moved to their final destination inside the project's folder structure.Even if you don't indicate a Texture folder for your textures to be included and leave the "Textures" option in blender empty,all your textures will be exported wherever the 3 files be,even directly on Desktop.Then you copy/paste them in their final destination.
That explains a lot because I have been exporting my files to blender assets model library with a texture sub folder and then moving copying files to the MSFS directories. I found a textures folder in the same directory as my blender asset with all the textures in there, so now I understand where they came from and all the .001. .002 tags came from. but to be clear the final result will be msfs projects sources/modelLib with folders inside each containing a model with the name of the object as a folder title with the three files inside that and then in the modelLib/textures folder all the textures for all the models will be in the that one folder correct?
 
That explains a lot because I have been exporting my files to blender assets model library with a texture sub folder and then moving copying files to the MSFS directories. I found a textures folder in the same directory as my blender asset with all the textures in there, so now I understand where they came from and all the .001. .002 tags came from. but to be clear the final result will be msfs projects sources/modelLib with folders inside each containing a model with the name of the object as a folder title with the three files inside that and then in the modelLib/textures folder all the textures for all the models will be in the that one folder correct?
Absolutely correct.
And you can place in the same folder structure all your custom objects and their associated textures.Only thing you must remember everytime you make even the slightest change to an existing object and place it along the others to repeate the package builting precedure via Fspackagetool.exe.Same when a completely new object is also added.And then replace your previous "CustomObjectPackage" inside community folder with the updated one.
 
So not to beat a dead horse my folder setup will be packageSources/modelLIb/hanger/Hanger.xml. + the other two and then modelLib/office/office.xml + the other two
And a single textures folder for all models
Packages sources/modelLib/ texture/Hanger_albedo.png, Hanger_normal.png Office_albedo.png, office_normal.png etc
 
I sorted out my previous error by renaming all xml files to match the model names. There was a typo in one of the names.

But I got another issue while exporting from blender, when I check the console, I get multiple messages that say
WARNING: Could not calculate tangents. Please try to triangulate the mesh first.
Screenshot 2020-11-11 084511.jpg


Is there a way I can correct this? I tried the triangulate modifier on the meshes but that didn't help.
 
So not to beat a dead horse my folder setup will be packageSources/modelLIb/hanger/Hanger.xml. + the other two and then modelLib/office/office.xml + the other two
And a single textures folder for all models
Packages sources/modelLib/ texture/Hanger_albedo.png, Hanger_normal.png Office_albedo.png, office_normal.png etc
Correct again.
Certainly once the completed package goes into community folder all custom objects will normally appear in SDK object list ready to positioned in place.However I think that from the moment any custom object is already placed to a scenery and the scenery is saved and recompiled to a package from within dev mode in MSFS,there is no need anymore for the package to be in community folder as the objects will continue to appear in the object lists because MSFS in dev mode will "extract" their data from within the saved scenery.That's most likely the reason some objects appear as double or even triple in the object lists as the same objects are present both in the dev mode of MSFS and the very same MSFS folder structure as well.
 
I sorted out my previous error by renaming all xml files to match the model names. There was a typo in one of the names.

But I got another issue while exporting from blender, when I check the console, I get multiple messages that say

View attachment 65115

Is there a way I can correct this? I tried the triangulate modifier on the meshes but that didn't help.
Don’t select the tangents ch3ck box in the 3xporter
 
Correct again.
Certainly once the completed package goes into community folder all custom objects will normally appear in SDK object list ready to positioned in place.However I think that from the moment any custom object is already placed to a scenery and the scenery is saved and recompiled to a package from within dev mode in MSFS,there is no need anymore for the package to be in community folder as the objects will continue to appear in the object lists because MSFS in dev mode will "extract" their data from within the saved scenery.That's most likely the reason some objects appear as double or even triple in the object lists as the same objects are present both in the dev mode of MSFS and the very same MSFS folder structure as well.
I think if you pull the project out of the community folder everything disappears. Maybe availbale for dev mode but no mods to scenery will exist. Then of course if they are somehow available to be used in another scenery, it too must be compiled. Example signage used multiple scenery files.
 
Don’t select the tangents ch3ck box in the 3xporter
Just tried that. I still get the warning. I guess it doesn't affect the exports though. But I don't think it is checking whether the checkbox for tangents is checked or not and attempts to export the tangents regardless.
 
My first post on the forum here, but I've ran into an issue when exporting a building complete with Point and Spot Lights into the sim.

My issue is not that the lights don't export, but more that while they show correctly in blender and the light doesn't pass through a surface, when exported into the sim, light seemingly passes through surfaces as if they weren't there. Attached is an example of what I mean (e.g. spot light from above balcony passing through the material.
124569074_2779093349084426_195067140201080021_n.jpg

Maybe not the best example to use as I'm not at the computer with the Blender files on at the moment. But when the building is moved out the way of MS generated lights (e.g. into the middle of the airfield) to make sure there aren't any external light sources acting upon it.

I've looked on the Blender2MSFS Wiki and it states that the Parameters supported for export are
  • Color
  • Power
  • Shape-size (cone angle for spot lights)
Does this signal that the reason for the light seemingly going round corners is because the Cast Shadows option, although selected in Blender Light properties, is not supported by the Toolkit?

Are there any material properties that would need to be changed to stop light going through them? Any advice would be much appreciated.
 
I think I found a bug:
When exporting "Windshield" materials, and adding an UV scale to the detail map, the plugin adds the "KHR texture transform" extension. THis causes the MSFS parser to reject the model:

Code:
               "ASOBO_material_detail_map" : {
                    "detailColorTexture" : {
                        "extensions" : {
                            "KHR_texture_transform" : {
                                "offset" : [
                                    0,
                                    -6
                                ],
                                "scale" : [
                                    7,
                                    7
                                ]
                            }
                        },
                        "index" : 1,
                        "texCoord" : 0

The UV scale is just a numeric parameter that does not alter anything else in the model apparently:

Code:
                "ASOBO_material_detail_map" : {
                    "detailColorTexture" : {
                        "index" : 1,
                        "texCoord" : 0
                    },
                    "detailNormalTexture" : {
                        "index" : 2,
                        "texCoord" : 0
                    },
                    "UVScale" : 7,
                    "UVOffset" : [
                        0.0,
                        0.0

In the second snippet, I exported with UV scale 1.0, then manually changed the value to 7 in the gltf. After building the package in FS, the detail map was properly scaled.

I can leave this one for when the model is finished and then edit manually, so it is not a showstopper for now!
 
A simple question this time:
The texture .png files must be at specific dimensions to be normaly "accepted" by MSFS"?Because I noticed all texture files MSFS uses by default are perfectly squared like 1024x1024 or 2048x2048 or similar.So besides such perfect squared dimensions could also other combinations be used?
 
Hello all, is this map correct for internal panel of an aircreaft. I have problems with sun reflections which seem to vibrate on some materials. do I have to use the collision material? with "msfs invisible" can someone give me some advice
Thanks
 

Attachments

  • Cattura2.JPG
    Cattura2.JPG
    117.1 KB · Views: 47
I thing the rgb shader (green) that you have plugged into metallic input is the roughness...rgb is usually, a/o - roughness - metallic. (at least for Blender2msfs) Try moving that one to roughness, adjust as needed and set metallic to zero, or include a shader in the blue channel.
 
I thing the rgb shader (green) that you have plugged into metallic input is the roughness...rgb is usually, a/o - roughness - metallic. (at least for Blender2msfs) Try moving that one to roughness, adjust as needed and set metallic to zero, or include a shader in the blue chan
Thanks Aviator! i'm not sure to understand what you mean.. can you please lost one minute to make for me the connections lines with paint?
 
like this...
rgb nodes.PNG
I sued materialize to get the roughness shader and materialize makes a smoothness shader (when built from within, not imported) so i used and inverter node (not shown) to flip it to a roughness texture
 
Status
Not open for further replies.
Top