Default zoom level

#1
Hi Arno

I downloaded your latest version (1.4.0.0 df98e696 DEV 13.4.2019) and noticed that the default view for an aircraft I am repainting for Milviz is barely visibile. I have to zoom in quite a bit to see the model. I did not have this problem with your previous dev release (which I unfortunately overwrite).

1) Would you be able to make that release available for me (I need to work on the paint for Milviz of a new aircraft in dev.)
2) if not, could you perhaps have a look at that issue?
3) More of a wish. It would be great to see the zoom level of the aircraft as well. and also have some predefined levels, except the two already provided.

Thanks for your consideration and for working on this wonderful and extremely useful programme.

Thanks and regards
Eberhard
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

I suspect that the aircraft.cfg file contains some point that is further away from the aircraft. Can you try to turn these points on in the preview to see if that's the case?

How do you see default zoom levels to work?
 
#3
Excuse my ignorance. Where can I set the points in the Preview?

Something similar to the zoom options in Chrome, or Word. default, full object and then probably 50% 75% and 100%. Dropdown menus would do the trick, I think.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
But if the current default zoom, which would be 100%, is not working right, then 75% zoom would also not work would it?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#6
So did you try to render the cfg points or check in the hierarchy editor which node causes the big bounding box?
 

Pyscen

Resource contributor
#7
Hello...

I bellieve what Arno is referring to.. there might be a comma or decimal point misplaced within the aircraft.cfg file.
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#9
Can you look at the bounding box in the object information form? What kind of values does it show?

How old was the previous development version you used?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#12
No, the modeldef.xml has nothing to do with the model size.

Did you look at the cfg points already?
 
#14
Is this what you are looking for

[contact_points]

// wheelbase 7.87 m
// track 3.00 m

//0 Class
//1 Longitudinal Position (feet)
//2 Lateral Position (feet)
//3 Vertical Position (feet)
//4 Impact Damage Threshold (Feet Per Minute)
//5 Brake Map (0=None, 1=Left, 2=Right)
//6 Wheel Radius (feet)
//7 Steer Angle (degrees)
//8 Static Compression (feet) (0 if rigid), 7.1" for
//9 Max/Static Compression Ratio ( 1.2 for PC-6 )
//10 Damping Ratio (0=Undamped, 1=Critically Damped)
//11 Extension Time (seconds)
//12 Retraction Time (seconds)
//13 Sound Type

max_number_of_points = 10

point.0 = 1, -24.66, 0.00, -4.60, 3000, 0, 0.43, 25, 0.226, 1.3, 0.3, 0, 0, 1
point.1 = 1, 1.16, -4.92, -7.49, 1000, 1, 0.83, 0, 0.6, 1.2, 0.5, 0, 0, 2 // 1.16' ahead of wing LE
point.2 = 1, 1.16, 4.92, -7.49, 1000, 2, 0.83, 0, 0.6, 1.2, 0.5, 0, 0, 3 // 1.16' ahead of wing LE

point.3 = 2, -1.56, -21.5, 1, 3200, 0, 0, 0, 0, 0, 0, 0, 0, 5
point.4 = 2, -1.56, 21.5, 1, 3200, 0, 0, 0, 0, 0, 0, 0, 0, 6
point.5 = 2, -23.56, 0, 0, 3200, 0, 0, 0, 0, 0, 0, 0, 0, 9
point.6 = 2, -21.56, 0, 6.8, 3200, 0, 0, 0, 0, 0, 0, 0, 0, 9
point.7 = 2, 2.44, 0, -2.9, 16000, 0, 0, 0, 0, 0, 0, 0, 0, 4
point.8 = 2, -6.56, 0, -2.7, 16000, 0, 0, 0, 0, 0, 0, 0, 0, 4

static_pitch= 6.8
static_cg_height= 7.82
gear_system_type = 0
emergency_extension_type = 0
tailwheel_lock = 1
 
#16
This is what I get when compiling the Object report

GUID{bc996812-2cf8-44d9-a2eb-8f96276958b9}

Bounding box-316,575 < X < 919,741
-136,069 < Y < 95,421
-2,095 < Z < 2,220
Levels of detailLOD 100 containing 606156 triangles and 194 drawcalls
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#18
There is a button to show the cfg points in the preview, it has an aircraft symbol on it. Try to toggle it and see if you see any point with a big offset.

Another option is open the hierarchy editor and check there with node has a weird size.
 
#19
toggling it does not make any difference. I see nothing showing up or closing

This is what I see in the Hierarchie editor. Is there a specific place I must look at, or which value has to be wrong?

ScreenHunter_270 Apr. 20 18.44.jpg
 

tgibson

Resource contributor
#20
In your last image, see where the Bounding Box section is? Since you have the top SceneGraphNode selected, you are getting the Bounding Box for the entire plane. You can see the numbers are the same as you posted earlier. It appears that the bounding box of that plane is 316 x 919 (meters, I assume) which is huge. If you click through the SceneGraphNodes and Model Parts, find the one(s) with the large Bounding Box.
 
Top