• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Emissive materials problem

Messages
11
Hi,

I have imported my first airport tower into MSFS2020 with correct textures. Now i'm trying to achieve the day/night cycle, so i make sure to put the emissive texture on the slot and set the emissive value to 1, but when i import it to the sim, this is what i see:

It is as if the simulator didn't get my textures at all, although i updated the model, exported the new files, copied the new textures into the folder and built the project numerous times. I also tried to lower the value of the emissive chanel in the 3ds max and when i imported the model back to the simulator it worked, as i could see it having a lower "light".

Any help of what can it be wrong? The texture itself it's a normal 16bits 2k x 2k grayscale image.
 

Attachments

  • Desktop Screenshot 2020.09.19 - 18.01.24.04.png
    Desktop Screenshot 2020.09.19 - 18.01.24.04.png
    1.1 MB · Views: 190
Set the Emissive color to white - that has worked for some people.
 
Yeah... that's the emissive value to 1. It just enables the emissive material, but it does not respect the texture on it.
 
Ok. 255,255,255 is white in an RGB space. 1 is white in a grayscale space, which is what Fs2020 uses. So yes, i'm setting it to white as i told on my first post and as you can see in the picture.
The problem is not that it's not working, is that it does not get it from the emissive texture.
 
Last edited:
Are you using a grayscale texture for the emissive map? I thought it should be a normal rgb texture.
 
I face the same problem. Before the last release, I could not get a night texture in the sim. Now I have ONLY the night texture also during the day.
My texture in the ModdelLib bgl : Ambient color 255; 255; 255 , diffuse color 0;0;0 , emissive color 255; 255; 255 , specular color 0;0;0
emissive mode AdditiveNightOnly, no Alpha
Euh ... I wish I could understand something to the colour system ...;) I just copy what the other say ... Often, it works :)
 
Hi,

A black diffuse color is not right either, that one should be white as well. Just like with the emissive texture, a black diffuse color will cause the diffuse (or albedo texture in PBR naming) not to show, as the texture color is mulitplied with the color (and black is zero, so nothing remains if you multiply with that).
 
Are you using a grayscale texture for the emissive map? I thought it should be a normal rgb texture.

yes, i’m using a grayscale texture because on the SDK documentation example they show a grayscale texture. But i tried using an RGB texture as well with the same luck.

As i understand, the emissive color (full white) is multiplied by the texels in the texture to obtain the emissive color. As per my texture, the whole model is black and there’s just a part of it whiter, so only a part of it should be emissive.
I think that the builder does not take the texture into account because there’s not even a bit of a difference in the whiter part of the texture when at nightime it is emiting.

I am running out of ideas.
 
@arno where can I petition for you to change the name from "diffuse" to "albedo"? Those two are not the same. They're not interchangeable and should therefore maintain a unique name. :duck:
 
Vitus, when converting a model it makes sense to use the diffuse texture as albedo texture. They are rather similar, but not exactly the same. Having a separate albedo texture slot would make updates to pbr much harder.

But I would like the have the name depend on the filter selected, while they use the same attribute.
 
@Vitus I just made the change, so it will be in the next development release. Underwater still the same attribute, but shown with the appropriate name now.
 
I remember that I did something similar in the Blender2P3D/FSX toolkit. I just think that it makes sense to make that distinction for the users, to signal that there is, in fact, a difference. Thanks for your consideration :wizard:
 
I hope to make the parameter descriptions and names vary on the FS version selected one day. But I need to figure out how to do that. Now there are some parameters that do kind of the same, but have a different name in FSX, P3D v4 and MSFS.
 
As i understand, the emissive color (full white) is multiplied by the texels in the texture to obtain the emissive color. As per my texture, the whole model is black and there’s just a part of it whiter, so only a part of it should be emissive.
I think that the builder does not take the texture into account because there’s not even a bit of a difference in the whiter part of the texture when at nightime it is emiting.

I just did a test here and the emissive texture is working fine. In my emissive texture I made the parts that should not transmit any light black and the other parts are gray or some other color.

1600628728731.png


And this is the texture I used:

txtext06_emissive.png
 
I just did a test here and the emissive texture is working fine. In my emissive texture I made the parts that should not transmit any light black and the other parts are gray or some other color.

View attachment 62314

And this is the texture I used:

View attachment 62315

Thanks Arno, just for the sake of it... what file type are you using? I moved onto other things, but i will have to go back to the emissive materials at some point and i think it's just because of my texture. which by the way looks like yours. Black where i don't want to emit and grey where i do.
 
I just used a PNG texture, like all textures in the PackageSource folder are PNG now.
 
I just did a test here and the emissive texture is working fine. In my emissive texture I made the parts that should not transmit any light black and the other parts are gray or some other color.

View attachment 62314

And this is the texture I used:

View attachment 62315

I just used a PNG texture, like all textures in the PackageSource folder are PNG now.

Hi Arno:

Are you are referring to the graphic format of this emissive image in the above cited group of *.PNG files ? :scratchch

[MSFS SDK install path]\Samples\SimpleScenery\PackageSources\modelLib\texture\Airport_Lights_Emissive.png


Thanks for clarifying this, so we can better understand / study the file types utilized in your example above: :)

https://www.fsdeveloper.com/forum/threads/emissive-materials-problem.449164/post-856648

GaryGB
 
Last edited:
So to be clear, in the export... you select the black bar relating to emmisive textures to white and the albedo bar that is white leave it as such! When Imported one of my model‘s posts was emitting bright white and the rest was dark (windows) but in my emissive texture file, everything was black except the windows. The post that went white was shaded correctly in th3 uav. Editor but something somewhere go crossed. I did notice that in the nodes, emissive had dead ended, that should be plugged into output (emmisive) vorrect?
 
Back
Top