Flight Toolkit

#22
Ok So I successfully installed 0.7.3 on XP, even if I can't get the DLCs through it this is cool it remind me of an old add on and manager that I had for FS 98 or was it 2004? So many versions, anyway I read that only some FSX craft convert successfully, and also says "To be able to install and enable 3rd party addons you must own and have installed the Alaska Wilderness Pack." what about those of us who didn't get it? Could someone elaborate on that?
Thank for all the hard work.
 
Last edited:
#23
For your Win 7 problems, make sure this directory exists before installing: C:\Users\<your username>\AppData\Local\Microsoft\Xlive\DLC\4d5308d2\00000002.

For XP: I think that version required the Alaska Wilderness Pack to be owned by the user in order to load any addons. There isn't an easy way around it, but you could potentially point one of the FileLocator.config files either from the base Flight installation, or one of the DLC you do have, and make it point to the one in the root of the DLC folder. The requirement for Alaska Wilderness Pack was removed in future versions.
 
#24
Ok I checked for the directory and it was missing, GFWL was also missing too so I installed it. and I created the Xlive directory I tried to install both versions 1.0 first and it failed.I trie install latest version 10.17.5 failed again, log is below. I understand it requires Alaska pack, how could I point filelocator.config do "<MappingEntry LocationType="Zip" PhysicalLocation= root directory for the DLC?
"The requirement for Alaska Wilderness Pack was removed in future versions." not sure what you mean by that? you mean future versions of flight toolkit?
Thanks

Error Log

[56A4:6374][2014-10-13T20:06:37]i001: Burn v3.8.1128.0, Windows v6.1 (Build 7601: Service Pack 1), path: C:\Users\user 1\Documents\FlightToolkit_1_0_17_5.exe, cmdline: ''
[56A4:6374][2014-10-13T20:06:37]i000: Initializing string variable 'InstallFolder' to value '[ProgramFilesFolder]Flight Tools\Flight Toolkit'
[56A4:6374][2014-10-13T20:06:37]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\USER1~1\AppData\Local\Temp\Flight_Toolkit_20141013200637.log'
[56A4:6374][2014-10-13T20:06:37]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\user 1\Documents\FlightToolkit_1_0_17_5.exe'
[56A4:6374][2014-10-13T20:06:37]i000: Setting string variable 'WixBundleName' to value 'Flight Toolkit'
[56A4:6374][2014-10-13T20:06:37]i100: Detect begin, 2 packages
[56A4:6374][2014-10-13T20:06:37]i000: Setting string variable 'NETFRAMEWORK45' to value '378758'
[56A4:6374][2014-10-13T20:06:37]i052: Condition 'NETFRAMEWORK45 >= 378675' evaluates to true.
[56A4:6374][2014-10-13T20:06:37]i101: Detected package: NetFx451Web, state: Present, cached: None
[56A4:6374][2014-10-13T20:06:37]i101: Detected package: FlightToolkitSetup.msi, state: Absent, cached: None
[56A4:6374][2014-10-13T20:06:37]i199: Detect complete, result: 0x0
[56A4:57FC][2014-10-13T20:06:39]i000: Setting numeric variable 'EulaAcceptCheckbox' to value 1
[56A4:6374][2014-10-13T20:06:39]i200: Plan begin, 2 packages, action: Install
[56A4:6374][2014-10-13T20:06:39]w321: Skipping dependency registration on package with no dependency providers: NetFx451Web
[56A4:6374][2014-10-13T20:06:39]i000: Setting string variable 'WixBundleRollbackLog_FlightToolkitSetup.msi' to value 'C:\Users\USER1~1\AppData\Local\Temp\Flight_Toolkit_20141013200637_0_FlightToolkitSetup.msi_rollback.log'
[56A4:6374][2014-10-13T20:06:39]i000: Setting string variable 'WixBundleLog_FlightToolkitSetup.msi' to value 'C:\Users\USER1~1\AppData\Local\Temp\Flight_Toolkit_20141013200637_0_FlightToolkitSetup.msi.log'
[56A4:6374][2014-10-13T20:06:39]i201: Planned package: NetFx451Web, state: Present, default requested: Present, ba requested: Present, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[56A4:6374][2014-10-13T20:06:39]i201: Planned package: FlightToolkitSetup.msi, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: Uninstall, cache: Yes, uncache: No, dependency: Register
[56A4:6374][2014-10-13T20:06:39]i299: Plan complete, result: 0x0
[56A4:6374][2014-10-13T20:06:39]i300: Apply begin
[4A6C:3444][2014-10-13T20:06:41]i360: Creating a system restore point.
[4A6C:3444][2014-10-13T20:07:10]i361: Created a system restore point.
[4A6C:3444][2014-10-13T20:07:10]i000: Caching bundle from: 'C:\Users\USER1~1\AppData\Local\Temp\{af585766-53bd-4c15-8276-d195f77cfd87}\.be\FlightToolkit.exe' to: 'C:\ProgramData\Package Cache\{af585766-53bd-4c15-8276-d195f77cfd87}\FlightToolkit.exe'
[4A6C:3444][2014-10-13T20:07:10]i320: Registering bundle dependency provider: {af585766-53bd-4c15-8276-d195f77cfd87}, version: 1.0.17.5
[4A6C:37F8][2014-10-13T20:07:16]i305: Verified acquired payload: FlightToolkitSetup.msi at path: C:\ProgramData\Package Cache\.unverified\FlightToolkitSetup.msi, moving to: C:\ProgramData\Package Cache\{A37F9265-CAC4-434D-8A0A-6F2106B603B7}v1.0.17.5\FlightToolkitSetup.msi.
[4A6C:37F8][2014-10-13T20:07:22]i305: Verified acquired payload: cabA72935ABBB8B4DCADA870C9CD5DEC52B at path: C:\ProgramData\Package Cache\.unverified\cabA72935ABBB8B4DCADA870C9CD5DEC52B, moving to: C:\ProgramData\Package Cache\{A37F9265-CAC4-434D-8A0A-6F2106B603B7}v1.0.17.5\cab1.cab.
[4A6C:3444][2014-10-13T20:07:22]i323: Registering package dependency provider: {A37F9265-CAC4-434D-8A0A-6F2106B603B7}, version: 1.0.17.5, package: FlightToolkitSetup.msi
[4A6C:3444][2014-10-13T20:07:23]i301: Applying execute package: FlightToolkitSetup.msi, action: Install, path: C:\ProgramData\Package Cache\{A37F9265-CAC4-434D-8A0A-6F2106B603B7}v1.0.17.5\FlightToolkitSetup.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" INSTALLFOLDER="C:\Program Files (x86)\Flight Tools\Flight Toolkit"'
[4A6C:3444][2014-10-13T20:07:32]e000: Error 0x80070643: Failed to install MSI package.
[4A6C:3444][2014-10-13T20:07:32]e000: Error 0x80070643: Failed to execute MSI package.
[56A4:6374][2014-10-13T20:07:32]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[56A4:6374][2014-10-13T20:07:32]i319: Applied execute package: FlightToolkitSetup.msi, result: 0x80070643, restart: None
[56A4:6374][2014-10-13T20:07:32]e000: Error 0x80070643: Failed to execute MSI package.
[4A6C:3444][2014-10-13T20:07:32]i318: Skipped rollback of package: FlightToolkitSetup.msi, action: Uninstall, already: Absent
[56A4:6374][2014-10-13T20:07:32]i319: Applied rollback package: FlightToolkitSetup.msi, result: 0x0, restart: None
[4A6C:3444][2014-10-13T20:07:32]i329: Removed package dependency provider: {A37F9265-CAC4-434D-8A0A-6F2106B603B7}, package: FlightToolkitSetup.msi
[4A6C:3444][2014-10-13T20:07:32]i351: Removing cached package: FlightToolkitSetup.msi, from path: C:\ProgramData\Package Cache\{A37F9265-CAC4-434D-8A0A-6F2106B603B7}v1.0.17.5\
[4A6C:3444][2014-10-13T20:07:32]i330: Removed bundle dependency provider: {af585766-53bd-4c15-8276-d195f77cfd87}
[4A6C:3444][2014-10-13T20:07:32]i352: Removing cached bundle: {af585766-53bd-4c15-8276-d195f77cfd87}, from path: C:\ProgramData\Package Cache\{af585766-53bd-4c15-8276-d195f77cfd87}\
[56A4:6374][2014-10-13T20:07:33]i399: Apply complete, result: 0x80070643, restart: None, ba requested restart: No
 
Last edited:
#25
No, you should be able to do an import statement. Something like:
<Import Path="path to the FileLocator.config in the Flight DLC directory"/>

Versions of the toolkit after 0.7.3 no longer require the Alaska Wilderness to be installed to work properly.
 
#26
No, you should be able to do an import statement. Something like:
<Import Path="path to the FileLocator.config in the Flight DLC directory"/>

Versions of the toolkit after 0.7.3 no longer require the Alaska Wilderness to be installed to work properly.
Ok I understand so what's keeping me from installing the flight tool kit into Vista?
Thanks
 
#29
there is a bug in the installer. you can try creating the dlc folder I mentioned earlier.

Edit: Oh I see you tried already. I need the other log file from the installation. It should be in %temp%
 
#31
If you don't have Flight already:
Make sure you have the latest GFWL client installed: http://go.microsoft.com/fwlink/?linkid=128962 (or www.flighttoolkit.com/flightInstallers/gfwlivesetup.exe)
You can download\install Microsoft Flight from here: http://go.microsoft.com/?linkid=9800616
Even though Flight is free, GFWL needs to generate a key for it so it can connect to the service. I have heard of people having problems getting one. If you run into this after installing Flight and haven't ever installed it before, I have a work around that can be used. Let me know if you run into this.
Hi there. I got the latest GFWL client and the game from the two links you provided. However, the game doesn't show up on my GFW Marketplace, so I can't check for the game key. I also tried running the game and signing in to LIVE as well, and even though I can sign in to my account, it asks me for the game key and it doesn't "auto complete" it. I guess I need that work around you mentioned. What can I do?

Btw, I never knew about this game before, only found out about it a few days ago, I played some missions and challenges with the A5 Icon (since the yellow biplane was locked), and I'm loving it, the graphics are beautiful, it's not too complex like other games, it feels good to control with my joystick and it has that "game" aspect with missions, challenges and jobs, which is very enjoyable for someone like me who isn't that experienced about planes and flying in general. Thanks for everything!
 
#33
OK, it worked. I could have tried that before, but I got the impression from the first post that I needed to have the key introduced before I could install the Toolkit. My bad. Thanks a lot!
 
#34
Steve,

I'm using the latest version of flight toolkit and everything seems great except one thing: when creating a profile/username the red text says that the username must be between 8-16 characters and only use letters, numbers, -, and _. However, I've tried both "Amadeus-" and "-Amadeus-" and neither work (I still get the red error text.)

I wish the lower limit was 7 so I could use "Amadeus" ...but, "-Amadeus-" wouldn't be so bad to look at in the career screen if it worked :)

Also, are the stats/profile saved on a server somewhere or locally on the computer?

Finally, I'm thinking you probably have source to MS Flight around somewhere for reference, so this is probably a bogus offer, but I have made a second career as a reverse engineer of games (mostly MMOs, but I've dabbled around occasionally.) Anyway, be willing to donate a little time here and there where I can if there were any reverse engineering needs of the actual client itself. (Otherwise, I'll just enjoy playing the game!)
 
#35
oh I think the name must start and end with a letter or number.

I have reverse engineered most formats or used fsx formats as reference, but I think most of it is figured out. Thanks for the offer!
 
#38
That would be great if you could change that rule -- but, obviously not a huge priority I'm sure.

Yea, I'm very good with reverse engineering compiled C++ (executables or DLLs, etc.), but worthless/clueless with regard to file formats...lol. I always use detours, provide routines that expose data, and call application functions and have never really worked on a project where additional data was provided to the client..so, I've never had to mess with reverse engineering file formats.

I recently had to do some bitstream reverse engineering though (for the first time) and that was new/different. :)

But yea, I'm digressing and getting off-topic. Thanks for doing flighttoolkit -- it's a great resource and I'm looking forward to seeing new(ish) things for MS Flight!
 
#39
Oh, and one more quick question: Do you have a site where you post test builds of flighttoolkit? I know about your wordpress site, and I can see you're posting there pretty often; however, I thought I'd ask just in case. Also, do you have a favorite IRC hangout?
 
#40
Steve usually tests in private with some other developers and if there is a bug which is noticed, he usually posts a test in the AVSIM forums or here. However, those are very rare! ;)
 
Top