FSX FSDS light map not working?

#1
I followed the default FSDS 3.5 light map tutorial. Checked "Light map with alpha" on the daytime texture. Created the texture with the same name as the daytime texture and added _L, created an alpha with black and white parts distinguishing landing light vs panel light lit areas. And the lights don't come on. I think it's something I'm doing wrong. Help would be apprieciated, thanks!
 
#4
And I have tried ticking "night" "light map" and "light map with alpha", and changing between "L" and "l", and "LM", all to no avail.
 
#6
No, they don't. However the daytime textures work fine and are reflective, as checked in FSDS. If I try to change them to end with _T, is there a way to get FSDS to still recognize the "_T" files as the original so I don't have to reapply and remap all the textures in FSDS? (So many parts were joined and split and joined..... that it would be almost impossible to retexture some parts the way they are.
 
Last edited:
#7
Here's what I'm doing in detail step by step. See if you guys can spot what I'm doing wrong. (there's almost no tutorials out there, besides the default help file)

Here's the plane in daylight:


the daytime textures are "CS300_fuselage_left_side.bmp" and "CS300_fuselage_right_side", both DXT3 format, 1024x1024. "Reflect" is checked when they were added and applied. thus the filenames in FSDS are "CS300_fuselage_left_side.bmp,R" and "CS300_fuselage_right_side,R". As you can see, the plane in FSX reflects beautifully, indicating that ",R" is working.

1. The light maps are created. with cabin lights lit greenish on a black background. Alpha is also included (white for landing light lit areas, black for panel light areas). Both files are also DXT3 format and 1024x1024. One is named "CS300_fuselage_left_side.bmp_L", the other "CS300_fuselage_right_side_L". These are placed in the same folder as the daytime textures (in /FSDS_V3.5/Projects/).

2. I now open the project in FSDS, go to Manage texture list, select the daytime fuselage textures and Edit. I now tick the "Light Map/Alpha". Clicked yes when asked if I want to change all references in model. Now these textures appear in the manage texture list as "CS300_fuselage_left_side.bmp,R,A" and "CS300_fuselage_right_side,R,A"


3. Going to the Manage Texture List again, I add the 2 "_L" files created in step 1 to the list. I'm not sure if I should tick "Light Map/Alpha" here, although it seems like neither options worked. (The 1st time I skipped this step 3 entirely and added the 2 "_L" files directly to the texture folder of the plane in FSX, that didn't work)

4. The plane is exported to FSX. I check if both "_L" files are inside the exported texture folder. They are indeed.

Not working:


Sorry if this was long. I suppose somewhere along the way I made a mistake. Hopefully someone points it out. Thanks again!
 

Attachments

tgibson

Resource contributor
#8
You should be able to change the name of textures by going to Edit/Manage Texture List, clicking on the relevant texture, and clicking Edit. Then click the Browse button and click to your new texture (a copy of the current texture with a new name). Then click Open and then OK. A warning will appear, click Yes. Then click OK. Your new texture name should be used, and all mapping should be retained. Save your model before doing this, of course.

Hope this helps,
 
#9
You should be able to change the name of textures by going to Edit/Manage Texture List, clicking on the relevant texture, and clicking Edit. Then click the Browse button and click to your new texture (a copy of the current texture with a new name). Then click Open and then OK. A warning will appear, click Yes. Then click OK. Your new texture name should be used, and all mapping should be retained. Save your model before doing this, of course.

Hope this helps,
Thanks tgibson. I followed your instructions and added the _T, then I did the same procedure shown in reply 7, but the night lights still don't show up. Now FSDS wouldn't even export the "_L" files into the texture folder anymore. Manually putting them in did not work. Then I found out I had to name the night files with "_T_L" in order for it to be exported with the other textures :confused: , but that didn't make it work either. So I'm still doing something wrong haha.
 

tgibson

Resource contributor
#10
Yeah, like I said I didn't think that FSDS required that.

One is named "CS300_fuselage_left_side.bmp_L", the other "CS300_fuselage_right_side_L".
I assume these are instead CS300_fuselage_left_side_L.bmp and CS300_fuselage_right_side_L.bmp?

You should not be adding the night textures to the texture list as you did in step 3 of your post above. These will be added automatically by FSDS. Perhaps this is the problem? Remove the night textures from the list.
 
#11
I followed your advice and let FSDS automatically export the _L files. Opened up the sim but saw no lights. **However, using the same procedure, I decided to try ticking "Night" instead of the "Light Map /Alpha" and renamed the files _LM and that worked!

Of course, doing it this way the cabin lights stay constantly on with no way of turning them off. Any idea why the _LM ("Night") worked but the "_L" (Light Map with or without Alpha) doesn't work?
 
Last edited:
#12
I guess that all "_L" textures are triggered by the landing lights and the "_LM" textures by MS daytime. Better check this facts, because I don't remember the exact difference between them.
 
#13
Have a look at the "Emissive Map / Self-Illumination Map" section of the "texturing aircraft models" help document in the SDK, it says to use "LM" for Self-Illumination Maps & no alpha is required.

Here's what it says about the material options:

Additive, AdditiveNightOnly, Blend and MultiplyBlend. There are the same four options with the postfix UserControlled.




    • The Additive option employs the emissive map in such a way that all values in the map brighten the object it is applied to. When Additive mode is chosen, the emissive map should be enabled all of the time, regardless of the ambient lighting values in Flight Simulator. Black on an emissive map set to Additive will have no effect.
    • Additive applies all the time, AdditiveNightOnly obviously only applies at night.
    • Blend is the third option for the emissive map mode. Here the map is displayed as per the other options, but is tied to the ambient lighting value in Flight Simulator. As that lighting value darkens, the emissive map effect is blended from a fully disengaged state (day) to a fully engaged one (night).
    • The Multiply Blend option is usually used to add colored tints to light colored, or white, gauge elements, and is progressively applied as it gets darker.
    • The Additive User Controlled option is usually chosen to enable light-splash on the aircraft’s surface so it can be engaged and disengaged as the lights are switched on and off. All the UserControlled options apply only when the Panel switch is turned on.
 
Last edited:
Top