mapping vc gauges, help?

hi, everyone! i worked through the issues with my car's FDE. now my issue is with the gauges. how do i make this texture appear in the simulator? i tried UV mapping by selecting a face from the sdk tutorial and it still doesn't appear. how do i create a texture sheet and make it appear in fsx? it only renders in 3ds max and i have it in the P3D Materials folder . After, how do i add & position the gauges to be where the speedometer is?

vcford2.png



vcford.png
 

n4gix

Resource contributor
All VC instrument artwork must be mapped to a bitmap sized with powers of 2. For example
  • 1024x1024
  • 1024x512
  • 512x512
  • etc.
All VC textures must have a $ as a prefix, which tells FS/P3D to generate a memory bitmap for the gauges to be projected on.

You set the gauge's position on the bitmap by telling the sim where the top left corner is located, followed by the "size" of the gauge's background. For example::

[Vcockpit01]
Background_color = 0,0,0
size_mm = 1024,1024
visible = 1
pixel_size = 1024,1024
texture = $B350i_VC1
gauge00 = ProLine21!pfd_left, 0,0,511,627

The above 0,0 means that the pfd gauge is projected on the $B350i_VC1 memory bitmap from 0,0 (upper left corner) and is 511 pix by 637 pix in size.
 
All VC instrument artwork must be mapped to a bitmap sized with powers of 2. For example
  • 1024x1024
  • 1024x512
  • 512x512
  • etc.
All VC textures must have a $ as a prefix, which tells FS/P3D to generate a memory bitmap for the gauges to be projected on.

You set the gauge's position on the bitmap by telling the sim where the top left corner is located, followed by the "size" of the gauge's background. For example::

[Vcockpit01]
Background_color = 0,0,0
size_mm = 1024,1024
visible = 1
pixel_size = 1024,1024
texture = $B350i_VC1
gauge00 = ProLine21!pfd_left, 0,0,511,627

The above 0,0 means that the pfd gauge is projected on the $B350i_VC1 memory bitmap from 0,0 (upper left corner) and is 511 pix by 637 pix in size.

I tried rendering it in 3DS Max but the render map shows it as black. How do i fix this to get this onto the panel?
1575096224342.png


1575096244677.png


1575096261308.png


here are further settings:


1575096285210.png


1575096316332.png




& texture is not rendering here from the material editor . how do i fix this?:
1575097738444.png

1575097776332.png
 
Last edited:

Deano1973

Resource contributor
Make sure you're texturing the correct side. I don't use 3DS but I notice the Y axis is pointing away from the driver's seat, which might possibly affect how the texture map displays from that position. Try swapping the box for a plane, one sided, with the Y axis reversed / plane rotated as necessary to face the active side of the plane toward the driver. Then try texturing again and see how it looks, making sure you also follow Bill's advice above.
 

n4gix

Resource contributor
On the Material Editor, click on the little blue ball to show the image in the viewport. It is the fourth icon from the right side.
 
On the Material Editor, click on the little blue ball to show the image in the viewport. It is the fourth icon from the right side.
I did that. I was able to manipulate the texture with the UV unwrapper, but in modelconverterx, it doesn't show. How do i get it to show? and if i render it , it only renders black and not the texture sheet. it is saved as a black texture . how do i fix that? i even put 2048*2048 in the options for the rendering size and it still renders black on the render map
 

Heretic

Resource contributor
The bitmap must be pure black (RGB 0,0,0) without any alpha channel and the material editor in 3ds Max must have "Is virtual cockpit panel texture" checked.
 
The bitmap must be pure black (RGB 0,0,0) without any alpha channel and the material editor in 3ds Max must have "Is virtual cockpit panel texture" checked.

I checked that part. The texture shows up in model converter x but it is black in FSX. How do I fix it to position the gauge on it? I have it in my texture folder without the “$” for now to avoid confusion. should it be in my panel or texture folder?, and should I have it as a .dds or bitmap?
 

Heretic

Resource contributor
You don't have to have the texture file present in the panel folder.

And I strongly recommend working through the SDK documentation and inspecting other, working simulator models for reference.
 

tgibson

Resource contributor
As people are explaining above, some people make the gauge polygon completely transparent, relying on the VC panel itself for any texturing. If instead you want the background bitmap to be visible on the gauge polygon, you do need to have the texture present in the panel's folder. It must also be specified in the relevant VCockpit section of the panel.cfg file. As an example, below find a VC gauge polygon that uses the $pan1 pseudo texture for the gauges, but also displays the pan1.bmp file as the background on that polygon. This texture is located next to the panel.cfg file in the panel folder. This allows me to light the panel gauges, etc. using a night texture. Note that the night texture goes into the plane's texture folder, and must be flipped vertically. (!)

[Vcockpit01]
file=pan1.bmp
Background_color=0,0,0
size_mm=512,512
visible=0
window_size= 0.320, 0.427
pixel_size=1024,1024
texture=$pan1
window_pos= 0.000, 0.000

gauge00=Z_DC6KMTG!GPU_MASTER_SWITCH, 372,388,14,19
...
 
I had a similar problem in Blender and found it was due to the texture naming and making sure that the name of material and texture in blender were the same as the final texture DDS file in the aircraft texture folder.
 
Top