FSX Modelconverter error

#1
Hi, I have windows 8 and modelconverterx doesn't seem to be working properly the stable version and the development release. I cannot import, export or do anything. As soon as I start modelconverterx error comes which you can see in the attachment in the image. I cannot do anything; I tried running it on administrator but it's still the same. Now I really want modelconverterx because its easy to use. I need help to fix this problem. PL HELP Thank you
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

Given the red cross I see I expect it to be related with the video drivers. What kind of graphics card you use?
 
#3
Mobile Intel(R) 4 Series Express Chipset Family and modelconvertex worked properly with this graphics card in my previous windows vista version plus this the same graphics card I use in my new upgraded widows 8 and modelconverterx does not even work when everything else works fine. When I got windows 8 and downloaded modelconverterx there was no red cross except that error box with small red cross which I used to get when I tried to import any model. Pl help me fix this
 
Last edited:

Pyscen

Resource contributor
#4
Hello Indi,...

MCX as well,... ADE and a few others all work in Windows 8 and 8.1...

The possible problem is that the .NET Frameworks need to be activated within Windows 8 and Windows 8.1.

From the "Control Panel" (Can be reached from the new Start screen by typing in "Control Panel"),... Within Control Panel, Click on "Programs" then under it you will See "Turn Windows features on or off".

A new Window will pop up,... Look for ".NET Framework 3.5" (which will include .NET 2.0 and 3.0) make sure its clicked. Also make sure that ".NET Framework 4.5 Advanced Services" is clicked. Only the "ASP .NET 4.5" and the "TCP Port Sharing" need to be click under the ".NET Framework 4.5" tab.

Hopefully this is the only problem that your having,...
 
#7
I did what you told me to do and I placed the MCX files in my download folder I downloaded 1.3 and later development release but both of them don't work.
 

Pyscen

Resource contributor
#8
hello Indi,...

ok,.. were the .NET framework clicked? already? or did you have to do that? What do you mean inside your download folder? Have you copied all the files from the zip file into a separate folder?
 

Pyscen

Resource contributor
#12
ok,.. copy all the files into a new folder outside the download folder,.. such as the main directory of your C: drive,... MSFS\MCX\ then all the files.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#14
I don't have Windows 8 myself. But could it be you need to update the drivers of the graphics card?
 
#15
Everything is fine and updated, its only MCX that makes me angry. I had windows vista before and it worked fine and now windows 8 and MCX doesn't work while everything else works fine. Can someone please please fix this and make MCX work with win 8.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#16
Hi,

We can't fix it for us if you don't provide more information. All I can tell you is that modelconverterx needs .net 2.0 and proper OpenGL drivers for the graphics card.

You already checked the .net framework, but did you check the graphics drivers already?
 

Pyscen

Resource contributor
#17
It would seem that the Mobile Intel(R) 4 Series Express Chipset Family has issues with Windows 8. In searching,.. it appears to be orphaned by Intel (no update for). Also,.. appears that the OpenGL is v1.1.

And If I recall,.. Arno,.. Check to see if I'm right,.. Indi needs 2.0 or higher? There are possible updates through Microsoft, but it wouldn't guarantee anything or warranty.

Indi,... do a search for the Mobile Intel(R) 4 Series Express Chipset Family with Windows 8,.. and go from there.

Hope this helps,
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#18
For the advanced features like bump maps, etc modelconverterx indeed requires OpenGL 2.0 or higher. But the fallback simple rendering should also work with earlier OpenGL versions. Although I think the OpenGL shader language at least requires OpenGL 1.3.
 
#19
sorry to replying late but is there any solution to make modelconverter work in windows 8? plus what do I need to update? and how to find out what Opengl version I have?
 
#20
Last edited:
Top