ADE P3D v5

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Y'all will see the announcement that P3d v5 will be released next week. ADE will be available with support for the new features such as sloping airports when v5 launches. TACANs are also supported although these have been around for a while.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Well I say it will be available next week when v5 is available. But for the avoidance of doubt the work to support v5 is done and and update to the dev build 1.79 o the 24th will unlock the functions.
 
Could you share some more info about this or even some demo videos of it in action Vis a vis the new features please, so we can get to grips with it easier please?!
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
I have no idea. I think there will need to be a lot of experimentation. LM have created a number of sloped airports as stock in the sim. As far as creating new ones ADE provides access to the new properties needed but I have not tried to create one yet. I am sure that ADE will get some process and error checking code in time but until there is more experience of using this it will have to wait.

I am not sure I can share the actual SDK but I expect it will be released alongside the sim as usual
 
LM have created a number of sloped airports as stock in the sim.
Hi, do you have a list? I try the classic LFLJ and Lukla but the view is horrible practical no smooth angle just the slope 45°,there should be more bending geometry.
 
Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Hi, do you have a list? I try the classic LFLJ and Lukla but the view is horrible practical no smooth angle just the slope 45°,there should be more bending geometry.
This is probably not the full list since they were added piecemeal:

LFHU, KAVX, KCOD, LFKD, LFKX, LSGK, LFMB, EGUO, LFFC, VYKL. VNFT, VNBJ
 
Read and see videos with default objects appearing on addon airports and there is a new method for excludes in V5? Assuming we have to draw excludes now for any old airport if we want them to work? Thank you for your development work keeping ADE up to date!
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
LM moved some objects in v5 it means that micros excludes created for projects for v4 may not exclude the moved objects. I am not sure of the best way to deal with them yet
 
LM moved some objects in v5 it means that micros excludes created for projects for v4 may not exclude the moved objects. I am not sure of the best way to deal with them yet
In older versions I used the "load default objects" and loaded taxi signs and buildings and deleted one by one. Could that accomplish the same thing in v5?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Maybe - the sequence might be to first Remove Stock Data and then Load Stock Data. I think it will need some experimentation starting with the v4 project
 
I have a problem, with the aprons and taxiways, even though draw is unticked, I still get them drawn in the sim, airport is KBVU, it was 61B. it means the paths are showing up at the edges of the ground polly.
cheers
Ken
 

tgibson

Resource contributor
I don't know how to fix your problem. But for the taxiways, change them to Apron Routes. And just make aprons small enough to fit under the ground polys.
 
How i can force ADE to think that im using p3d v4, now when i have uninstalled p3d v4 and using p3d v5, it detects it to FS9 version and cannot open p3d ade files?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
If you have uninstalled v4 then ADE won't be able to work with it. If you are using v5 why do you need to go back to v4?
 
If you have uninstalled v4 then ADE won't be able to work with it. If you are using v5 why do you need to go back to v4?
No im not going back to earlier p3d v4, only need to get that ADE work if there is v5 compatible version available.
Current 1.78 version does not detect P3D, that's why i want to get the ADE work.

Now when i open ADE it goes straight to FS9 version, it will not give me choice the Sim version, i have cheated many addons to think p3d v5 is v4 so it works.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Sorry - I am not sure I understand. You can load v4 projects into v5 but they may need some processing before they will work. The main issue is that in v5 LM added a lot more stock (default items) and moved some existing ones. We are working on a process in ADE to make this easier but it is still in testing for a few more days.
 
Top