Problem Launching Flight™

#1
Hi There!

I'm new here, but was advised by a fellow Flight pilot, HB1PC3, to join this website to ask for much needed help.

As I am also posting to msFLIGHTS.net & AVSim.com to ask for the same advice, I have posted all the problematic information to a page within my own website, at:
http://www.smartartsplus.co.uk/flightadvice.htm
in the hope that someone out there in the virtual Flight skies can help me relaunch my game.

Thanking you in anticipation of a solution!

Paul J. Hopkins
(aka Lordnum)
 
#2
For those not wishing to visit my prepared web page, its content is as follows:

Hi There!

I am presenting this as a web page as I am posting a link on three forums (FSDeveloper.com; AVSim.com; & msFLIGHTS.net) to see if anyone out there can help me solve a new problem that has developed on my computer, with regard to running Microsoft Flight™. I am usually quite capable of solving my own computer problems, but this one has me completely baffled and so, I turn to you out there in Flight Simulator World for much needed assistance!

On 30th August 2016, I received an email from fellow Flight pilot, BergSpreu69, announced the launch of two new FREE aeroplanes for Flight, developed by FS Tester. That evening I downloaded both add-ons and installed them via the Flight Toolkit, agreeing to the T&C’s outlined on the installation pages. I then launched Flight and gave them both a good testing of my own and decided they were both a brilliant addition to the game – Thanks FS Tester for all your hard work! I parked up at Hilo International and logged out and did not attempt to re-enter Flight for about another 4-5 weeks, as I was rather busy with other matters.

My present nightmares arrived at the beginning of October, when late one evening I logged into my ‘account.xbox.com’ to see if any of my Flight pals were online in the game and saw DeltaSierra80 & HB1PC3 were playing. I clicked on my usual QuickLaunch icon to start Flight and …

After about 5 minutes of the computer gone all sluggish, a dialogue box (I have never seen before) appeared on my screen:

If I press ‘Retry’ the cursor flicks over to the ‘Switch To’ button; if I press ‘Switch To’ the Windows Start Menu appears. I have no idea what the error message is referring to by “the other program is busy.” Can anyone offer me any advice?

In the 4-5 weeks since last flying in Flight, I had not installed anything else on my computer. Nor had I performed any Windows Updates. I left the problem, once I’d managed to kill the non-launching-Flight via the Task Manager and tried again the next morning.

I got the same error message and so went to Programs & Features to see if I could either Repair or Un-Install Flight. On attempting to repair the game, progress stopped with a new error message:

which tells me to look in its default folder:

'C:\Users\Paulspixels\AppData\Local\Microsoft\GFWLive\Downloads\4d5308d2e0000001\Content\'

(where Paulspixels is the name of MY computer) but there is no 'game.msi' in there or anywhere else on my computer - I've searched! On cancelling the Repair Tool, I received error message:

I used the Flight Toolkit to remove every add-on I had, including the offending Beechcraft and Maule Ski - I say offending, because up until their installation on my PC, my copy of Flight worked perfectly! Anyway, once I had removed everything via the Toolkit, I un-installed the Toolkit itself and then cleaned the registry. Next, I un-installed Flight, deleted the remaining Flight folders from 'C:\Program Files (x86)\Microsoft Games' and then cleaned the registry again and set about re-installing Flight from scratch.

I noticed, during the new installation process that the folder, 'C:\Users\Paulspixels\AppData\Local\Microsoft\GFWLive\Downloads\4d5308d2e0000001\Content\' reappeared and contained the missing ‘game.msi’ file and so I assumed everything was okay again. When GFWLive reported that the game had been installed successfully, I clicked on the play button only to find myself back at the ‘other program is busy’ dialogue box! I checked back to the previous missing (game.msi) folder to find that it had vanished into thin air again, much like my MS Flight™ career!

Having been in touch with various other Flight™ pilots, HB1PC3 advised me to get every one of the items listed at: https://support.micr...n-us/kb/2977003 which I did and have installed all that my computer would allow:

and still no success!

I have been a Microsoft Flight Simulator addict since around 1995 and am now suffering withdrawal symptoms! I am at a complete loss regarding the above and don’t know what to do next, but maybe, hopefully, you do!?

My PC is an Acer Aspire X3990 running Windows 7 Home (64-bit) with 8 GB RAM and has never had a problem running Microsoft Flight™.

Please help me sort this problem out, so that I may announce the re-start of Flight’s AeroHunting Season – see web link, below.

Best regards,
Paul J. Hopkins
(aka Lordnum of Lordnum’s Flight Experience)
 
#3
I have now updated the C++ files on my computer, which now look like this:



and I will try to re-install the whole Flight™ and the Toolkit again, this evening. If this doesn't solve the problem, then it is time to throw in the towel!
 
#4
First I would uninstall everything (including GFWL) and follow the directions here for installing Flight: http://www.fsdeveloper.com/forum/threads/flight-toolkit.431166/

Here is a copy of the relevant instructions:
Installing MS Flight:
Make sure you have the latest GFWL client installed: http://go.microsoft.com/fwlink/?linkid=128962 (or www.flighttoolkit.com/flightInstallers/gfwlivesetup.exe)
You can download\install Microsoft Flight from here: http://go.microsoft.com/?linkid=9800616
Even though Flight is free, GFWL needs to generate a key for it so it can connect to the service. I have heard of people having problems getting one. If you run into this after installing Flight and haven't ever installed it before, make sure you use the Non-GFWL mode of the Flight Toolkit. You will be prompted for it at the end of the installation process of the Toolkit.

Installing the Flight Toolkit (Requires Vista or newer OS):
You can download the latest tools here: http://www.flighttoolkit.com/Downloads/FlightToolkit_1_1_28.zip (If you have a problem where GFWL says you need a key to play, make sure you use the Non-GFWL mode. You can change this after installation from the Addon Manager)
Website for the Flight Toolkit: www.flighttoolkit.com


I didn't see anything in your post about important info like what OS you are using. Also, did you check to see if any automatic updates or driver updates were installed between August and October that could have broke something? Have you tried running a virus scan?
 
#5
Thanks for your reply, Stonelance - much appreciated, as I'm almost at the end of my tether!
My computer is an Acer Aspire X3990 running Windows 7 Home (64-bit) with 8 GB RAM and has never had a problem running Microsoft Flight™. I never let Windows run automatic updates. I always do them manually, as I like to see what they are installing and whether I want/need it, otherwise Security Update for Win 7 'KB3035583' (Get Windows 10 - GWX) will sneak its way, malware-like, back onto my system!! I have run virus scans and anti-malware scans, since this nightmare began and no infections have been found.
I first got/installed Flight™ back in January 2013 and after a week or so of enjoying it, I bought the full package: both expansion packs (Hawaii & Alaska) and all the DLC, except for Carbon Cub Deluxe as I was happy enough with the Basic Cub. I got a key when I first joined via http://microsoftflight.com/ and changed my name from the randomly selected name to that of 'Lordnum'.
Last night, I uninstalled everything again and today, I been reinstalling everything, via the GFWL (using the latest client).
This time the contents of folder: C:\Users\Paulspixels\AppData\Local\Microsoft\GFWLive\Downloads\4d5308d2e0000001\Content
stayed intact, complete with the 'game.msi' file, but still the game will not launch and takes me back to the initial problem of the 'other program is busy' dialogue box.
What will happen if I uninstall all the C++ Redistributable Packages that I have installed on my system? … Fellow Flight™ pilot HB1PC3 has been invaluable to me in helping to try and get me virtually airborne again, but the list of installed C++ Redistributable Packages now comes to 21 and I'm sure I didn't needx any of that list before this problem began!
 
#6
Lots of different things will depend on those, so it is hard to say what will happen. You will most likely break something. The Flight Toolkit for example depends on the 2015 x86 redist. I've never heard of anyone having the problem you are having with Flight. I suspect something has happened to your Windows installation or PC. Are you having problems with any other software?
 
#7
I've decided to uninstall all the extra C++ Redistributibles that I've added trying to get Flight restarted - i.e. the ones added in the last two weeks of battling this problem. As my copy of Flight was a fully paid up package, I don't believe I need the Flight Toolkit, because I have no intention of having repaints on add-on aeroplanes again, as that is where this trouble began with the addition of FS-Tester's Beechcraft Baron & Maule Ski.
I use my computer primarily as a business and art package tool and everything else works perfectly. The only problem that exists on it is with Flight and, as I discovered over this past weekend, FSX won't launch either, so I guess I'll just have to do without my favourite games for a while.
I've spoken to one other fellow Flight pilot, Flint34 and he had a similar problem when he added the Beechcraft Baron, inasmuch as his Flight then stopped working, but he was able to uninstall both Flight and the Toolkit and reinstall Flight without the Toolkit to get it working again. As I said in my initial report, the only change to my system between August & October, was the addition of FS-Tester's new planes.
In future, I will stick to the old adage, "If it ain't broke, don't fix it!" Thanks for your time and replies, but I have to go back to work now and won't be around for a couple of weeks.
 

rhumbaflappy

Moderator
Staff member
Resource contributor
#8
You could restore your system to a point previous to the installation of the new planes. You don't lose data with a restore, so it shouldn't bother your important files.
 
#9
I did try a system restore the moment I discovered that Flight wouldn't work, but even that didn't work.
As for trying a restore now, unfortunately I have been installing and uninstalling so many different programs (inc Flight; Toolkit & FSX) that the restore point prior to the offending new planes has long since been overwritten by the new points.
Ah well, Flight was fun whilst it lasted (3 years). I'll have to make do with Solitaire or reinstall Windows … which isn't going to happen anytime soon!
 
#11
"I really doubt adding those addons would have caused that kind of error. Something else must have changed.
If FSX is not working, it is could be from uninstalling C++ redists. A lot of stuff will probably stop working if you did that."


I have only removed the large number of extra C++ redists that I added over this past weekend, but have left the ones that were there before this problem started. I only discovered FSX wasn't working over this past weekend and I installed that back in 2014 when I assumed Flight was going to stop altogether, so none of the C++ redists that would have been installed at that time have been removed from my computer.

As stated a couple of times, above, nothing else had changed or been installed or Windows updated between August and October, apart from the installation of the new planes. That was the only change to my computer between Flight (and FSX) working and then them not working.

Maybe after Christmas, when I have some spare time, I will consider reinstalling Windows and my system from scratch and then look again at these games, sans Toolkit, as I still have all the original installation files for Flight backed up on an external drive.
 
#12
Yesterday afternoon, I uninstalled all the extra C++ redists I had installed over this past weekend and this morning I reinstalled Flight and everything worked! Well, almost everything … I have miraculously gone from Pilot Career Level 26 back down to Level 1 and have to learn how to fly again and redo all the various missions and achievement to regain all the built in repaints that I'd already achieved. I've also lost the RV-6 RCAF repaint which I unlocked by finding the Keyhole Aerocache. Ah well … better than having no Flight at all, I guess!
 
#13
I will now concentrate on the re-opening of AeroHunting Season for those that still like to discover all the oddities hidden in the fantastic scenery to be found in Flight.
Thanks for taking the time to respond to my queries :wave:
 
Top