• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Problem with a comp texture - its there but doesnt get compiled

Messages
237
Country
germany
Hello.

Not sure where to post this since it has various aspects, i hope its ok here. Its a SubstancePainter file but the error occurs on build only.

I have a problem with some texture that i made with Substance Painter. My project has nearly 30 objects, all done the same way but it only affects this one object/texture.
The problem is that the metal texture of one single object (AO/Roughness/Metal) doesnt get included in the build.
Weird thing is, its there everywhere. Its applied in Blender, it gets exported into the gltf (its attached, see line 456), its in the modellib/texture folder and the texture itself is working fine (one can view it in any program, its shown in Blender and of course in SP too). Its a comp texture (metal channel, with Rougness and AO), exported with Substance Painter MSFS exporter.

But when i build it i get this:

1619837933421.png


The pic above shows a build of the project directly after only this certain one object was re-exported to the modellib, so it shows only the log after adding this new object. The metal-texturepart of this object is always skipped and then hes crying that it wouldnt exist. But it does exist, 100% (see one of the pics below).

The Substance Painter file of course has AO

unknown.png


And roughness

unknown.png


This is how i export (like always)

unknown.png


This is the modellib

unknown.png


Here one can see it applied in Blender (anyway one can see it in the gltf attached)

unknown.png


Ive tried so many things already without luck....I renamed the textures, re-exported out of SP, saved it into another project and built there, all those things and more, it doesnt get compiled. If someone renown here would have the time to take a look i can send him the object with textures. Would be amazing. This is a more or less important object, its the mainbuilding.... and the roughness wouldnt hurt here.
 

Attachments

  • EDMI-Vereinsheim.rar
    2.7 KB · Views: 66
Last edited:

Lagaffe

Resource contributor
Messages
724
Country
france
Last week I have experimented the same thing with Armorpaint. I have had the same error messages !
Solution:
I have deleted the old material in Blender and changed the texture's names (HN433_Siege.png => Siège.png).
After that I recreated a new MSFS material with the new textures names for the png and the export succeed.

Perhaps a PB with a bad material (created for FSX) or a PB with the prefix of the names used : all textures are for my Ménestrel HN_433 and all names were like HN433_*****.png, the compiler seems to be very litiguous.
 
Last edited:
Messages
237
Country
germany
Thank you Lagaffe.

I will try to rename again but i did that already. It's so weird....no idea what is happening
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,339
Country
us-wisconsin
What if you load the material into a paint program, and then re-export it as PNG. Use a different paint program than what created the original texture. There could be something about the format that the compiler doesn't like.
 

Lagaffe

Resource contributor
Messages
724
Country
france
My answer have two parts:
- renaming the texture is the first part
- delete and recreate the MSFS material is the second part (it is the solution)

I have this trouble an other time this afternoon so I delete this MSFS texture, save blender file, quit the program and launch Blender to recreate the texture: It is OK now.
 
Last edited:
Messages
237
Country
germany
The thing with reexport from another program may be good try.

Yes Lagaffe, ill try it now again. Before reading here i re-exported again out of substancepainter, one time in 8 bit 4k and one time in 2k only. Tried with both but no luck... hangs always at the same metal map.

Will try these 4 things now

- renaming (again)
- export out of another programm, like gimp or something.
- re-import the blender file into substance, renamed, and export again
- attach a whole other normalmap to the object, even a wrong one, just to try (tip from Karlo, to troubleshoot)

Will report^^ Thanks everyone.
 
Messages
933
Country
australia
I downloaded and added the texture to a model. Seems to have compiled just fine for me. I'd delete the material from Blender and recreate it. Unless you want to go into the Shading tab and double check that the materials are all joined up correctly. Notice that the error message appears right after the model has started to be compiled. That suggests an error with the material definition in the model rather than the texture itself. The easiest solution is to delete the material in blender and make a new one.

For example, I detail one issue I had with Blender and the materials here. It may not be your issue but it shows how an error in the material definition can be something that prevents the model from working properly: https://www.fsdeveloper.com/forum/threads/blender2msfs-breaking-metallic-texture-output.450603/
 
Messages
237
Country
germany
Anthony, that looks very promising. Thank you!

Got unexpected visitor and still couldn't try the other tips so far but now that i read your linked post i remember seeing something like this.

When i reexported the texture and applied it in blender it added a .001 behind the png.
Never saw this before. I've seen that the .001 etc is added to a nodename on copy or to the material but I've never seen it be added behind the .png so far.

So at the texture slot in the msfs standard material settings the path to the texture looked like this always:

../textures/EDMI_Vereinsheim_Metal.png.001

I wasn't sure what that means since it made no sense for me. Why would he write a 001 behind the png if the name has no 001 in it.
Then I simply deleted the .001 and exported. The model looked fine in blender, so i thought all is good. Seems not.

Sounds on first look like it could have the same offspring then.

I have the feeling one of those 5 tips now will make it work. Thanks a lot everyone!

EDIT:

This is what im talking about

1619915722516.png


Trying it out now.
 
Last edited:
Messages
237
Country
germany
YES! That was it :) Amazing.

I had that gltf.001 setting too, like youve said Anthony. Deleted it and deleted the .001 out of the single nodes, that automatically deleted the .001 behind the pngs too and now it compiled ^^

EDIT:

And i saw how it happens now to, on my models, that so far all have 4 k 16 bit texture set, i wanted to do the albedo in 8 bit only just now. So i exported in SP to another folder, same name just with 8 bit. Then i went to Blender and applied this 8 bit to the Albedo slot. Voila, it writes a .001 in there again.
This doesnt happen when the texture is renamed before added.

So that .001 goes there as soon one is applying a texture with the same name as before but out of a different folder maybe? At least it looks like that. But nearly cant be that this is the only thing that has influence. It doesnt happen on all my models. I did this with a few other without the .001 getting added.

EDIT2: jup, thats the step that brings up this problem. Easy to reproduce. Save textures to another folder, with textures having same name. In Blender choose new texture from new folder, .001 gets added.
 
Last edited:
Messages
255
Country
germany
The reason for this is that even if you delete materials and textures in Blender they are kept in the background in the blender file. When you reload the texture it gets assigned the 001 extension and therefore isn't recognized as an image anymore after export. In the outliner near the top right corner select "Blender File" instead of the default "view layers" here you can permanently delete images and materials from the blender file.
 

Lagaffe

Resource contributor
Messages
724
Country
france
For reasons I don't know, during multiple manipulations on materials, some of them can get corrupted and lead to these compilation errors. The *.png.00x can be sources of problems because they are in the GlTF file exported by Blender but don't exist really on your hard disk. Sometimes, I have edited the GlTF blender file in Notepad and make manually corrections to point to the right names but it is annoying.

The only effective solution for me is :
1 - to destroy the material or even to go through the Outliner and Orphean Data (this function permit to deleted ALL olds images, mesh, textures that you daoe'nt want anymore) to remove all traces and then save the Blender file.
2 - when I reopen the file, I create a new material with the textures that were causing problems and everything will back to normal.

PS: Outliner and Orphean Data can permit to resolv what Fabs79 is saying: remove all datas keeped in bakground.
 
Top