FS2004 Prop transparency conflict with clouds

When I design props for FS9 AI aircraft, I find that the transparency of the slow and blurred disks causes a drawing order problem with any low cloud behind them:



Is this a known FS9 problem (FSX seems to be OK) or is there a way around it please?

John
 

tgibson

Resource contributor
It is a known problem, and there may be a way. If using FSDS 2, make sure the slow and blurred props are the last ones in the parts list. To do this, Cut them from the model and Paste them back in.

For FSDS3 and GMAX, make sure that your material for blurred and slow props has at least a tiny bit of transparency (opacity < 100) so MakeMDL will do the same thing.

Hope this helps,
 
Thanks Tom. I'm using Gmax and my opacity setting for the prop_slow and blurred material is set at 99% although I've tried it at 95% too. The result is the problem in the screen shot.

I've saved the texture as Dxt3 but I've also tried what I think is the Microsoft format for the DC-3 props which is 32bit (I presume 888-8). That still creates the drawing order problem, although not for the default DC-3.

I'm not clear whether the prop texture should have the "_t" suffix for transparency. Could you just advise on the right texture format please?

John
 

Heretic

Resource contributor
Try to name the material for prop_slow "ZBIAS_prop_slow".

That should, IIRC, make it show above everything else.
 
Thanks for that one Heretic, but it didn't work unfortunately. I wonder if the result is peculiar to my Graphics card (Nvidia GTX 580 SC)?

John
 
I wonder if the result is peculiar to my Graphics card (Nvidia GTX 580 SC)?
No. This is a typical problem with AI_aircraft in FS9.
All transparent parts of the AI_aircraft, whether texture or material, will covered by the clouds.
 
Aha, you are right Flusirainer. I've just confirmed that by setting up the default DC_3 as AI. The slow and blurred props also disappear when viewed against cloud. Worth asking the question though.

John
 
Top