• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v4 Specular Texture not recognized by ADE

Hi,
Reading how it's done is supposed to be straight forward but I am running into some trouble achieving this. I read the manual/forums but to no success.

I am creating a GP line in ADE, which works perfectly in the sim. Trying to add a specular texture though by placing it in the ADE's main texture folder with a suffix of _Specular, as per manual instructions, ADE doesn't recognize it. This is confirmed in the sim and also from my scenery's texture folder, which only has the main texture copied not the specular texture.

I also tried the same workflow for GP poly and the same problem exists.

Anyone can shed some light on what I am doing wrong?

Thanks
 

gadgets

Resource contributor
Did you specify the Material to be used to the GP Editor when you created /edited the line/poly? See user manual pages 7 and 25
 
Hi,
I did all the definition through GP texture editor but not in material editor. I was under the impression that material editor will give you all the options similar to MCX options but for adding just a specular texture this can be done automatically by adding the same texture name with _Specular suffix in ADE's texture folder. This assumption is wrong? Main texture works ok, just specular is not detected.

Thanks
 
Hi,
I did also the material definition and still specular map is not recognized by ADE. I guess I am still missing something basic. Here is my complete workflow:

1) Texture xyz.dds and xyz_Specular.dds are placed into ADE Texture folder.
2) xyz.bmp (24 bit) is placed into Texture_Dpy
3) In ADE I go into GP Material editor and choose, "New Material" - I name it xyz and define all parameters as I have them in MCX for the same material using specular map.
4) I go to GP Texture editor, define the texture there.
5) I create a GP line and in the end in GP editor, I define layer, width main texture, line pattern and for material I choose the xyz I created in material editor.
6) I compile airport but specular texture is not copied in the scenery's texture folder.

Am I missing anything here?

I attach a screenshot of material editor for the material I create in case I have a setting wrong there and ADE keeps ignoring the specular texture.

spec.jpg


Thanks
 

gadgets

Resource contributor
You seem to have done everything right, I see no reason from a review of the related code why the texture is not copied and, to my recollection, no one else has reported such an error. So, I need to be able to duplicate your situation.

You have not identified which versions of ADE and ADE-GP you are using. If not ADE 1.78 or later, please update and try again. If you are using a recent version of ADE, please zip up and post the following files:
  • your .ad4 file,
  • the compiled .bgl,
  • xyz.dds
  • xyz_Specular.dds
  • Texture_Defef.txt
  • Lines_Def.txt
 
I am on version 1.78 because when I installed 1.79 I had some issues with the in sim aircraft position (not shown) so I reverted back to 1.78 that is working ok.
Let me update to 1.79 again and test the same workflow and get back to you shortly with the results.
 
I did the same workflow with v1.79 and the specular textures are now being copied as expected! Not sure what the issue was but the newer version looks like it fixed the texture recognition.
Another issue I noticed is that if I import the GP bgl compiled with ADE, into MCX, even though it shows on the debug lines at the bottom the correct number of objects being read, it doesn't load all of the objects and materials into preview or material editor.

Any ideas on this?
 

gadgets

Resource contributor
Another issue I noticed is that if I import the GP bgl compiled with ADE, into MCX,
Perhaps a MCX "guru" will jump in and explain.

Glad the latest version of the GP Editor (included in 1.79) resolved the issue
 

tgibson

Resource contributor
For your MCX question, I suggest posting it on the MCX forum. That said, I don't know if Arno ever stated that MCX could load already created GP BGL files created by ADE?
 
For your MCX question, I suggest posting it on the MCX forum. That said, I don't know if Arno ever stated that MCX could load already created GP BGL files created by ADE?
It does load them but only one at a time and randomly. Not something blocking just came across it and thought of mentioning it in case I was missing something from my part.

@gadgets

Moving to the next step of the specular (testing it in the sim), unfortunately it still doesn't work as a specular texture. Specifically, as confirmed above, with ADE 1.79 the specular texture is recognized and copied over to the scenery's texture folder however checking the result in the sim doesn't seem to be having any effect.

What I am doing is that I have the straight lines done in sketchup and then through MCX exported directly (with the specular textures defined in MCX material settings) and all is working great in the sim with a clearly visible result.

A few lines that need to be curved I used ADE GP. Main Texture and specular used are the same ones as used in MCX for the straight lines thus it's neither that the specular texture is problematic, nor that it's working and I don't "realize" the effect because in the sim I have side by side one line from MCX (with working specular) and one from ADE GP.

As a test, I tried using color values for the specular in ADE-GP and that worked ok so again it doesn't look like an issue of material definition/linking to the main texture.
Since in ADE-GP there is no specific specular texture definition, unlike in MCX case, is there a must have and/or a must not have setting for the material and texture and blocks it from showing up in the sim?

Thanks again for all the great help,
 
In addition to the issue outlined above, I attach a screenshot from the sim, (showing the same main texture and same specular texture being used in both MCX and ADE-GP), and the difference in the result (ADE-GP having the same result as without specular).

Also material settings in GP are the same ones used in MCX.

Any help appreciated.

Thanks

ADE_GP_Spec.jpg
 

gadgets

Resource contributor
If you send me the files I asked for several posts above and note which particular GP line is the one of interest, I'll see what's going on inside the *_GP.bgl
 
Hi,
Sorry, I thought you only requested the files for the issue I had initially (specular not being copied that is fixed in ADE1.79).

To keep it clean and help you debug the issue, I created a simple arc line at LGAV (next to the numbers of 03R) and included the rest of the files you request. The issue remains exactly the same.

Thanks
 

Attachments

  • Debug specular.zip
    1.6 MB · Views: 13

gadgets

Resource contributor
The problem is that while the specular texture is being moved into the texture folder, it is not referenced in the *_GP.bgl file. Don't know why yet, but I will "get to the bottom of it".
 

gadgets

Resource contributor
Please give the attached a try and report.

If this works (and I believe it will), this is a watershed moment - all because of a missing "*" in a wildcard statement
 

Attachments

  • ADE_GroundPolys.dll.22139.zip
    152.6 KB · Views: 13
Hi,
Unfortunately it still doesn't work. I replaced the dll with the one attached above and I even did the workflow of the material from the beginning just in case. Result in the sim still the same, as if there is no specular.

Some things I noticed in case they help:

1) In the Scenery's Scenery folder, there is now a new EMPTY folder created during build, called, "ADE_GP Textures". I don't know if this is accidentally and if it's now referencing the textures to a different path, although I copied the textures in that folder as well. In the Scenery's texture folder, textures (specular as well) were copied as expected.

2) My tests are in P3Dv4 and during initial ADE loading I select P3Dv4 as a sim version. Not sure if the code is common or different between the two.

Thanks
 
Hi again,
After playing around a bit with the new dll, I finally managed to make it work!! The issue was that in material properties I had to disable the options under "Fresnel Ramp affects:"
I definitely tried those off as well before the new dll and still was not working, so we can confirm that the new dll is the fix!

Only grey area now is with the new folder in the Scenery's scenery folder, called ADE_GP Textures and is empty. Is there a new requirement for this or shall we ignore and delete it?
 
Top