• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Substance Painter

Messages
119
Country
spain
I have managed to import my own materials into the simulator using the Albedo Map and the Roughnes / AO / Metallic Map.

But as soon as I put the Normal Map on my own material in the "Material Inspector" the texture stops working fine and only the edges of the polygon and an oblique line in the center are shown to me.

I am exporting the Normal Map from Substance Designer with the following settings:

- DirectX.
- Components: RGB.
- Color Space: SNorm.
- 8 bits.
- Exported color space: Raw.
- 2048 x 2048.


EDIT: I noticed my albedo map is not working good either... it is showed always on gray.
1.PNG
2.PNG
 
Last edited:
Messages
94
Country
netherlands
I have the same problem as you. Noticed that if I only use the albedo map it works fine, but as soon as I add the Normal or comp it goes wrong.
 
Messages
119
Country
spain
I have the same problem as you. Noticed that if I only use the albedo map it works fine, but as soon as I add the Normal or comp it goes wrong.
I used your guide so it makes sense hehehe.
I will try to figure out where is the problem and i will post it here as soon as i fix it.

If anybody knows the correct form to create a new PBR material on the SDK please share.
 

Vitus

Resource contributor
Messages
1,480
Country
newzealand
Quick FYI:
I uploaded a new version of the Substance Painter export-presets to the resources, pending approval by the moderators.

I made some improvements on the export settings since I uploaded them here:
  • Added two emissive texture sets
  • Changed the format of the Metallic maps to 16 bit PNG, as recommended in the SDK
  • Changed the output format of Albedo /w alpha to TGA. I found that it makes it easier to work with in Photoshop.
 
Messages
119
Country
spain
Aaaaaand it's aaaaaliiiiiiive:
Thanks you Vitus!
It work perfect for me when painting my 3D Models.
But im still having problem with the normal map on custom materials.
 
Messages
235
Country
unitedstates
I am just about to download and start learning Substance Painter. I created a building for the first time this week in Blender and baked an AO map for it. I was happy yesterday to be able to get it into the sim and see it. Now my question is one of workflow. This is my assumption... I can now export my mesh from Blender to Substance Painter and it will have my model and AO? Then I can texture the model in substance painter and when it's done I can export back into Blender and it will have my full PBR textures from Substance Painter? Do I then need to assign textures within Blender before exporting to MSFS? Assuming I have to assign the textures in Blender and it's not already done then at that point when I export using MSFS Materials then the model should show in the sim with PBR textures? Am I in the ballpark here with how this works?
 

Vitus

Resource contributor
Messages
1,480
Country
newzealand
I posted my workflow in another thread, if you remember our earlier conversation... you can find it here:
 
Messages
235
Country
unitedstates
I posted my workflow in another thread, if you remember our earlier conversation... you can find it here:

I remember your post and I had it bookmarked. Just trying to still wrap my head around how this works. Am I going to be able to come out of substance painter with full PBR, normal map, and emissive textures for the model? I guess that's what I'm wondering. I am trying to keep from bouncing back and forth between too many programs.
 

Pyscen

Resource contributor
Messages
2,846
Country
us-texas
I remember your post and I had it bookmarked. Just trying to still wrap my head around how this works. Am I going to be able to come out of substance painter with full PBR, normal map, and emissive textures for the model? I guess that's what I'm wondering. I am trying to keep from bouncing back and forth between too many programs.

That is correct... from SP you can get full PBR textures. The only thing you might have to do yourself (using either Photoshop or GIMP) is placing certain maps in their proper channels. If you are using Photoshop, you will want to use tga instead of png. Photoshop doesn't appreciate png files with alpha.

The normal map you shouldn't need to do anything from SP.
 

Vitus

Resource contributor
Messages
1,480
Country
newzealand
The only thing you might have to do yourself (using either Photoshop or GIMP) is placing certain maps in their proper channels.

Actually, you can avoid that - at least for MSFS development, by using a pre-configured exporter set. I added one to the resource section a while back:

If you export your textures using a preset like this, you can plug them directly into your texture slots in blender and you'll have ready to go PBR model. Easy-peasy :)
 
Messages
405
Country
ca-britishcolumbia
I can't for the life of me figure out how to use the export presets. I've put the files in the ... Documents\Allegorithmic\Substance Painter\shelf\export-presets folder, but I don't see them as selections when I open the export texture dialogue.
 
Last edited:

Pyscen

Resource contributor
Messages
2,846
Country
us-texas
Hello

Show the directory and the preset file. Also, show where you are looking for the preset.
 
Messages
405
Country
ca-britishcolumbia
I found the solution. My version of Substance Painter was too old. I downloaded a trial version some time ago, but at that time I didn't really need it for my project. Activated it yesterday and didn't bother to update to the latest version. On doing so tonight, it now sees the presets.
 
Top