Using SBuilderX with Prepar3D

#1
Hi, I just installed SBX after installing Prepar3d, and somethings arent working correctly.
When I start SBX, it gives me prompts which say the following:
-Check your Polys.txt file!
-Check your Lands.txt file!
-Check your Waters.txt file!
-Check your Bridges.txt file!

I'm currently unable to show the background in SBX. When I navigate View > Show background, the text for "Show background" is greyed out and I can't click it. Why is this?

Initial FSX Settings:
---------------------------------
Full Path to Flight Simulator:
C:\Program Files\Lockheed Martin\Prepar3D v4 - (in RED)
Name of the Simulator:
P3D

Shp2Vec.exe, Resample.exe and ImageTool.exe:
(unable to load folder where these items ACTUALLY are)
BglComp.exe and BglComp.xsd:
C:\MSFS\FS Design Tools\SBX315\Tools - (in black)
Shp2Vec.exe, Resample.exe and ImageTool.exe:
(unable to load folder where these items ACTUALLY are)
---------------------------------



I noticed that it says on that dialog box that "The following tools should exist in the SBuilderX/Tools folder.", so I copied the files(Shp2Vec.exe, Resample.exe, ImageTool.exe, Shp2Vec.exe, Resample.exe and ImageTool.exe) from the P3d subfolders into the SBuilderX/Tools folder.




After this, the FSX Settings dilog box looked like this:
---------------------------------
Full Path to Flight Simulator:
C:\Program Files\Lockheed Martin\Prepar3D v4 - (in black)
Name of the Simulator:
P3D

Shp2Vec.exe, Resample.exe and ImageTool.exe:
C:\MSFS\FS Design Tools\SBX315\Tools - (in black)
BglComp.exe and BglComp.xsd:
C:\MSFS\FS Design Tools\SBX315\Tools - (in black)
Shp2Vec.exe, Resample.exe and ImageTool.exe:
C:\MSFS\FS Design Tools\SBX315\Tools - (in black)
---------------------------------



Thanks!
 
Last edited:
#2
Update: I found out how to solve that issue of the greyed out 'Show Background', but there appears to be another missing folder!
HOW TO SOLVE: You need to choose a tile server. This uses a google plug in and requires internet connection.
edit > preferences(some versions dont have this)
ELSE
edit > tile servers > select 'google_api3_Satelite' > CHECK the checkbox beside it
The is a prompt when I try to pan a scene that reads the following: "Globally Exeption. Could not find a part of the path 'C:\MSFS\FS Design Tools\SBX315\Tools\Cursors\pan.cur'."
I went to the path and the 'Cursors' folder was missing. Where can I find/download this folder?
 
#3
Hello:

If you intend to use Scenery Builder X (aka "SBuilderX") < NOT 'SiteBuilderX' > to output scenery compiled for use in FSX, you must also properly install the Prepar3D SDK version 1.4x, it will then have written the required folder structure and Windows Registry strings so that SBuilderX can find them.

Otherwise, if you only intend to compile files for use in P3D version 4.x, your manually-copied SDK file solution above may be sufficient


Additionally, I would recommend installing and using only the latest "full" SBuilderX version 3.15 :

https://www.fsdeveloper.com/forum/threads/sbuilderx-v315.441705/#post-787619

"I have made a full zipped version of the program, with all folders filled for immediate use without a previous installation of version 314:"

Full SbuilderX v315

Dick

PS: Be certain that SBuilderX.exe (as well as every other FS utility and its installer) is "Run As Administrator"


If you continue to see the same error message regarding files being 'missing', let us know, and we can assist you further.


Hope this helps ! :)

GaryGB
 
Last edited:
#4
Hello:

If you intend to use Scenery Builder X (aka "SBuilderX") < NOT 'SiteBuilderX' > to output scenery compiled for use in FSX, you must also properly install the Prepar3D SDK version 1.4x, it will then have written the required folder structure and Windows Registry strings so that SBuilderX can find them.

Otherwise, if you only intend to compile files for use in P3D version 4.x, your manually-copied SDK file solution above may be sufficient


Additionally, I would recommend installing and using only the latest "full" SBuilderX version 3.15 :




PS: Be certain that SBuilderX.exe (as well as every other FS utility and its installer) is "Run As Administrator"


If you continue to see the same error message regarding files being 'missing', let us know, and we can assist you further.


Hope this helps ! :)

GaryGB

Thanks again Gary, sorry for the name mix-up haha. I've still got a few questions though.


I've already installed the P3D v4 SDK, should I overwrite the files when i install the v1.4 SDK?

And when I install the "full" SBuilderX version 3.15, does this mean I have to uninstall the previous version of SBuilderX completely?
 
Last edited:
#5
No: if necessary, re-name the prior existing SBuilderX top-folder name, then just un-ZIP the "full" version of SBX315 to the drive, and copy any desired *.SBP / *.BMP / *.TXT files from the old installation to the new
[SBuilderX install path]\Tools\Work sub-folder.

GaryGB
 
#6
No: if necessary, re-name the prior existing SBuilderX top-folder name, then just un-ZIP the "full" version of SBX315 to the drive, and copy any desired *.SBP / *.BMP / *.TXT files from the old installation to the new
[SBuilderX install path]\Tools\Work sub-folder.

GaryGB
Cool, that works in a way that there are no more error prompts popping up, thanks!

However, the maps are only able to be shown in zoom levels 0, 1 or 2 . Anything higher than that still hasn't finished downloading as Im typing this. Is this normal? Or is there something still missing?
Im using the GoogleServer_api3.dll. I've tried the normal GoogleServer.dll but it still has the same issue.
 
Last edited:
#7
Cool, that works in a way that there are no more error prompts popping up, thanks!

However, the maps are only able to be shown in zoom levels 0, 1 or 2 . Anything higher than that still hasn't finished downloading as Im typing this. Is this normal? Or is there something still missing?
Im using the GoogleServer_api3.dll. I've tried the normal GoogleServer.dll but it still has the same issue.
Solved: basic computing method. Turn it on and off again(press F1 to show/hide the map)
 
#8
Hi again:

The legacy GoogleServer.dll is deprecated, and is no longer updated or to be used; use the GoogleServer_api3.dlls instead. :pushpin:

GaryGB
 
#9
-Check your Polys.txt file!
-Check your Lands.txt file!
-Check your Waters.txt file!
-Check your Bridges.txt file!

I get these errors when loading - i also get "Error - Display Cursor" when using the line tool - any ideas why?

Thank you
 
#10
Hi, @craigt47 ,
I think that you need to install SbuilderX 3.13, then download SbuilderX 3.15 separately. Next step is to copy all files from 3.15 and put them into the 3.13 folder and overwrite.
 
Last edited:
#11
Yes i have managed to fix it now. Thank you.

Out of intrested can you use SBX to make roads with traffic? If so, are there any good tutorials?
 
#12
Hi

Yes it is.

You draw a line over the map.
After the creation of the line, right click and select properties.
On tab called Vector_lines, select freeway_Traffic_line. Now it's possible to select the number of lanes and the direction.

NOTE: It's necessary to draw both directions of the traffic, so one line for each direction!
Now that you have all the lines (vectors), you select all off them and then File -> compile BGL.

The bgl file will be saved at work briefcase inside of Sbuilder folder, or something like that!!!
Add the bgl to P3D and enjoy!!


!!EDIT: I wonder if P3D allows one lane only for traffic, because Sbuilder does not have that option. Or one vector with two lanes with opposite traffic directions.

Br.
Mário C
 
Last edited:
#13
Hi

Yes it is.

You draw a line over the map.
After the creation of the line, right click and select properties.
On tab called Vector_lines, select freeway_Traffic_line. Now it's possible to select the number of lanes and the direction.

NOTE: It's necessary to draw both directions of the traffic, so one line for each direction!
Now that you have all the lines (vectors), you select all off them and then File -> compile BGL.

The bgl file will be saved at work briefcase inside of Sbuilder folder, or something like that!!!
Add the bgl to P3D and enjoy!!

Br.
Mário C
I will give it another go, i did try that method by nothing was working. Can i lay Vector lines for traffic over vector lines for roads?

Thank you in advance
 
#14
Hi

Yes it is.

You draw a line over the map.
After the creation of the line, right click and select properties.
On tab called Vector_lines, select freeway_Traffic_line. Now it's possible to select the number of lanes and the direction.

NOTE: It's necessary to draw both directions of the traffic, so one line for each direction!
Now that you have all the lines (vectors), you select all off them and then File -> compile BGL.

The bgl file will be saved at work briefcase inside of Sbuilder folder, or something like that!!!
Add the bgl to P3D and enjoy!!


!!EDIT: I wonder if P3D allows one lane only for traffic, because Sbuilder does not have that option. Or one vector with two lanes with opposite traffic directions.

Br.
Mário C
Oh forgot to ask - what does F and T stand for in the direction?
 
#15
Hi

I only created traffic for photoreal, so I never tried over road vectors.
Yes that letters is for traffic direction, if I'm not wrong.

Don't forget to select all the lines before compile. The only option that will be available at compile window is Terrain vector.
 
#16
So i have tried the above. But there is no moving traffic. It is creating CVX file which i have placed in the addon file in p3d. But no traffic is showing in the sim

Question:
1. Does the width affect i have set it at 15
 

rhumbaflappy

Moderator
Staff member
Resource contributor
#20
The above screenshot shows raster compilation (photoreal). Traffic is vector (shp2vec). Also the above are not errors, they are warnings and will be ignored by resample. Are you selecting the lines before trying to compile them?
 
Top