• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

No reflection P3D V4 PBR

I'm trying to create some PBR models for P3D v4 & v5 but I noticed the model does not reflect in v4 but reflects perfectly in V5 what could be wrong ? I attached screenshots from both sims.
 

Attachments

  • 2020-10-18_21-19-45-704.png
    2020-10-18_21-19-45-704.png
    1.9 MB · Views: 12
  • 2020-10-18_20-44-26-729.png
    2020-10-18_20-44-26-729.png
    2.2 MB · Views: 12

Pyscen

Resource contributor
I assume that you are including the windows as part of the PBR texture. If this is so, you will need to have it as a standard texture ( as in FSX ) and not a PBR texture.
 
So I tried the FSX Style and I got the reflection working perfectly using specular map. I am just wondering why the PBR Reflection work in v5 and doesn't work in V4.
 

Pyscen

Resource contributor
Because in P3D v5 uses the blue channel within metallic map for the enivironment or realtime enviroment in conjunction with the alpha channel of the albedo map. P3D v4.5 doesn't have use of the blue channel within in metallic map even when the alpha channel in the albedo map is used.

Basically the blending mode is the problem in v4.5. For some reason opaque and translucent modes can not be used on the same texture.
 
Last edited:

Pyscen

Resource contributor
Just a suggestion... I don't know for sure but mask in the blending mode might work? Again, I'm not sure.
 
Top