FSX:SE Please Help Me fix this problem

#1
When I try to load my ADE (Created or Edited) Scenery In FSX it crashes At 6% And I don't know what to do please watch this video to visually see it.

here is the .ad4 files,
1. EGWL_ADEX_LD.ad4 was the last one I tried and is in the video
2. EGLW_ADEX_LD.ad4 was the first one I tried but failed to load
 

Attachments

Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Please attach the project file (. ad4 extension) to a post here so that we can check it.
 
#7
It works here, but the real EGLW should be London Heliport. I guess that you're trying out ADE in the ocean. Nonetheless you obviously ignored the excellent manual as there are lacks that would have been more obvious on land. Furthermore, the function "Fault finder" is your friend. Look around here and you'll find tons of useful stuff.
 
#11
There is something weird with EGWL_ADEX_LD.bgl. It cannot be read by ADE nor by Bgl2Xml.

It doesn't crash FSX-MS but doesn't display.

Which version of BGLComp did you use to compile it? I have a feeling that it was from P3D-V4 and not from P3D-V1.4.

Edit. AFX reads it partially, parking spots, taxi-nodes and start points.
 
Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#12
EGWL displays fine for me. I do not know what is happening with EGLW since the user aircraft is placed next to the Thames for me but the airport itself seems somewhere else and the elements do not display. One obvious oddity is that the airport elements are at a distance from the ARP - airport reference point. Good practice is to have the ARP at the center point of the airport - this is the way it should be in real life according to ICAO regs.

Not sure what version of ADE you are using George but the current version opens both EGWL and EGLW. You may be right though that at least one airport was compiled with the v4 compiler - that would cause issues with older versions but should throw an error.

The bottom line on EGLW is that there is something wrong with it. Can't say what at the moment. You might want to consider redesigning it with the ARP at the center of the airport. Also have you added any helipads - not sure why they appear as a heliport.

EDIT
See below I found another EGLW in my FSX installation which was delivering the heliport.
 
Last edited:
#13
I am using the XP version of ADE. However, AFX does open the BGL but it soesn't read the runway, taxi-links or aprons.

I have no problem with the ad4 files which compile and display correctly.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#14
You are right George. I found another EGLW created by ORBX which was the heliport I was seeing. Removed that and the EDLW presented here compiles and displays correctly for me.
 
#19
Sorry if I did use the p3d BlgComp. Its just that I.. got frustrated with this issue. :banghead:
Besides, the original BglComp didn't work ether.
 
Last edited:
#20
As I already wrote, no problem here (why ever). I'm on FSXA only. However, I'm wondering whether the doubled ICAO might cause the error (an infinitesimal small difference might cause strange effects - or not. Chaos Theory... :duck:).
 
Top